Question about Metabo Saws

Open Question

Metabo we 14-150 plus 6" angle grinder. as soon as I plug it in the red light comes on and it will not run.I already replaced the brushes. cleaned up the commutator with scotchbrite.

Posted by on

Ad

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 31 Answers

SOURCE: not getting enough power?

brushes or bearings worn out

Posted on May 15, 2009

Ad
brewerstool
  • 141 Answers

SOURCE: Carbon brush sizes

They are exactly the same brushes. Part number 316041640 .

Posted on Sep 15, 2009

heatman101
  • 43501 Answers

SOURCE: sparks are coming from my metabo w6-115 angle

Hi,
The brushes are shot and need to be replaced...

You should be able to buy replacement parts here

heatman101

Posted on Jul 16, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Sparks are coming from my metabo w6-115 angle grinder where the bushing are and it seems to be grinding a bit


There are always some sparks with power tools from the brushes.
You should remove the brushes for inspection to check wear.
Be sure to reinstall in the same direction.

Jul 16, 2011 | Metabo 06204 4 1/2" 900W Ang Grinder

1 Answer

How do you remove and release the quick grinder pad?


There is a button at the front of the grinder usually black or red, depress it lightly and rotate the wheel (unplug grinder please) wait until you feel it fall into spot, depress tightly and hold then turn wheel and unscrew to replace pad. Reverse to reassemble.Good Luck....

Apr 21, 2011 | Metabo ® 12 Amp 9000 RPM Model WE14150...

2 Answers

Grinder doesn't start everytime the switch is pushed on and the light at the base of the tool comes on. What could this be ,the grinder is several years old.


that is a service tool light and more than likely the brushes are worn and need to be replaced, make a wiring diagram before removing anything, you can get parts from ereplacementparts.com, you would need your brand and model number. Let me know if you need more assistance

Jan 29, 2011 | Metabo 01451 We14 150 Quick Electronic 6...

1 Answer

Grinder runs about 2 minutes then shuts off. I replaced the heat sensor- no change. What else could be the problem?


check the condition of the brushes, make sure not sticking in the brush tube and also look at the commutator for a really dirty surface.

Dec 21, 2010 | Metabo 01451 We14 150 Quick Electronic 6...

1 Answer

Carbon brush sizes


They are exactly the same brushes. Part number 316041640 .

Sep 15, 2009 | Metabo WE14-150 Quick Angle Grinder

1 Answer

Magnetic brush size


Yes and no. From 1999 to early 2008, excluding the slightly beefier "Ergo" models, the size / part number is the same. However, on the newest models there are differences in density between some models. Wire placement is different from the older models.

Sep 13, 2009 | Metabo WE14-150 Quick Angle Grinder

3 Answers

Just replaced the brushes in a Metabo WE14-150Quick Angle grinder


when you replaced the brushes did you notice the tool throwing sparks? Generally when I work on these after replacing the brushes I have to clean the commutator to seat the new set. You could also have other problems, e.g. bad brush holder (did you replace as assembly or just brush) Let me know what happened to the first set and if when you plug in and try it does it come up to full speed.

Sep 12, 2009 | Metabo WE14-150 Quick Angle Grinder

2 Answers

Hello, my Metabo WE14-125 won't work anymore, there's a small red flickering light on my machine and I don't know what it means! At first I thought it were the carbon brushes, so I changed them, but the...


The light is an overload indicator that should come on when the tool is really hot. Internally, a sensor monitors the motor temperature and when the motor becomes too hot, tells the electronic to limit the voltage to the motor. This causes the tool to feel like it has no power. It should be run no load until it cools off, the LED goes out. The tool should have full power again.

If the light is on continuously, even when cool, and it doesn't run, get the tool to an authorizied service center; it may need a new armature. You can find your closest service center here:
http://www.metabo.us/Service-Centers-USA.5317.0.html?&no_cache=1

May 17, 2009 | Metabo W14 125 Ergo Angle Grinder 5"

Not finding what you are looking for?
Saws Logo

Related Topics:

48 people viewed this question

Ask a Question

Usually answered in minutes!

Top Metabo Saws Experts

Vernon Taylor

Level 3 Expert

3662 Answers

Spud Howell

Level 2 Expert

57 Answers

JOHN LAPIER

Level 3 Expert

2428 Answers

Are you a Metabo Saw Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...