Question about Legacy LA1478 Car Amp

1 Answer

The light comes on but little sound comes out

Everythings hooked up right and lights come on. the only way you can get a little bit of sund of it by hooken the speaker wires up to both posative on the amp

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 9 Answers

Theres a chance you may have blown up the amp. never put a sub that is to strong for the amp because its pushing all of the energy out of the amp to power up the sub, causing the amp to blow a fuse or the channels, on the back there is control of frequency turn everything all the way up to see if you can even get it to thump hard but dont blow your sub if it pops turn down some stuff and check the head unit to where its fading to the front or rear and balance to left or right

Posted on Jul 27, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Power light is on but no sound


verify circuit breaker or fuses. check mute toggle if equipped with mute.

Nov 27, 2013 | Pioneer VSX-D510 Receiver

1 Answer

Won't run but makes sunds


the sounds and light are from a different battery source, lift the seat up and make sure the battery under the seat is plugged in

Dec 26, 2012 | RC Thomas the Tank Engine

1 Answer

98 Chevy K1500 that the daytime running lights won't come on, I've tried the control board under the dash, fuses are good. I also tried the relay in the fuse block. The green light in the dash comes on but...


Sounds almost too simple but have you checked the wiring to the parking brake. If it is depressed enough to light the brake light in the dash the DRL's will not light or if the wires are not hooked up same problem. You also state you have checked the control board under the dash I assume you are talking about the Diode an aluminium finned box a little bit larger than a deck of playing cards under the dash on the right side of the steering colum at the swell in the dash. remove this diode and insert a shunt in the connector and see if those babies light up if so its the diode

Apr 05, 2010 | 1996 GMC Yukon

1 Answer

Its on over current


when the overcurrent light lights up, this means the amp is being run too hard or too loud. try cutting the gain back a little. i always hated putting in the sony amps that had those lights on it. it seems that when you turn it up and get it sounding good the light comes on.... if the overcurrent light is on all the time and it doesnt make sund....the amp could be bad. good luck.

Dec 17, 2009 | Sony XM-754SX Car Audio Amplifier

1 Answer

Computer worked fine, unhooked it to hook up a new one, decided to hook the emachine back up to play games on, got it hooked up but it won't come on now. everything is hooked up right, i opened it up and...


make sure you hook everything with a little force especially the memory until it snaps back into place. same goes for all the cards. care should be give to the cpu, nice and easy. make sure your power supply is potential enough or has not gone bad. The MB can give a green light but there could be too little energy for the whole system.

Mar 27, 2009 | E-Machines Emachine T5026 power supply **...

1 Answer

Protection Light Comes on


Sounds like you have an ohm problem, Tryy hooking the positive from one speaker to the negative on the other speaker. Then hook the negative from the first speaker to the negative on your amp and the positive from the second to the positive on the amp this will drop your ohm load and the amp should stop going into protection.

Mar 08, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Rockford Fosgate P3002 Amp


what are the color of the lights that stay on.red= protect/ green=on.if the amp has little sound it probably still working,check deck output volume(rca)

Aug 22, 2007 | Sony Xplod XM-554ZR Car Audio Amplifier

Not finding what you are looking for?
Legacy LA1478 Car Amp Logo

51 people viewed this question

Ask a Question

Usually answered in minutes!

Top Legacy Car Audio & Video Experts

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

xxxxxx xxx

Level 3 Expert

4874 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Legacy Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...