Question about Car Audio & Video

1 Answer

Orion amp will not work!

The amp just stopped working one day.So i took the panel off and hooked it back up again. Then i noticed the the red light would blink on and off, and the fan inside would also work but not really. It would slowly pick up speed as the power light would blink until i herd a click sound and the hole process would start over again. The click noise would happen every 30 seconds. I want to try to fix the problem so if any one that knows why its doing what is doing please tell me what i need to fix the problem.

Posted by on

  • phantom007 Nov 25, 2007

    It is the orion 8004 model.



1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

What model Orion?

Posted on Nov 25, 2007

  • Perry Babin Nov 25, 2007

    When you mentioned the fan, I thought it might have been an older model like the 2100 HCCA or the 2250SX.

    While I'm not familiar with your amp, it sounds like it may be going into protect. You should check the B+ and remote voltage to make sure it's not dropping below 11 volts. If it's not dropping, try disconnecting all speaker wires from it. If it's still doing the same thing, it's likely that the output transistors have failed.



1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

I have a Kenmore Elite Front load washing machine, the control panel has no lights going to it

Perhaps a good spraying with contct cleaner will FIX it at least for awhile .

Dec 31, 2014 | Kenmore Washing Machines

1 Answer

Sony xplod amp won't work it stopped for no reason

try hooking the amp up with 3 wires, the red power wire, the black ground wire, and the remote wire, do not hook up the speakers at this time

Apr 25, 2010 | Car Audio & Video

1 Answer

1995 Pathfinder Will Not Start

try removiing the lights again and then unhook the battery for 10 minutes and then hook it back up you could have affected the vehicles ats when the lights shorted and unhooking the battery should reset this problem

Mar 03, 2009 | 1995 Nissan Pathfinder

1 Answer

Sx 2150 one day it stop working this amp. is 17 years old help me

here is the contact details for the company...

For Technical Support: dotted_line.gif Phone: (800) 876-0800 x 2032 Fax: (760) 599-1380 E-mail:

Jan 23, 2009 | Orion Car Audio & Video

1 Answer

Car Amp

i'd try looking at the remote wire

Dec 13, 2008 | Rockford Fosgate Punch 300S Car Audio...

1 Answer

Orion 12000

the speaker out let on back of speaker box went bad and burnt the circuits in the amp

Mar 15, 2008 | Car Audio & Video

1 Answer

Pt- red light on

mine done that the other day and i took the fuse out of the side of the amp for about a minute put it back in and came on dont know why it worked but it did hope that helps you l

Aug 25, 2007 | Performance Teknique ICBM-9560 Car Audio...

1 Answer

Wiring for 2500d orion amp

ground wires(heavy black)is connected when the red light no need check the red hot wire which is connected to battery terminal maybe loose.or theres no power comming in.thre are 2 hotwire in that amp one is red which is the main and yellow or sometimes orange which is the remote on. now if you sure that the power terminals is properly connected,ur speakers is working and input wires are good and still no sound. your amp is probably not try experimenting the wires or hook up two amp by any means..u might destroy all ur amp. hope this help u....

May 11, 2007 | Orion 2500D Car Audio Amplifier

1 Answer

Subs stopped working & protect light on the amp is red...

well at this point i would say it is both,, the subs fried because your amplifier passed dc [direct current] and fried the voice coils on your subs....return them if they are under warranty,, the amplifier sound like you either operated it beyound its specifications or it has a defective output stage allowing it to pass or leak turned the voice coils into the equivelent of the runners in a toaster oven....when an amp passes dc it is going to do so to whatever speakers you hook to either bring it to a shop to be fixed/ return it to place purchase for exchange or throw it away.....or you will continue to experience the same problems....I am the amp goes into protection when it detects a short...[ the short is produced by the amp and it is detecting its own fault and putting it in to protection after it BURNS up your drivers....

May 16, 2007 | Volfenhag ZX-4712 Car Subwoofer

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

712 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4905 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers


Level 3 Expert

78010 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides