Question about Sony Xplod CD Player w/MP3 Playback CDX-GT50W

1 Answer

Sony cdxgt50w car cd player

Will not work at all! The 10amp fuse is not blown, and I am 100 percent sure that power is getting to the unit. Still it acts as if it is not hooked up whatsoever. I would like to fix it without buying a new one. Please suggest ideas

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that gotĀ 5 achievements.


    An expert that hasĀ over 500 points.


    An expert who has answered 200 questions.

  • Expert
  • 231 Answers
Re: sony cdxgt50w car cd player

If you are sure power is going to unit,There is a strong possiblity you have a burnt trace , main harness solder joints bad or shorted reverse polarity protect diode on main board .Also make sure you have power to both MAIN power (RED) and STANDBY POWER ( YELLOW) AND of course a good ground on radio chassis..

Posted on Nov 29, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Sony xplod drive-s cdx-gt31w power comes on but no sound comes out of speakers

your sound ic is blown if you can get hold of an amplifier connect it to your deck and if you get sound out of it then your sound ic is surely blown and will need replacing

Jan 01, 2014 | Sony CDX-M10 Car CD/ MP3 Player

1 Answer

Im hooking a cd player into my 93 toyota pickup ive got the ground and the power hooked up but nothings happening what the deal

A fuse may be blown inside the unit. Before you install it, check its' operation with an external power source (12 Volts DC) to make sure it works first. If it doesn't power-up, check the fuse inside.

Nov 02, 2010 | Pioneer DEH-15 CD Player

1 Answer

The unit keeps blowing the fuse in the cars fuse box(10amp), the unit then does not work or display anything, but it still ejects the cd and takes it back in.

you have a short or the wrong amp fuse how can it eject or take it back in if the fuse is blown??? unless there is a secondary fuse somewhere is it wired into the accesory fuse it is possible it is wired into a spot that may have something else hooked in and your deck is overloading the fuse check to see that you have it so it is the only unit wired to a fuse

Dec 28, 2009 | Sony CDX-L350 CD Player

1 Answer

When i press the source button it will not change to cd and when i press the eject button the cd will not come out

On my CDX-GT20W, when it would not change to Aux input, I had to remove the faceplate and press the reset button to Reset the unit. The reset operation put everything back to factory defaults....which meant reprogramming all station presets, however, the entire unit functions as new. Hope this helps. Page 4 covers this.

Sep 29, 2009 | Sony Xplod CD Player w/MP3 Playback...

1 Answer

I have power going to the unit yet there is no display,a sony cdx-gt220,i know i have power because it is loading and ejecting cds yet no display.please help,its doing my nut in!!!!

I have a Sony CDX GT 530U. I had a problem with no display and I thought no power period. I did not try to install a CD, so maybe I did have power to the CD motor but no display. This was frustrating because I could get the old factory Nissan radio to power up and work so I thought I had a dead Sony unit. After a lot of monkeying around, I discovered I had blown a fuse while installing the unit (you should disconnect the negative terminal of the battery when installing the radio... which I thought I skip, that was a no no.). I had checked the auto fuses, those cheap little plastic fuses behind a panel below the stearing column inside most cars, at least all the fuses I thought went to the car stereo. Turns out I missed one that was labeled "Batt" or something like that, which was the constant power wire to the car stereo. There was another fuse for the Accessory power to the car stereo (the main juice went the key is tuned to ACC or Start position). Turns out the Sony unit display runs off the constant power, or at least the unit on/off button runs off the constant power wire, so even though the ACC power wire was live, the Constant power wire had a blown fuse and the unit would not turn on. Check all your fuses inside the car, I bet that's your problem. Constant power on my Nissan Sentra was a 7.5A fuse, while the ACC power ran off a 15A fuse, but your vehicle may vary. Good luck.

Jul 16, 2009 | Sony Xplod Car Audio CDX-F7810 - CD/MP3...

1 Answer

I had to disconnect the power wire to my KDCpmp435U, there is power going to the stero but the deck will not power up

are you 100 percent positive that there is power going to the stereo, i have installed for years and sometimes i suprise my self on little things i miss,
check the fuse at the back of the deck make sure the fuse didn't pop
and check the fuse in your car fuse box to make sure you didnt pop that one either, write me back if these still arent the issues

Jul 02, 2009 | Kenwood KDC-MP435U CD Player

1 Answer

JVC KD-G140 Chevy s10 problem

Your headunit is getting constant power (yellow wire). You most likely have no switched power (acc red wire). You can be certain by testing the red wire w/ a 12 volt test light when your ignition is on. If there is no power to this wire then you probably have a blown fuse. The radio fuse should be a 10amp fuse located in the drivers kick panel.

May 28, 2009 | Pioneer DEH-2000MP MP3 CD AM/FM Car Stereo...

1 Answer

No power to front panel but have power to main unit.

You Have constant power (yellow wire) but your Acc wire or switched power wire (RED WIRE) does not have power. Check the connection of this wire. You most likely have a blown fuse in your vehicles fuse panel.

May 19, 2009 | Sony Xplod CD Player w/MP3 Playback...

1 Answer

Got a new Kenwood KDC-128 car radio recently, fitted it but the radio presets would not stay when the ignition was turned off. Then it stopped working altogether and I noticed the 10amp fuse at the back...

you need to hook the yellow wire off the back of the radio up straight to the battery this keeps memory power to the head unit then wire the wires in color coded sequence red to red black to black so on and so forth if this doesnt fix it you might want to think about replacing head unit

Jan 02, 2009 | Kenwood KDC-128 CD Player

1 Answer

Pioneer deh 1600 has no power

Well.. if there is smoke coming from the head unit, the head unit could be bad. It odviously may have a wire crossed or a fuse blown, or even the wire harness could be bad. First, check the fuse for the radio on drivers side door, then check the other fuse box under the hood. Make sure all radio fuses are intact and not blown. Second, check behind the head unit to make sure no wires are touching each other and shorting out. Third, if nothing else helps, buy a new head unit & wiring harness :]

hope this helps!!!

Jun 12, 2008 | Pioneer DEH-1600 CD Player

Not finding what you are looking for?
Sony Xplod CD Player w/MP3 Playback CDX-GT50W Logo

Related Topics:

130 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Audio Receivers Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

286 Answers

xxxxxx xxx

Level 3 Expert

4681 Answers

Are you a Sony Car Audio Receiver Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides