Question about Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

1 Answer

I have good suction at brush, but no suction in hose connection

I have checked all ducts and there is no obstruction.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 97 Answers

I would change the bag and under the bag there is a filter, if dirty wash and make sure its completly dry before putting back into machine. once all done, have machine in upright position, turn on and see if there's sucktion at hose. hope this helps

Posted on Jul 29, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Riccar 8995 no suction


If it's been over a year since you've replaced the belt that is the first place to start. Stretch belts lose elasticity and will still turn the brush roll but when the brush roll is lowered to the carpet it may not turn fast enough to pick up properly. If you have good suction at the end of the hose check to make sure there is not an obstruction in the tube where the hose goes into the bottom of the vacuum to the brush roll. Make sure your filters are replaced at least once per year and the bag is not full or has a lot of fine powder dust in it which can clog the bag.

Jun 13, 2014 | Riccar 8955 Upright Vacuum

1 Answer

My hose no longer works no suction buth the vacuume still works how do i fix I checked the hose checked the filters nothing works to get my hose so it has suction.


Check the following after unplugging the power cord from the outlet.
- Check for suction at the back of the unit, after removing the hose where it attaches to the back of the vacuum. If there is NO suction, the machine will need to be taken to a local Service Center for inspection.
If there IS suction at the back of the machine with the hose removed, please check the following:
Unplug the unit from the outlet.
- Check the Pre and Post-Motor filters for debris. Dirty filters can restrict airflow. The pre-motor foam filter is square and located in a pull out tray underneath the dirt cup. The foam filter may be hand washed in cold water with mild detergent. Reinstall the filter when it is completely dry. The post-motor HEPA Media filter is rectangular and located on the side of the machine. Note: The white HEPA Media Post-Motor Filter is not washable.
- Ensure the dirt cup is empty.
- Check the upper tank for build up or clogs.
- Twist the inner cyclone to the left and pull down
- Wipe the inside of the upper tank and separator plate with a
damp cloth moistened with water or mild cleaning detergent.
- Once the inner cyclone is dry, lock back into the machine by
pushing up and turning to the right.
- Put the dirt cup back in
- Check for good suction at the end of the upholstery hose. If there is good suction, make sure the hose is firmly connected to the lower hose on the back of the vacuum. If there is no suction at the end of the hose, check the hose for splits, cracks or clogs.
- Make sure the brush is rotating. If it is not, remove the access plate and examine the brush, and belt for damage. The access panel can be removed by lifting the 4 tabs located at the bottom of your machine. Lift tab 1 then 2-4 tabs to remove the access panel.

CLEARING CLOGS
- Detach the upper hose from the machine. Insert a broomstick into the hose to push any obstruction through to the opposite end.
- Remove the screw from the left side of the lower hose on the back of the unit, and straighten this section of hose by pulling it down or lay the unit out flat, and roll the unit on its side with the lower house towards the top side. Look through the hose for any obstructions. Push a broom stick through the lower hose to unclog.

Aug 12, 2010 | Bissell Upright Vacuum - The Pet Hair...

1 Answer

No suction?


-Check to make sure the dirt cup is empty.
-Check the filters, If your filters are dirty they can restrict airflow.
The black filters only may be hand washed in cold water with mild detergent, re-install filters when they are completely dry.
-Check for good suction at the end of the upholstery hose. If there is limited suction from the upholstery hose detach the hose from the machine. Insert a broomstick into the hose to push any obstruction through to the opposite end.
-Check the lower hose for clogs. Remove the screw from the left side of the lower hose on the back of the unit and straighten this section of hose by pulling it down or lay unit out flat (the detent will need to be pushed twice) and roll unit on its side with the lower hose towards the top side. Look through the hose for obstructions. Push a broomstick through this lower hose to unclog.
-Check brush belt and replace if broken.

Aug 03, 2010 | Bissell 6594 PowerForce Bagless Upright...

1 Answer

No suction in hose


Remove the machine side of the hose--is there suction at the machine? If so, run a broom handle or similar through the hose to dislodge the clog. If no suction at the machine, you may need to fish out debris with a hooked stiff wire from the port. Remove the bag and examine the port area underneath for similar clogging. Finally, check the brush area underneath the machine bottom plate for more obstruction. Also, check the brush assembly for debris accumulation. Remove the drive belt and check for free turning of the brush. If turns hard, remove the brush, clean the bearings and roller pins, then apply a small quantity of light oil like 3-1 or sewing machine oil. Hope this helps!

Jun 20, 2010 | Lindhaus 380 Diamante Bagged Upright...

1 Answer

Low suction


Check the tube that leads down to the brush head for clogging as well as any motor or HEPA filters. If that still shows nothing, take the cover off the brush head (like you're changing the belt) and look for obstructions in there. Usually, if you have low suction on the accessory hose, the problem is with a motor filter, HEPA filter, or a clog where the hose goes into the unit. If you have good suction on the accessory hose but none on the floor, it's usually in the brush head (clog or broken belt) Good luck

Feb 28, 2010 | Dirt Devil Vision Turbo W/Bonus Upright...

2 Answers

Kenmore progressive 360 vacuum cleaner has low suction


Check the tube that leads down to the brush head for clogging as well as any motor or HEPA filters. If that still shows nothing, take the cover off the brush head (like you're changing the belt) and look for obstructions in there. Usually, if you have low suction on the accessory hose, the problem is with a motor filter, HEPA filter, or a clog where the hose goes into the unit. If you have good suction on the accessory hose but none on the floor, it's usually in the brush head (clog or broken belt) Good luck

Feb 28, 2010 | Kenmore 35912 / 35913 Progressive Upright...

1 Answer

No suction


Check the tube that leads down to the brush head for clogging as well as any motor or HEPA filters. If that still shows nothing, take the cover off the brush head (like you're changing the belt) and look for obstructions in there. Usually, if you have low suction on the accessory hose, the problem is with a motor filter, HEPA filter, or a clog where the hose goes into the unit. If you have good suction on the accessory hose but none on the floor, it's usually in the brush head (clog or broken belt) Good luck

Feb 28, 2010 | Euro-Pro EP602 Bagless Stick Cyclonic...

3 Answers

The machine will not suction - it will spray and spin the brushes but will not suction - the power is going to the machine, but it will not suction.


Disconnect the suction hose. While running, check the suction port if it works, by putting a piece of paper. If the paper is taken in, then it is oK. Now, check the suction Hose for breaks or opening before the suction head. Breaks or opening breaks the suction power at the suction head. Loose connection between the suction pipe and the suction port also must be check as this will also cause the same
problem. You may need to replace the suction hose
to correct this problem,
Send us the e-mail and your vote if this solves your problem.

Sep 27, 2009 | Eureka Atlantis 2590A Wet/Dry Vacuum

1 Answer

Suction is so light when using attachments will not pick up anyth


If there is no obstructions, its probably the motor has burnt out or shorted, causing loss of suction. Good luck.

Aug 28, 2009 | Dyson DC14 All floors Bagless Upright...

1 Answer

I have good suction at brush, but no suction in hose connection.


Please unscrew the hose connection to the back panel. Is there suction there while in the upright locked position? If so, visually check the hose inside for obstructions.

Jul 12, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

Not finding what you are looking for?
Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum Logo

Related Topics:

74 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18390 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1456 Answers

Brad Brown

Level 3 Expert

15478 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...