Question about Car Audio & Video

Open Question

One channel on my pdx-v9 amplifier is not working, what do i check

Posted by on

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I had my stereo up, not all the way, and my sub went out mysteriously. I am running the pdx 1.100, runs 12" sub only. I have power, checked all connections, everything appears to be fine. Any ideas on...


check the fuses, take and ohm meter (multimeter) and read out the sub. check your rca output at the head unit with some earphones and an rca to earphone adapter.

Aug 09, 2010 | Alpine PDX-1.1000 1000W x 1 Car Amplifier...

1 Answer

Alpine amp not working.


possably, did you get it professionally fitted? they have lifetime warranty on install,

Apr 22, 2010 | Alpine PDX-1.1000 1000W x 1 Car Amplifier...

1 Answer

Alpine pdx 1.000 keeps cutting out


You are going to want to make sure all your power wires and grounds are 4 gauge as well as the wire leads to and from the capacitor-4 gauge also. make sure you have a very good ground - the power wire from the battery should hit a distribution block-from the dist. block a 4 gauge should go to the capacitor another 4 gauge to the mono amp and another to the 4 channel amp -every component should have a good solid ground even if you have to bust out a grinder and a drill and some self tapping sheet metal screws and go nuts on it- see if that helps you

May 26, 2009 | Alpine PDX-1.600 Car Audio Amplifier

1 Answer

Alpine pdx 1.600keeps cutting out


you need more batt, more amps, try new batt, capacitors are paperweights, spend on good batt.

May 14, 2009 | Alpine PDX-1.600 Car Audio Amplifier

1 Answer

Alpine PDX 1.1000 low power output - sub not loud


system not configurate properly go to a pro and let them do for you you have good equipment just need to put together rite.for wht you have you can get better sound than that,,good luck

Mar 30, 2009 | Alpine PDX-1.1000 1000W x 1 Car Amplifier...

2 Answers

Channel 2 crackles


Make sure your speaker wiring does not come close to the 12v power cable running for your amplifier. If your amplifier's 12v power cable runs on the drivers side of the vehicle, run your speaker cables on the passengers side and make sure your tweeters have a high pass filter to stop any pickup of engine sound (When you are driving you *WILL* notice it at high RPM. a HPF (High Pass Filter) will also stop those nasty hissing sounds on S's.

Feb 11, 2009 | Alpine PDX-4.100 Car Audio Amplifier

1 Answer

Alpine PDX-4.100 3ch operation


use channel 1 and 2 as normal, use the positive from channel 3 and the negative for channel 4 as mono 1ch, your bridged output on the mono chan should be around 200watts at 4ohms.

Nov 25, 2007 | Alpine PDX-4.100 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

33 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4834 Answers

yadayada
yadayada

Level 3 Expert

74896 Answers

The Knight
The Knight

Level 3 Expert

73591 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...