Question about Hoover Vacuums

2 Answers

Hoover platinum check bag will not go off. changed bag and cleaned vac

Posted by on

Ad

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Welcome Back:

    Visited the website for 2 consecutive days.

  • Expert
  • 42 Answers

Get a Kirby

Posted on May 03, 2017

Ad

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Hoover Master
  • 76,649 Answers

Check the hose for carpet fiber, it may be starting to plug.

Posted on May 02, 2017

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Bag light wont turn off


Hi there! The vacuum may be still sensing dirt in the cleaner. Try wiping the area down in and around the bag port. Be sure you are replacing the bag with a genuine Hoover Type Q bag. Also, when assembling the bag remember to slide the red bag door lock to the right to lock it on. If the check bag indicator light still comes on there may be an issue with the sensor on the vacuum. We would recommend taking your vacuum in to a Hoover authorized service center for repair. Hope this helps! Service Center Locator

Sep 13, 2014 | Hoover Platinum Collection Upright Vacuum

1 Answer

I replaced the handle on my Hoover UH30010 Platinum Bagged upright and now the check bag light is on and vac will nut run.. Is there a reset button? How do I fix this?


Hey. I believe you will need to replace the main PCB board too. My new handle was sent with a new PCB board. However, I tried just replacing the handle first and it acted the same way you describe. Once I changed the PCB board it worked fine. Hope this helps.

May 25, 2012 | Hoover Ultra U6430-900 WindTunnel Bagged...

2 Answers

Hoover windtunnel dirt finder light stays red. We've cleaned the elbow the roller the hose and have a clean bag. The vacuum is new only had it for 3 months.


I'm not sure about a 3 month old vac, I'd probably go the warranty route. However, for the older vacs thy start getting false positives. The sensor is simply a microphone hooked to a computer chip detecting sounds of dirt entering the bag.
To rig it to start working, you'll need to remove the tool accessory tray and elbow that enters the back of the vac, and attached to the bag. This will reveal the microphone at the elbow, and wire that runs into the bottom area of the vac. When on, a large amount of air comes from the bottom screw and area where the wires enter. My fix was to clean up the microphone contact points a little bit with a screwdriver, and then leave the vac running while putting in dampering in the hole at the bottom, and around the back of the elbow. Cotton balls and electrical tape at the bottom hole, and napkins around the outside of the elbow (wedged between the back of the vac assembly and elbow did the trick). The schematic for the vac is here: http<colon>//www<dot>vacsrus<dot>com/CartGenie/pg_U6485900<dot>asp
Look for micrphone.

May 12, 2010 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Hoover turbo cyclonic only 12 weeks old stopped working while cleaning. I was using the hand tool and after about 3 minutes it just stopped and will not turn back on.


try changing the fuse in your plug ( uk ) if this fails to fix it , have it repaired under warranty
print-icon.gifPrint/Download




















Warranty The Platinum Collection Lightweight Bagged Upright plus Portable Canister warranty covers parts and service of the cleaner for six years.
As a member of the Hoover Platinum Collection, the Platinum Collection Lightweight Bagged Upright warranty gives the owner access to the exclusive Platinum Collection member services line for the best in customer service.
TTI Floor Care North America
7005 Cochran Road
Glenwillow, OH 44139
1-877-MY-PLTNM


Nov 15, 2009 | Vacuums

1 Answer

HOW DO YOU REPLACE THE BELT ON A HOOVER US140-900 WIDEPATH TEMPO VAC


To help you in your efforts to change your belt here are some good resources. This is the manual for your vacuum. It explains how to change the belt:

Manual for HOOVER U5140-900 WIDEPATH TEMPO VAC

Here you can get replacement belts for your models:


http://www.vacbelts.com/hoover-40201160-belt.htm

Oct 20, 2009 | Hoover S1410 WindTunnel Porta Power Bagged...

1 Answer

Poor suction (new bag, clean filter, clear hose)


check the impeller on the moter it may be missing a fin or two (question does it make any unusual noise or vibration ?)

May 01, 2009 | Vacuums

1 Answer

Hoover powermax s3530 spitting out dust


recently had same issue with friends. remove the filter and see the other thin filter there that goes to your motor compartment.. remove that and clean it. also check inside your tubes make sure not partially clogged.

Apr 17, 2009 | Hoover Powermax S3530 Bagged Canister...

1 Answer

Hoover Wind tunnel supreme, loss of suction


http://www.geeksquad.fixya.com/ThreadView.aspx?prdid=40600&thid=562967
Hoover Wind tunnel supreme, loss of suction
posted by bazballfan on May 01, 2008
Hello, I purchased two of these models in late 2007 and after changing the bags on each of them I have little to no suction with the vacuum. The hose is fine and I have taken them apart and there is no obstruction in the hose or in the base.
These worked so well and now they don't do anything. The bag isn't filling much and the simplest things can’t be vacuumed up
Please help me to fix this



Hello,
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure.
Hoover U5450-900 Windtunnel Supreme Vacuum
Sorry you are having a problem, it sounds lie you have done almost everything, but just in review it could be some of these problems:
Belt change – every 4 to 6 months
Are the brushes in good shape
Where does your suction drop off
Is the bottom plate securely on the bottom
Are there any gaskets that are broken or leaking
Is the bag installed securely
Did you check for any clogs or obstructions
Is the filter clean
Feel free to contact your local vac dealer in your area.
So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.
http://www.hoover.com Telephone
Contact our Customer Service Department at 1.330.499.9499
Monday through Friday
8 a.m. - 7 p.m. EST

Thanks, Don – The Vac Man
Go Ahead. Use Us.

May 01, 2008 | Hoover U5450-900 Windtunnel Supreme Bagged...

2 Answers

I have an old hoover turbopower approx 1986 i think its a U1102, the prob is it doesnt pick up anymore and i wondered if it had some sort of filter on it, ive cleaned all the tubes put new bag on but its...


http://www.geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=562013
Generic problem for all Vacuums
I have an old Hoover
Posted by badhoover on May 01, 2008
I have an old Hoover turbo power approx 1986 I think its a U1102, the problem is it doesn’t pick up anymore and i wondered if it had some sort of filter on it, I’ve cleaned all the tubes put new bag on but its still got weak suction, could you make any suggestions, thanks…

Hello,
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure.
The biggest thing on a Hoover Upright is the belt change and the brushes on the brushroll to be of good length, you said you did change the bag and sometimes if it is a hard shell vacuum there is a filter below the bag the needs cleaning or changing, if you have a soft shell or cloth outer bag, you can clean the inside the of the bag or replace the outside bag because even the pores of the bad lose it’s filtration such as your clothes will loosen up after you wash them a few times – the fabric is not as tight as it used to be. The belt change for a flat belt is every 4 to 6 months, and keep the extra belts in a Ziploc bag in the refrigerator. Also check for any bad gaskets that could be leaking, I may suggest a vacuum tune up @ you local vac dealer. So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.
http://www.hoover.com Telephone
Contact our Customer Service Department at 1.330.499.9499
Monday through Friday
8 a.m. - 7 p.m. EST

Don – The Vac Man
Go Ahead. Use Us.




May 01, 2008 | Vacuums

Not finding what you are looking for?
Vacuums Logo

Related Topics:

33 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18402 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1466 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...