Question about Saeco Coffee Makers & Espresso Machines

1 Answer

My coffee machine wont't turn on

Saeco Syntia HD 8836

Posted by on


1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that got 5 achievements.

    New Friend:

    An expert that has 1 follower.


    An expert who has answered 20 or more questions within one hour.

  • Expert
  • 65 Answers

Check the fuse in its plug for starters.

Posted on May 02, 2017


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

I have a Saeco syntia which I usually add beans, but have ground coffee and am not sure how much to add

If it's an espresso machine, you can find a manual at link. Use the scoop provided with the machine and add 1 scoop, no more than 2 scoops.
Visit the support page for your Saeco Syntia Super automatic espresso...

Oct 07, 2017 | Saeco Coffee Makers & Espresso Machines

1 Answer

Syntia swims in water in dreger drawer

Syntia is not set to "3 beans" amount or beans used are too large to create enough grounds to make a full 9 grams for a good puck .
The finger guard does not allow enough beans to grind in the timing of the software , common problem.... until the finger guard openings are made bigger or ... the software is re-programmed

Mar 05, 2014 | Saeco Syntia Espresso Machine & Coffee...

1 Answer

I have a Saeco Syntia and a Red Wrench with the #14 came on the display. I have turned on and off and now the yellow thermostat symbol comes up. you can feel it heating up but it does nothing else.

need to tell me when the wrench appears ,at start up ? YES? then most likely "over pressure valve" is broken and machine needs to be serviced by service center to replace the plastic part with a metal parts ,Stop using it or the leaking water will damage the system .

Jan 18, 2014 | Saeco Syntia Espresso Machine & Coffee...

1 Answer

Saeco syntia leaking out the bottom

Over pressure valve is broken, near the water pump , stop using it and get it fixed , or you may damage your Computer board

Nov 08, 2013 | Saeco Syntia Espresso Machine & Coffee...

1 Answer

Saeco syntia ground coffee chute not working well

The grind on the coffee might be too coarse and instead of making espresso its coming out like drip coffee because the water is running through it too fast.

May 25, 2012 | Saeco Syntia SS Automatic Espresso Machine

1 Answer

Water tank parts for saeco syntia

Don't know where you are but in the UK supply the parts.

Mar 02, 2011 | Saeco Syntia Espresso Machine & Coffee...

2 Answers

Saeco syntia - error message 'problems with the water circuit'

I read your post. Could you explain me this problem?
Me too have a syntia, but I never saw this error message.
What kind of symbol do you see?


Jul 11, 2010 | Saeco Coffee Makers & Espresso Machines

Not finding what you are looking for?

Open Questions:

0 Answers

Defect Saeco Odea Giro. Red exclamation flashing fast. Mashine is function only in service mode. A defect in Saeco Odea Giro. TYP 0310R ser. number. 9007SA40523803 Please help for repairing the machine. I bought the automatic coffee machine second hand. After unpacking, I discovered that someone was intruding into it cracked plastics and handles. By common check, I discovered the 1st fault - a broken piston catalog number 11003468. This is quite a common fault with these machines. 2nd defect leakage of the valve. Even one O ring was missing. I replaced all O-rings with new ones. Then I went over to check the individual sensors: Level sensor in the tank - OK Sensor closed coffee bean hopper - OK Sensor of closed door on the brewing unit side. - OK Sensor on the waste container - okay When I wanted to try switching on a microswitch that detects the presence of the brewing unit in the hole, I did not find contact. So I removed the wall behind the brewing unit and found that there were two microswitches near the toothed wheel. I checked their functionality. Both well. I assumed that one of them was not at his destination. The one with the green connector I supposed to indicate that the brewing unit is in place. I moved him to the top. I checked the state of the electric motor and lubricated the gear. I returned the wall back. Next, I ran the diagnostic mode and checked other components: a Boiler - Heats up b The pump - presses correctly and the green diode flashes during its operation and shows the activity of the flowmeter c solenoid valve - switches correctly d the grinder grinds and during its operation the green diode flashes and reveals the activity of the speed sensor in the mill e the brewing unit is moved to the top position and to the basic position without any problems Other things I've done: The whole coffee maker is cleaned, deep decontamination is performed using the diagnostic mode. Check the flow meter clean without oxidation. Check the tightness of all hoses. Both boiler thermostats are checked. Removed and thoroughly cleaned the mill. Despite this, the machine behaves as follows: Turn on the machine and fne the mill shaft. The red exclamation mark flashes very quickly. The green light of the boiler heating is not lit or flashing. However, the boiler is heating up properly. When I eject the tank water flow, the red exclamator lights up permanently. After the tank returns, the red exclamation mark will flash rapidly again and the green indicator the boiler is heated will light up properly. When switched on, the Indycatter does not light the cup. Only a drop of water drops and coffee beans lit up. Can not prepare coffee, can not refuel hot water. All this can only be done in diagnostic mode. In the diagnostic mode, I also de-aerated the machine. Both the nozzle and the coffee outlet through the brewing unit. Self-cleaning will not start. I do not know anymore, maybe there is a bug in the electronic panel. Will anyone advise me? Thank you.

Mar 09, 2018 | Saeco Coffee Makers & Espresso Machines

Coffee Makers & Espresso Machines Logo

Related Topics:

56 people viewed this question

Ask a Question

Usually answered in minutes!

Top Saeco Coffee Makers & Espresso Machines Experts


Level 2 Expert

75 Answers


Level 1 Expert

22 Answers

Shehu Pro
Shehu Pro

Level 3 Expert

1284 Answers

Are you a Saeco Coffee Maker and Espresso Machine Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides