Question about Vacuums

Open Question

My versacamm sp540v doesnt seem to have any vacuum working to pull the media down flat. i have been into the settings and set the vacuum at 100% but still vacuum not working. any suggestions?

Posted by on

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Eureka 9410 upright vacuum motor


They normally have a reverse thread nut on top then just pushed down on a tapered end so needs to be levered off normally a wide flat blade paint scraper etc can help spead load so fan doesnt break or distort

Apr 13, 2017 | Vacuums

1 Answer

The spin scrubs quit working all of a sudden while i was steam vaccuming my carpet, there is a little dog hair in there but it doesnt look like enough to completely clog it, how do i get them to spin...


(1) Assure the Brush Control on the hood is NOT set to the OFF position.
(2) Remove the brush assembly by pulling/unlatching it from base on each side.
(3) Does one of the brushes have the drive pin present? It should be about ¼ inch square, and two inches long. It attaches the brushes to the drive mechanism.
(4) Remove and clean the intake filter. One the base of the cleaner, behind the brushes, squeeze the two red abs together and pull the panel down to access the screen. Clean the hair/debris off the screen and reassemble.



Sep 20, 2009 | Hoover SteamVac F5914-900 SpinScrub...

3 Answers

Bissel proheat 2x main suction problems


bissel pro heat x2 does not suction up the cleaning fluid

May 25, 2009 | Bissell ProHeat Turbo Deep Cleaner Upright...

1 Answer

Cant seem to get the green light going on vacuum head,hook seems to be wrong way when its should be hooking the band off its doing the opposite


1)First, you turn the square belt lifter on the front of the power nozzle until the red arrows line up (belt off)
2)Remove the power head from the front of the machine. Now turn the belt lifter the other way and line the green arrows up again (belt on).
3)Turn it upside down and release the two clips that hold the metal baseplate on and remove the baseplate.
4)Grab the brushroll and pull it out of the power head. Slide the new belt onto the center of the brushroll. It will hang loose...it doesn't have to stretch around anything yet. MAKE SURE THAT THE BRUSHROLL SPINS FREELY!! If it doesn't, you'll burn all new belts quickly due to the added strain on the belt. New brushrolls are available here...  NEW KIRBY BRUSHROLLS
5)Look at the ends of the brushroll. The brushroll has three height settings...you should see notches AND  NUMBERS on the sides of the brushroll's end caps. ONE notch (also #1) FACE UP on BOTH sides is the first setting and should be used when the roller is new. Three notches is the last setting used before a new roller is needed and should be used if the brushes are short and worn. Put the brushroll back in, making ABSOLUTELY SURE sure that the SAME NUMBER of notches and the same raised number on the edge are FACE UP on BOTH sides. This is important, as the brushroller will be unbalanced if inserted wrong.
6)Replace the baseplate by fitting the front clips into place and then push it down in back and secure it with the two rear swivel clips. Make sure it fits securely down over the bumper on all sides with no suction leakage.
7)Turn the belt lifter to where the RED arrows line up, making sure that the inner "hook" grabs the belt and stretches it up while you are turning it. Once you have the belt stretched up, put the power nozzle back onto the Kirby and lock it in place.
8)NOW...turn the belt lifter back to GREEN. If the little green light on the power nozzle lights up when you turn it on, CONGRATULATIONS!!! The brushroll is spinning!!

Apr 18, 2009 | Kirby Ultimate G Bagged Upright Vacuum

2 Answers

Hoover WindTunnel Self-Propelled V Belt


when you released the end to slide the new belt on it allows the tension roller to slide into the wrong position. Remove the top so that you can see the roller, at the left side of the roller mechanism there is a screw, loosen it enough to allow the roller to return to the correct position.
good luck

Mar 23, 2009 | Hoover U6441-940 WindTunnel Bagged Upright...

1 Answer

Dyson vacuum brush roll doesn't turn


The brushbar should only turn when you meet two conditions:
1) When you step on the front of the machine and pull back on the handle (recline the machine in other words)
2) The dial is set to CARPETS

The brushbar shouldn't turn at all when it is set to the BEAR FLOORS setting.

To rectify the problem - call the Dyson Helpline so that they can refer you to an authorized dealer in your area - the repair dealer will inspect the dial and figure out why the functionality seems to be switched. They'll be able to fix it for you.

Mar 19, 2009 | Dyson DC07 All Floors Bagless Upright...

1 Answer

Hoover Windtunnel carpet level adjustment


The suction is so great that it sucks up your carpet, then nothing works. I get my children to stand on the corners/edges of the rug so that it stays perfectly flat on the floor while I vacuum. Or, you can turn off the brush roller (set it to "hard floor" setting). Or, tip the vacuum cleaner's front up slightly while vacuuming, to reduce suction.

Oct 28, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

4 Answers

Nutone vx550c central vacuum


You ended chat so fast i guess that fixed ya ??

Aug 09, 2008 | Broan-NuTone VX475 Bagged Central System...

1 Answer

Brush roll wont turn


Might be that the the idler wheel is stuck and not engaging the V belt. If you look down just past the V belt you will see a black roller, it needs to be against the belt. It is either stuck or the asm. is broken.

Apr 16, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Agitator stops when sweeper is pulled backward


If you have made no changes to the vacuum's setup and are using it on same carpet you have previously used it on with no problem, then the most likely cause is the agitator/beater bar's drive belt is worn or on some models may have a tension adjustment which is set too loosely. This can also be caused by having the vacuums height adjustment set to low for the carpet or flooring you are using it on, causing to much drag when the vacuum is pulled backwards for the agitator to overcome.

The vast majority of agitators turn in a forward direction, as if it would pull the vacuum forward, when you pull the vacuum backwards the drag is increased.

So...First check height adjustment (a no cost fix), then check out the tension adjustment (if present on you model, some engage when top of vacuum is tilted back after stepping on the release pedal) Lastly, consider changing belt especially if you have had the vacuum awhile or if it gets a fair amount of use or it you seem to need to use it on a low height setting all the time to vacuum up debris.

Hope this helps!

Dec 19, 2007 | Kenmore 34923 / 34925 Progressive Bagged...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

23 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18389 Answers

D. Floyd Kolb
D. Floyd Kolb

Level 3 Expert

43501 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...