Question about SCOSCHE Car Audio & Video

1 Answer

Brand new system not working

Had my scosche scdbta60a hooked up by a professional and it's not working.all the wiring is right, power tested on all wires. Reset not funtioning when the faceplate is on. Only sign of life is a red light when I do a reset with the faceplate off.

Posted by on


1 Answer

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.


    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 5 Answers

Check your fuses.
Could be just a defective product...
but really check those fuses

Posted on Apr 25, 2017


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

Scosche SCDBTA60A when hooked up to the wiring in my truck will not power on the head come on when first plugged in and then shuts off

Believe me that is only the start of your problems, the unit is one of the most disappointing things I have ever bought, it doesn't work using a memory stick either using the buttons or the app it needs a complete rewrite of both firmware and software and Scosche tell me they are not rewriting either so tough luck!! Check other forums for other opinions but whatever you do don't buy it.

Mar 17, 2014 | Scosche Industries Car Audio & Video

1 Answer

Hey i have a scosche in-line fuse block i purchased. I haven't had any problems until recently. My fuse fried. So i bought more and went to replace it and every fuse i try instantly fries. i cant seem

Most likely the amplifier you have hooked up to that fuse position is defective and causing the fuse to blow. Or you have a short in the powerline somewhere. Disconnect the power wire from the amplifier, tape up the end so it won't short out to anything. Replace the fuse, if it doesn't blow then you will need to get the amp checked, if it does blow, then you have a short somewhere along your power wire.

Jan 30, 2014 | Scosche Industries Car Audio & Video

1 Answer

I recently wired a eonon e1091 into a 2007 silverado classic. i used a scosche wiring harness that allows me to keep my chimes. everything works fine but when i turn the truck off, theres still power...

It's called delayed acc. power. It should shut off as soon as you open the door. Unless the red stereo wire is hooked up to constant power. You may need to check with a test light.

Oct 31, 2010 | Car Audio & Video

1 Answer

How to install Scosche - 2-Channel Adjustable Line-Out Converter

If it is an active converter and not passive, you should have three power wires, black goes to ground, yellow to battery, and red to the remote/amp (blue) wire off the deck. Then there should be four input wires. These connect to your speakers, white-white/black to left, grey-grey/black to right. Black line indicates ground, or (-). Then simply hook up the RCA jacks to your amp! Caution: the Scosche only accepts 80w of power, 40 per channel. Otherwise you rick blowing the converter, possibly the amp (usually a mosfet), and then possibly the subs, though not likely.

Mar 05, 2010 | 1999 Ford Explorer

1 Answer

HID will not funtion hooked up right. They won't light. Everthing works as it should hit hi beams fog lights go out hi beam light comes on inside on dash. Its easy hookup maybe missing something? This is a...

yeah, shouldn't be that difficult. red-power, black-ground. unplug them then put everything back to normal, then try them to see if the originals(low beams, high beams, fog lights) work ok. if they do it's in the wiring. turn on your low beams and that's the wires that you need. just find the one that sends 12volts to the low beams and hook it up to red on HID's then hook the black(ground) from HID to chasis, not the ground wire from car and check to see if they work.

Sep 24, 2009 | 2009 Honda Ridgeline

1 Answer

Schoche converter trouble

yes , if you do not make your connections right you could probably damage the high to low, verify that all the wires you tapped into where speaker wires

Jul 15, 2009 | Scosche Industries Scosche Slc4 Speaker...

2 Answers

Wiring the scosche fai-3a to a pioneer two channel amp

the 2 left and right dont matter, it only matters when ur hooking up a 4 channel amp.
all u do is connect one of the channels to it but it would be best o buy a stereo ull have alot of engine nose and vibration on ur speakers and a thump every time u turn on ur car but itll sound ok for now ti

Jul 07, 2009 | Scosche Industries Scosche Slc4 Speaker...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

45 people viewed this question

Ask a Question

Usually answered in minutes!

Top SCOSCHE Car Audio & Video Experts


Level 2 Expert

125 Answers

ray gallant

Level 3 Expert

49094 Answers

Your Consultant

Level 3 Expert

552 Answers

Are you a SCOSCHE Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides