Question about Pool & Spa

1 Answer

Why if I press the "Jets" button I hear a click but the jets do not go on. The is a Balboa 500Z one control hot tub?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Master
  • 76,846 Answers

The water jet motor is most likely defective.

Posted on Apr 15, 2017

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Have an Emerson model # R63MWENA-4727 on my Hot Tub. Runs continuesly fine. But when I turn the jets on I hear a " click" and it won't run.


It is a problem in the relay of that one motor in your spa electronic control most likely. If you have many jets buttons, you can unplug 1 pump from the control and plug in another relay see if the motor works.. if it doesnt work it your motor if it does work then its the relay in the controle system.

Sep 04, 2015 | Emerson Pool & Spa

1 Answer

Our 880 Marin hot tub is constantly running the jets on 1/2 of the tub as if the circulation pump is running. The icon on the control panel does not show the jets are on. When we push the button to turn...


sounds to me with a power surge you could have a relay on the circuit board not working properly.
You will most likely need to change the circuit board to correct the problem.

US Parts Center

Sep 22, 2013 | Pool & Spa

1 Answer

Balboa VL700S control panel jets 1 not working


Your problem is going to be in the circuit board in the spa control box under the skirt.
You have a bad relay.
Rod
US Parts Center

Jun 25, 2013 | Pool & Spa

1 Answer

No temperature display cant set temperature


Located behind the access panel there is a grey box that is the spa pack. Open that up with the 2 screws on the top of the pack. There is a small glass fuse on the circuit board. One of those fuses is most likely blown. If that is not the culprit you need a new topside control. More than likely it's the fuse.

Mar 04, 2013 | Jacuzzi Balboa R574 System for 1 2 Speed...

1 Answer

I have just refilled by hot tub with a balboa 500z pump. After refilling it the pump is working fine but the jets are not. The dr light has come up. Please can someone help me bleed the pump to get it...


Priming can be done many different ways depending on thetubs design. Some tub manufactures provide bleed valves located on the plumbingjust beyond the pump and heater unions. Some pumps have a bleed valve locatedon the pump. If there are no bleed valves then you will have to release theunion nuts to allow the air to escape.
You can find answers to common spa or bath problems online at http://www.balboadirect.com/support.aspx
Hope that helps.

Jun 12, 2011 | Balboa Instruments Duplex Digital Panel 2...

1 Answer

My Balboa 500Z-Series Hot tub has been working fine for 6 months. Then today, without warning the lights started flashing and I could not turn them off from the light button. Additionally a code...


Hello!
I have a question about my Balboy 500Z. When the water is heated the motor pump is still running that means the pump runs all the time without interrupt even the water has it's temperature. Now my question: is it possible to turn of the pump? thank you for your quick answer! Greetings Beat from Switzerland

Jan 02, 2011 | Balboa Instruments Duplex Digital Panel 2...

1 Answer

Hot tub stuck in 'SL' mode


Need to know what buttons your topside control has... depending on the model, some have a mode button which you press and release and then immediately press the temp up or down, to select SL for sleep (no heat), ST for standard (heat as needed) or EC for Economy (only heat during filtration). If the mode button is not present, and you have a single temp button and light button, try pressing and releasing temp and then immediately pressing light button, repeat until choice appears, then wait, it will hold last displayed mode.

Jul 09, 2010 | Jacuzzi Balboa R574 System for 1 2 Speed...

Not finding what you are looking for?
Pool & Spa Logo

Related Topics:

40 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pool & Spa Experts

Jay Finke
Jay Finke

Level 3 Expert

1363 Answers

Bill Jordan

Level 2 Expert

372 Answers

David Spradling
David Spradling

Level 3 Expert

6498 Answers

Are you a Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...