Question about SimpleTech 250GB USB2.0 7200 RPM External 250 GB IDE Hard Drive

1 Answer

SimpleTech 500GB Hi-Speed USB 2.0 causing Windows to crash

Every time I transfer files to and fro this harddrive, I get the blue screen crash from Windows.  No other programs can be running, and it still happens.  Any ideas?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that got 5 achievements.


    An expert who has written 50 answers of more than 400 characters.


    An expert who has answered 200 questions.

  • Expert
  • 244 Answers
Re: SimpleTech 500GB Hi-Speed USB 2.0 causing Windows to...

Blue screen means hardware problem, Try to defrag your hardware possible bad sector problem. Just follow the procedure as follow: Click Start> Programs>Accessories>Disk Deframenter.

After opening fragment's system select the drive by highlighted the available drive and click defragment button. Just wait until done. It will automatically fix the bad sector if not so critical.

If the problem persist during the defragment, there is a critical problem with your harddrive.

Please rate me SOLVED

Posted on Nov 21, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

I have a pininfarina simpletech 500GB usb external harddrive that does not show up in the My Computer folder of Windows Explorer. Tried hooking it up to a different computer with the same results; no...

If it is a new hard drive then it needs to be formatted. You can do this by going into your start menu - control panel - administrative tools - computer management - disc manager. I could be a little off on the wording as I don't have my computer handy, but in the disc management you should be able to right click on the drive in here and choose format. This will format the drive to be used. I hope this helps.

Sep 10, 2011 | SimpleTech SimpleDrive Pininfarina 320GB...

1 Answer

Working with a mac-formatted G-Speed Q on a Windows 7 system using MacDrive. Somewhere in the middle of a large (unattended) data transfer, a blue screen of death seemed to have happened and rebooted the...

Since the drive crashed in the middle of a data transfer it probably has a damaged directory. Try connecting the drive to your Mac and run DiskWarrior on the drive to repair the directory and allow the drive to mount.

May 16, 2011 | G-Technology 0G01793 G-SPEED Q 8TB USB 2.0...

1 Answer

The blue light does not come on the red power light flashes and the red power light flashes i see nothing on the lap top

it might have been dropped, if so it could have bent the little read pin inside causing it to not be able to function correctly, those little harddrives cant take a very big hit

Sep 18, 2010 | SimpleTech SimpleDrive Pininfarina 500GB...

1 Answer

I am using simpletech 320gb for last 1 the speed of copying and pasting files is very low......what should i do to increase the speed?

The drive may have gotten badly fragmented. Connect it to the PC, and run defragmentation, say, overnight (may take long with an USB drive).
You can use the defragmenter built into Windows (found in drive's Properties, Tools tab), or better use a 3-rd party solution, like DiskDefrag.

There may be other causes as well, but defragmenting the files/folders on the disk would be my first move. Good luck :)

Jun 21, 2010 | SimpleTech SimpleDrive Pininfarina 320GB...

1 Answer

SimpleTech SimpleDrive 640 GB external USB harddrive wont turn on

Loose connection inside the Drive case. Remove drive and check internal wiring.

Dec 23, 2009 | SimpleTech SimpleDrive Pininfarina 500GB...

1 Answer

500Gb SimpleTech Ext Drive No Power

It sounds like you might have a problem with the power supply.
I have seen MANY external hard drives with failing power supplies. Take it to the store you purchased it from for a check up, it should still be under warrantee if its only 3 months old.
Good Luck!

Jun 17, 2009 | SimpleTech SimpleDrive Pininfarina 500GB...

3 Answers

External HD not recognizing USB ports as being Hi-speed ports

I have the same issue. I have 4 Simpletech Signature 250GB drives. They all worked fine at first. After about six months two of them started connecting at USB 1 speeds. It occurs on 4 different computers!!! The post about it being the computer assumes is wrong. How can it work fine for six months and then suddenly change. Also it occurs on different computers. I have submitted a tech support request with simpletech and will post the results.

Jun 14, 2009 | SimpleTech Signature Mini 160GB External...

3 Answers

I have a 500GB external SimpleTech HD. Tonight it

If it was running at the time it fell, the heads crashed into the platters, and the buzzing you're hearing is the dents left in the platters spinning by 7200 times a second.
Not good. Likely will need a professional service to recover the data.

Jun 05, 2009 | SimpleTech SimpleDrive...

1 Answer

Data on my Simpletech 160GB is gone...?

Take the drive out and put it in a new external case. the copying may have been caused by a virus in the computer.

Nov 24, 2008 | SimpleTech 160GB USB 2.0 / FireWire...

2 Answers

Simple tech 500gb usb hard drive

Youve damadged the harddrive, is the harddrive spinning or making any noise?

Jun 16, 2008 | SimpleTech SimpleDrive Pininfarina 500GB...

Not finding what you are looking for?
SimpleTech 250GB USB2.0 7200 RPM External 250 GB IDE Hard Drive Logo

Related Topics:

105 people viewed this question

Ask a Question

Usually answered in minutes!

Top SimpleTech Hard Drives Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

Arcadian Duran
Arcadian Duran

Level 2 Expert

284 Answers

Gareth Cockram
Gareth Cockram

Level 3 Expert

657 Answers

Are you a SimpleTech Hard Drive Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides