Question about Digidesign Mbox 2 Barebone

4 Answers

I just recently received a replacement mbox 2, and initially had problem installing protools, due to an error, I cleaned the back of the dvd and i have managed to install it, but the mbox2 usb and spdif green light is continuously flashing and a message appears that says your usb connection may be malfunctioning, windows does not recognise the usb connection. When I go into the sounds and devices in the computer the mbox 2 does not show. I have windows xp system and mbox 2 and protools 8 is what I am trying to set up. Please can someone advise how to fix this. greatly appreciated.

Posted by on

  • 1 more comment 
  • stew2008245 Jul 23, 2009

    Hi, thank you for that, your link that you posted does not work, where do I get the drivers?



    Thank you,



  • stew2008245 Jul 27, 2009

    Hi, thanks, I dont see USB 2.0 EHCI Host controller - I have a section Universal Serial Bus Controllers, but dont see this listed,I cant see other devices either. Please advise. Thanks,

  • stew2008245 Jul 28, 2009

    Hi, Thanks for that I have spoken to digidesign and have had to put the mbox2 back to be checked, I tried in other ports and there is no light coming from the usb area at all. From viewing your reply. I had the protools 8 installation disc, can't remember seeing a blue disk - what was this for? is this for drivers. I thought the relevant drivers are installed when you install protools 8? Within the control panel add remove programmes you could see protools drivers were installed at the time - though they dont tell you which ones. I managed to clean protools installation dvd and do a full install but once again windows did not recognise the usb device. When you say when you do re-install, you need to make sure to do the full installation and restart before connecting box, do you mean after the protools installation, and reboot you have to connect the mbox2 to the usb port after that i.e. not leave the mbox 2 connection on whilst it is rebooting? You need to connect the mbox 2 when you are installing protools at that time, but do you mean after it has installed and rebooted you remove the connection, and then after rebooting you connect the device? Just would like clarification, as this is the 2nd mbox2 return after having the same problem and I may be getting a replacement. I need to find out why windows is not picking up the box, and your help is appreciated. The option for installing wave drivers where does that appear? does it just appear as drivers as well as everything in the reinstallation? I am concerned I may have the same problem again, your advice would help. Thank you!

×

Ad

4 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 2,777 Answers

If it does not even show up in sounds and devices it would appear to be to be a hardware problem on the mbox's side . When you unplug and replug the USB to your computer do you get the sound notification that something has been plugged / unplugged? If you do not then that indicates the actual USB connection is not even attempting to speak with the computer. If it doesn't make the sound you will need to contact digidesign to find out about warranty repair / replacement. Please call them at 650.731.6100 for more information.

Posted on Jul 28, 2009

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 101 Answers

Hi, I use pro tools myself and had a couple of issues trying to set it up as well. Don't know how experienced you are with PT etc.. so will try and keep it user friendly
Did your installation pack come with a cd/dvd and a blue one (pc and mac)
Sounds like your installation might not have gone as it should, and maybe as a result you may be missing some of the drivers neceserry
The installation normlly puts in place the ASIO drivers (for music apps ) amd also the wave drivers for windows to use, meaning you can use it as an every day soundcard(even though windows doesn't love using the mbox as an everyday card)
Make sure the cd /dvd is cleaned to the best of your ability, stick the dvd back in and do an uninstall of protools Remember when you do the re-install follow the instalaltion to the letter, for instance you need to make sure you do the full install and restart BEFORE connecting your mbox , that way windows can pick it up with the drivers
Re-install the program making sure you don't select the option just to install pro tools on its own, install pro tools and the wave drivers. If you are still getting no results I have a copy of the drivers somewhere on my pc so if the re-install doesnt help I can email them to you. The digidesign website is also really good if you haven't joined up yet, and has loads of updates patches etc...
Get back to me and tell me how it goes
http://www.digidesign.com/index.cfm?langid=1

Posted on Jul 27, 2009

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 3,037 Answers

Are you using the USB port on the back of the computer or ones that are located on the front? if they are ones on the front then the problem could be one of two things. 1. the front USB ports are not properly hooked up. 2. the case you are using doesn't support USB2.0 and only has USB 1.1 cables for the front connections.

Or you may need to update your USB drivers. I have provided the directions below to do this.

  1. Open Device Manager. Locate Devices by Type.

    To open Device Manager, either run Devmgmt.msc at a command prompt, or follow these steps:
    1. Click Start, right-click My Computer, and then click Manage.
    2. Expand System Tools, click Device Manager, and then click Devices by type on the View menu.
  2. Right-click USB 2.0 EHCI Host controller, and then click Update Driver.

    You can find the USB Host controller entry in either of the following locations:
    • Universal Serial Bus Controllers.
    • Other Devices

      Note In the Other Devices location, the USB Host controller entry is labeled Universal Serial Bus controller with a yellow exclamation mark.
  3. Click Install the software automatically (Recommended), and then click Next.
  4. Click Finish when installation is finished.
Let me know how this turns out.



Benjamin

Posted on Jul 23, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 3,513 Answers

Hello,

Thanks for contacting Fixya.com

If I understood the issue correct the usb port is not recognised and and therefore shows some messages in it. I would request you to please install the drivers for winxp once again from the bellow mentioned link:

Pro Tools and its hardware are very intricately linked. You cannot run one without the other (at least under normal circumstances). So, you will have to instal pro Tools, even if you never plan to use it, in order to get the MBox drivers installed. Then, whether or not you will be able to use it is another story. Digi hardware is only designed to work with Pro Tools. There are some workarounds available, though. More info here: http://www.sweetwater.com/sweetcare/...er&-find=Go%21

Good Luck and God Bless

Posted on Jul 23, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have bought a mbox 2 and lost my installation cd with the protool program provided in the kit. Can I get/find/buy another one?


You can find the latest drivers and software for your Digidesign Mbox 2 from the manufacturer's website at avid.com.

Jul 07, 2011 | Digidesign Mbox 2 Barebone

1 Answer

Can't get my mini mbox usb working for protools 8 after inserting


You were supposed to install the software first (which holds the drivers for the hardware) before you plugged in the MBox. I had the same problem, but I had to use drastic measures and reinstall my OS.

Mar 29, 2009 | Digidesign Command 8 USB Control Surface...

1 Answer

Mbox


This means that your firmware on the Mbox and the drivers need to be updated. I had the same problem afte updating my protools from version 6.7, Did you recently do any protools upgrades? You can go to Digidesign>My Digi>downloads>Mbox>firmware updates or>driver updates

Oct 17, 2008 | Digidesign Mbox External Sound System

2 Answers

Mbox cannot start new session or load in old sessions.


Digidesign website had the answer....go to windows,show workspace and change the settings for your relevant disc from transfer T to R...record in the A..audio column.
Thanks  Bobcat8

Oct 07, 2008 | Digidesign Mbox External Sound System

1 Answer

Mbox problem (no input,output)


i'm running os 10.5.6 w/ protools 8.0 and the original mbox. i had the same problem. protools opened and seemed to work except there was no sound from either analog outputs or headphones. this worked for me:
1. shut down computer
2. unplugged all usb cables except keyboard/mouse
3. restarted computer
4. re-plugged usb cable from computer to mbox
5. opened protools session
6. hit play and now i'm hearing sound and everything seems normal.

i hope this helps everyone else

Oct 03, 2008 | Digidesign Mbox External Sound System

1 Answer

Protools mbox2 issue


it doesnt sound like its the mbox more maybe the protools install. But as far as the cable goes can you tell me if you can ping the mbox throught the 1394 connection. If you cant ping it then damage may have been caused to the unit and it may need to be serviced. I fix my own M-box's but in my store it only costs around $50usd to fix almost all problems with a mbox2

Sep 22, 2008 | Digidesign MBox 2 External Sound System

1 Answer

Mbox 2 and new macbook pro


my Mbox isnt being found by my mac. when i try and install protools it tells me the mbox carnt be found. i have tried different usb cables ect but nothing seems to work.

Jul 22, 2008 | Digidesign Mbox 2 Barebone

2 Answers

Digidesign Mbox on Vista


same here but when i pull up protools the mbox does not power on !!I have the imac g5

Jun 21, 2008 | Digidesign Mbox External Sound System

2 Answers

Mbox 2


dkjkjd jheuj'y je

Jun 13, 2008 | Digidesign Mbox 2 Barebone

1 Answer

Setup


plz give solution how to driver install

May 31, 2008 | Digidesign Mbox External Sound System

Not finding what you are looking for?
Digidesign Mbox  2 Barebone Logo

Related Topics:

85 people viewed this question

Ask a Question

Usually answered in minutes!

Top Digidesign Computers & Internet Experts

yadayada
yadayada

Level 3 Expert

76691 Answers

ali_zulfikar
ali_zulfikar

Level 2 Expert

156 Answers

Zhenya Ogorodnikov

Level 2 Expert

218 Answers

Are you a Digidesign Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...