Question about Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

I have a 04 silverado with factory bose stereo. I have installed a Xplod xm-zr604 and the sub is playing but it will not crank up. Its as if the volume is very low.I have tie in after the factory amp for my input source.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 15,935 Answers

If you dont have a line level converter with adjustable output - get one.

Your amplifier only amplifies the signal it gets - and if its a very low voltage - you wont get as much output from the ampifier.

I always recomend PAC converters. They are a little more expensive - but are #1 adjustable, and #2 they also make one with voltage sensing. You wire up a positive power source, and when it detects voltage from the speaker wires - it will send a remote turn on to your amplifier. (MTX has this technology built in to its amplifiers)

No more crawling under the dash or removing the factory radio!!!

Thanks for using FixYa - a very Helpful rating is appreciated for answering your FREE question.

Posted on Jul 24, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Red power/protector light


The amplifier has gone into protect mode and will stay in that mode until the cause is corrected.

Nov 17, 2013 | Sony Xplod 800W Class AB Bridgeable...

1 Answer

Sony xplod stereo wiring diagram


Yes you need to turn on the BOSE amplifier in the car to hear the sound. The wiring diagram is actually on top of the factory radio
You will need a 12v trigger to turn the amp on. this is assuming you have all the speaker (inputs) connected to the output from your new deck.

Sep 09, 2013 | 2001 Audi TT

1 Answer

I got Sony Xplod XM-ZR704 700W 4/3/2-Channel Car Stereo Amplifier and 12" sub. it play good for continuous 2 hours but after that starts tripping and goes on off. i checked all wires and connections.


Amp is probably over heating. Make sure the ohm load of speaker is good for that amp. This amp is not really built to handle a bridged 2 ohm load. Make sure ground wire is clean and tight to the body chassis.

May 18, 2012 | Sony Xplod XM-ZR704 700W 4/3/2-Channel Car...

1 Answer

Hey i have a sony amp (600 watt xm-zr604) with 2 10"sub(sony xplod).when i raise the volume hight enough the amp go off(red light came on) what can i try


sounds as though (at high volumes) the amp thinks it has a short circuit. This may be caused by the way you have them connected.
Speakers have a resistance and amps needs a certain amount of resistance to function right (too little resistance = short circuit)
The way it works out for the speakers is, if the two are connected to one amp output channel, the amp will see half of the resistance of a single sub. (4 Ohms/sub amp sees 2 Ohms)
If the amp instructions say that it's 4 Ohms/channel then you need to use 1 channel for each sub.
Hope this has been some help.

May 07, 2011 | Sony Xplod 800W Class AB Bridgeable...

1 Answer

I have a sony explod an want to hook up the sub that came stock in my truck ( 04 chevy ss) its a bose sub. an dont want to run a amp, can it be done and how?


You can do it, but you'll need to use one of the outputs from the stereo, i.e. right rear/left rear. Disconnect the exsisting wiring to the sub. You'll need to run the two output wires from the stereo straight to the sub.

May 09, 2010 | 2004 Chevrolet Silverado 1500 Crew Cab

1 Answer

How should i arrange the wiring on my xm-zr1852 xplod amplifier to get the best performance out of my 12'' audiobahn subwoofers?


it depends on the impedance of the subs-if your subs are dual 4 ohm coils then you can parallel the coils which will give you 2 ohms per sub- you could get max performance from your amp by just wiring the 2 ohm speaker load to each channel of the amp which will hit them with about 200 watts rms each. another way to do it is to wire the coils in series which will make each sub an 8 ohm load and then parallel them together and that will show a 4 ohm load -which you can use to run the amp safely in bridged mode. This will give you exactly the same amount of power to your subs as in 2 ohm stereo will. so with your amp being 2 ohm stable in stereo or 4 ohm stable in bridged mode- those are the numbers you want to hit for maximum"safe" operation

Dec 10, 2009 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Amp and sub connection


Too many problems, lol. One at a time. I lost you in your post, run by me again but one amp at a time.

Jan 08, 2008 | Sony Xplod XM-1652Z Car Audio Amplifier

Not finding what you are looking for?
Sony Xplod XM-554ZR Car Audio Amplifier Logo

418 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4834 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

287 Answers

Philip Rowney
Philip Rowney

Level 2 Expert

94 Answers

Are you a Sony Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...