Question about Sony XM-2100GTX Car Audio Amplifier

3 Answers

Red Power Protector light

First installe my amp it worked fine except for if i turn the sub up really high it would reset my stereo for some reason. That's issue one. Then today when my amp initially turned on the pow/pro light was green but then i turn up my stereo it turns red and there is no sound from the sub. It was working fine a few days ago and now if i turn my sub up or the stereo up high it just turns red. Can someone help me?

Posted by on

3 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Sony Master
  • 636 Answers

Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. Your amp is clipping. .A thumbs up would be greatly appreciated if this answer is helpful to you.

Posted on Dec 18, 2014

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 11 Answers

Turn your gain down

Posted on Jul 23, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 113 Answers

Hi, the only way i can see the amp resets the stereo is that power is dropping. The amp should have its own wires directly to power/battery so as to not affect anything else.

On the protect, try to disconnet all the speakers, make sure the power is OK. If it appears to work, the there could be a problem with speakers/cables. Try a different speaker to see if it works. If the problem continues with speakers off, a different speaker etc, then there is a problem with the amp. Hope that helps

Posted on Jul 22, 2009

  • Garth Urie
    Garth Urie Jul 22, 2009

    Hi, the only way i can see the amp resets the stereo is that power is dropping. The amp should have its own wires directly to power/battery so as to not affect anything else.

    On the protect, try to disconnet all the speakers, make sure the power is OK. If it appears to work, the there could be a problem with speakers/cables. Try a different speaker to see if it works. If the problem continues with speakers off, a different speaker etc, then there is a problem with the amp. Hope that helps

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Well i was driving one day and my subs just whent out so i bought brand new wires and hooked everything up but the power protector light turns red whenever uu turn it up past volume 10 i really do not know...


It sounds like your amp is going into protection. I know it's frustrating, but this is actually a good thing. If you subs you have are drawing too much power and the amp can't keep up, it will shut off instead of melting the board. Usually, the protection mode only last a few seconds. The user normally turns the music down that the protection shuts off and the music plays again. I recommend looking at a larger amp for your subs, if you are going to play them that hard.

Aug 14, 2011 | Car Audio & Video

2 Answers

2 12" subs + 600W amp. Turn on, goes boom once, then red light


Is your gain all the way up? If it done this before, sounds like your over working the amp. Make sure your subs ohm load is capable with the amp load to. If they are 1 ohm and your amp is only 2 ohm stable, it would beat for a lil bit then go into protection mode to. Check your wires too.

May 13, 2010 | Insignia 600W Bridgeable Amplifier with...

2 Answers

Amp Turns on Fine, but no Sound


have you checked the levels on the ohms? adjust them higher if need be contact me on yahoo msgr if you need more assistance

jcbproducts-always forward

ym-jcbproducts

Nov 14, 2008 | American Pro VS-2043 Car Audio Amplifier

3 Answers

Power protector light on sony xplode 1000 watt amp


a green light is the power indicator, a red light is when the protector is in affect

May 30, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

AMP FOR SUB SHUTS OFF SOMETIMES


your amp may be overheating, or you have it up too loud and the surge protector is shutting it of in fear of damage to your amp.

Apr 24, 2008 | Kenwood KAC-7202 Car Audio Amplifier

1 Answer

Protector light keeps coming on


the reason why this is happining is that your pushing to much power than that amp can handle you need to get a bigger amp so it can withstand the power that you want to push to it also the red light comes on so you dont blow the amp.

Jan 08, 2008 | Sony XM-1252GTR Car Audio Amplifier

1 Answer

Car audio


hi, your amp seems to be getting power but the cables might be wrong so it's not getting enough power. the light on the amp should be green if everything is going well. are you sure the cables are suitable for your amp?

Sep 11, 2007 | MTX RT202 Car Audio Amplifier

1 Answer

Amp keeps kicking off? Power Protector?


as long as your powers and grounds are good(make very sure your ground is ok) then either you have a intermittent short in one of the subs or the amp is getting ready to die lol.. The sony amps are notorious for faulure-the quality is just not there... Is the amp really hot??? the only other thing you coudl try is to ass a fan or two in it or around it and see if that helps it out..

Aug 18, 2007 | Sony XM-2200GTX Car Audio Amplifier

2 Answers

My Power Protector Light wont turn Green


switch off the amp then take off all the wires off including the speaker wire and then reconnect the wires on like before the problem is that the amp is on protection and if that dont work then get it repaired another thing is make sure ur amp fuses havent blown.

Nov 04, 2006 | Sony Xplod XM-554ZR Car Audio Amplifier

Not finding what you are looking for?
Sony XM-2100GTX Car Audio Amplifier Logo

219 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4848 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

287 Answers

Philip Rowney
Philip Rowney

Level 2 Expert

94 Answers

Are you a Sony Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...