Question about Car Audio & Video

Open Question

KXD15 Amp EQ lights flash when turned on, but no power or sound, what is wrong? Was working fine yesterday.

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

pnevai
  • 48 Answers

SOURCE: No Sound/ lights flashing on Amp

Disconnect your subs from the amp. If the lights go out then your sub is blown and is putting the amp into protect. If the lights keep flashing even with the subs disconnected than the Amp is toast.

Posted on Jul 14, 2007

SOURCE: power & protect

my amp says Lo on the digital circle on top of the amp i have a mtx 9500 bridged to the amp and it cuts out at high volumes and suddenly please help



Posted on Oct 20, 2008

  • 1 Answer

SOURCE: Radio won't turn on - EQ lights flash

My Sebring radio won't turn on - it has power. The EQ lights flash - almost like a security code needs to be entered.

Posted on Apr 09, 2009

jr fix it
  • 5 Answers

SOURCE: my 600w power amp XM-554ZR wont turn on

open it n there is a red wire look at the end of it n u would see a black celinder with a with a white strip on it change that part if it is burn

Posted on Jul 14, 2009

  • 1 Answer

SOURCE: rED LIGHT FLASHING after local power cut in East London

I switched off the power, then I disconnected the lid from the base, put the power back on, the green light came on & then I reconnected the lid to the base & it has been working fine ever since

Posted on Aug 28, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Machine stopped - alarm light flashing


just saw this yesterday. remove the top rear paper guide. on the left side between the tractor feed and the input slot for the paper, there is a sensor flag that pivots. check for paper scrap caught under the flag. it prevents the flag movement, causes a paper out alarm.

Jul 13, 2012 | OKI MicroLine 420 Matrix Printer

1 Answer

I have this mixwer for domestic use only, swithced it on last night and power is there, but no sound at all, from any channel.Could you please advise,


Make sure your audio source is playing.

Make sure your channel is not muted.

Make sure your channel is assigned to "main mix" (bottom button to right of main volume slider).

Make sure your main output slider has volume applied.

Make sure the cable you're plugging into your "main output" is being plugged into the 1/4" or xlr output receptacle that corresponds with the slider you provided volume to.

You should then put the outgoing cable into either an eq or an amp.

If you're going to an amp first, place the cable carrying the signal from the board into an "incoming" slot on the amp. Run a cable from the output of that channel of the amp to a speaker. Turn on the amp and fade the volume knobs up. That should give you power - provided your board, cables, amp and speaker are working properly.

If you're going to an EQ first, place the cable carrying the signal fromt he board into an "incoming" slot on the eq. Then run a cable from the output of the same channel on the eq to an incoming slot on your amp. Then run an outgoing cable from the same channel on the amp to a speaker. Flip your eq on, flip your amp on, fade up the volume on the amp, and make sure you don't have a gate closed on the eq (also make sure if you have a gain knob on the eq, that it's at least partially providing power). If your board, cables, eq, amp and speaker are working properly, you will have sound.

Nov 18, 2010 | Yamaha Mg8-2fx 8-Channel Mixer with...

1 Answer

I have a 1999 dodge caravan. Passenger sign turn signal flashes for a short period & goes solid. Reverse light & brake light work just fine. Multifunction switch, light sockets, light assembly...


Sounds like the relay is burning out. When the lights stop flashing does the indicator on the dash light up and stay on and/or does the exterior lights light up and stay on? If the indicator light is staying on then you have a wiring problem to the lights or you have the wrong bulb/ bulbs. If the exterior lights stay on it is a bad relay or power to the relay.

Oct 31, 2010 | 1999 Dodge Caravan

1 Answer

Conecting my equalizer to amp'


What kind of EQ?

Typically you would place an EQ or any processor in a Tape Loop:

Tape Rec/Out to EQ In; EQ Out to Tape Play/In on the amp. Select Tape Monitor on the amp to place the EQ in-line with whatever source you're playing. Use it's ability to modify the sound sparingly.

Feb 23, 2010 | Audio Players & Recorders

1 Answer

RED LIGHT FLASHING after local power cut in East London


I switched off the power, then I disconnected the lid from the base, put the power back on, the green light came on & then I reconnected the lid to the base & it has been working fine ever since

Aug 27, 2009 | Epson Perfection 4990 Flatbed Scanner

1 Answer

Radio won't turn on - EQ lights flash


My Sebring radio won't turn on - it has power. The EQ lights flash - almost like a security code needs to be entered.

Apr 09, 2009 | 2001 Chrysler Sebring

1 Answer

I have a Toshiba C/X3030D television was working fine yesterday when turned off. Turned on today and digital channels will not work. Analogue is fine,Digital menue is just flashing up and will not stay...


I have a Toshiba C/X3030D television was working fine yesterday when turned off. Turned on today and digital channels will not work. Analogue is fine,Digital menue is just flashing up and will not stay open so can not reset television. Any one with ideas as to what has gone wrong?
Thanks

Jul 11, 2008 | Televison & Video

1 Answer

Mtx 1501d


ARE U USING THE CONTROLS THAT CAME WITH THE AMP?
USUALLY THE CONTROLS CABLE GOES BAD

May 08, 2008 | MTX Thunder 1501D Car Audio Amplifier

2 Answers

Plugged in, worked, turn on later, did not work


First thing i would do would be to check convergance amp ics

http://home.earthlink.net/~oleg.filippov/ConvergenceFix.htm
http://cmpalmer.blogspot.com/2006/11/fixing-my-own-tv-part-ii.html

Jan 01, 2008 | Toshiba 55H70 55" Rear Projection...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

34 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4834 Answers

yadayada
yadayada

Level 3 Expert

75005 Answers

The Knight
The Knight

Level 3 Expert

73619 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...