Question about Electrolux Vacuums

1 Answer

Electrolux Velocity pet lover 1800W Drive belts keep on breaking...

They just snap while I'm vacuuming.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Welcome Back:

    Visited the website for 2 consecutive days.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

Dear Judy, there are several things that can cause the problem you are having but I can give you a few things to look at. First is that you are getting the correct belt for your machine. Second is the motor and brush roll moving freely after you install a new belt & before you start vacuuming?. Third is the machine set at it's lowest setting(try a higher setting to start) finally is the belt an after-market made in china one. Quality in Chinese rubber products can suck at times. If all this is ok than it maybe best to take to your local vacuum repair shop. Good Luck-Jack of all trades bob
http://www.habitacionesparalationos.org/

Posted on Jan 02, 2017

Testimonial: "Thank you Jack of all trades bob! Great that you answered so soon. Will have a look at the settings and check if the belt is the right quality."

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My electrolux vitesse pet lover 1800w has stopped working


Is the flex all right? Check it with a voltmeter or a continuity meter (available for a small sum in your local hardware or electrical shop).

Jan 19, 2015 | Electrolux Vacuums

1 Answer

Electrolux Vitesse Pet Lover 1800w. I was given this vacuum today. It works fine but is really loud. It's hardly had any use. Is this normal? I just put in ear protection.



Should not be that loud. Check all the filters and see if they are ok. Check to see what the suction level is. This is kind of subjective. IT might have a bad bearing in the motor.

Nov 18, 2013 | Vacuums

1 Answer

Motor sounds like a airplane


It sounds like it is time to replace the motor. You might also want to think about replacing the unit itself since the motor can be very expensive in comparison to the cost of the vacuum itself. I would recommend thinking about a different brand like electrolux or hoover.

Oct 31, 2011 | Eureka 3276AZ Pet Lover Bagless Upright...

1 Answer

I need to know how to get in to replace the belt...


The belt replacement can be done in just a few easy steps.
You're going to want to turn the vacuum on it's side to access the base of the unit. Unscrew the bottom of the vacuum and remove the brushroll. Make sure to remove any string or clumps of dirt that could have caused your old belt to break. Stretch the belt with the brushroll until it can be put into place. Secure the bottomplate back into place. That should do it!

Sep 08, 2011 | Eureka 3276AZ Pet Lover Bagless Upright...

1 Answer

Electrolux vitesse pet lover 1700w. Keeps cutting out and electrical sparks in front vent


Hi there SmartAlec from NelsonVacuums.com.au here. I am sorry to be the bearer of bad news but if you can visibly see sparks and its cutting out then i would say that the motor brushes are nearly worn out. On this particular vacuum cleaner they are not sold as a spare part so i think it would need to go to a repair center for a new motor or to vacuum heaven for a replacement.
Regards Alec

Aug 23, 2009 | Electrolux Vacuums

1 Answer

I have a velocity pet lover 1900 only 2 months old


You have broken the rubber belt that drives the brush. Flip over and remove the old belt and replace it with a new one.

Jim

Jun 10, 2009 | Electrolux EL1000A2 Pronto Bagless Stick...

1 Answer

Electrolux velocity pet lover 1800


we had the same problem and replaced the driver belt. The only problem is that we seem to have to replace the belt everytime we hoover!

Sep 07, 2008 | Electrolux EL1000A2 Pronto Bagless Stick...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

35 people viewed this question

Ask a Question

Usually answered in minutes!

Top Electrolux Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18390 Answers

yadayada
yadayada

Level 3 Expert

75744 Answers

Mack Baxter

Level 3 Expert

381 Answers

Are you an Electrolux Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...