Question about Car Audio & Video

Open Question

There's a strange tick coming out of the amplifier. where does it come from and what to do about it.

That's when I connect amp 2.

Posted by on

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Primare spa21 amplifier, Sometimes when I turn it on from standby mode only 1 speaker works till I adjust the volume then both speakers come on and the problem doesnt happen till I switch off then back...


I have not had the same problem, but you can try and reload factory setting. This can help if there is no sound or with other strange symptoms. Connect video out from amp to a TV/monitor and push menu and find the memory menu. If this help you must remember to store the new setting or else it will return to the previouse settings.

Nov 06, 2011 | Audio Players & Recorders

1 Answer

I have a 1400 watt cruch amp & i hooked it up myself. when i turn the radio on the power wire on the amp comes on, bt if the audio cords are hooked up, the protection light comes on. if i dnt hook the...


Should the amplifier go into protect mode, simply disconnect all RCA and speaker leads, while keeping +12 volt, power ground and remote leads connected.

1. Now turn the amplifier back on, and if the diagnostic LED lights, the amplifier has an internal fault.

2. If not, plug the RCA cables back, and reset the amplifier. If it goes into diagnostic now, the fault lies in the input, either with bad cables or source unit.

3. If the amplifier seems fine with RCA cables plugged in, connect the speakers, one at a time, and if one of the speakers or its wiring is faulty, it will activate the diagnostic
system.

Dec 08, 2010 | Mobile Authority A-500 Car Audio Amplifier

3 Answers

I have this hooked up and works fine with the key on, but when i start the car, sub light, amp and sub dont come on.


You have connected it to the wrong power wire - one that is only active in service mode - first key position.
You should draw a wire directly from the battery (don't forget to add a 40 amps fuse on the wire) to the amps. If you don't want them constantly operational (you will have to manually shut them down) install a relay on the wire with the command coming from a wire from the instrument key position - second position of the key. Use a voltmeter to identify the wires.

Oct 15, 2010 | Rockford Fosgate Power 351M Car Audio...

1 Answer

Who knows how to replace an AC chord on a bgw 750a power amplifier who can i communicate with who is familiar with this amp. i had a short and located where a wire inside was grounding out the amp but...


At this point you are better off not connecting the ground wire at all. The BGW was designed for a 2-wire system and is internally isolated. Just connect the white and black to where they were before and call it a day.

Dan

Nov 05, 2009 | Audio Players & Recorders

3 Answers

2004 Lincoln Navigator, Strange ticking noise coming from rear passenger 3 row area over wheel well some sort of computer box. only when turn ignition or vehicle running, sounds like clock ticking


This is caused by a blend door actuator on the rear a/c unit. There are 2 located on the case. Take it to a dealer and they will know what you are talking about.

Oct 15, 2009 | 2004 Lincoln Navigator

1 Answer

Amplifier won't turn on and sound wont come out of it trying to find out if it is connected right


get a test ligh and check for power at the amp at the remote turn on wire and power wire then check for a good ground connection to the amp

Sep 26, 2009 | Peavey AMPLIFIER, 1000 WPC, DDT, 8/4/2...

1 Answer

Amp not working


if your light is not coming on then you probably dont have power to it. check all your connections and make sure it is all hooked up right. check the remote with in the back of the deck.

Jul 24, 2008 | Volfenhag 1000 WATT AMP 4 CH AMPLIFIER...

1 Answer

Multipal amps


make sure your speakers are connected correctly if subs and are inside the box then check connections also at times the rca at the back of the head unit can disconnect. if power light is on then error is either speakers not connected correctly, rca faulty or not connected or speaker output on amp is blown

Jan 03, 2008 | Kenwood KAC-7202 Car Audio Amplifier

1 Answer

Orion XTR Pro 1000 amp ticking


the amplifier output transistor or ic may be damage, its the relay may be thats ticking, or if not the output going to the speaker may be shorted or overloaded with low impedance, you may remove some speaker and try again.

May 18, 2007 | Orion XTR Pro 1000 Car Audio Amplifier

2 Answers

Amplifier not working


Do yourself a favor and take it to a repair shop. It will be alot easier on yourself and you will get your amp back in working condition alot faster.

May 04, 2007 | AudioBahn A8000V 400W x 1 Car Amplifier...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

37 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4861 Answers

yadayada
yadayada

Level 3 Expert

76132 Answers

The Knight
The Knight

Level 3 Expert

74243 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...