Question about Winter Sports

1 Answer

My sled 1998 polaris touring ideals great half speed good high speed cuts out I have cleaned the carbs twice drained gas put new gas in still stall out still what's next

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 682 Answers

Did you try changing the spark plugs?

Posted on Jan 03, 2017

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

93 xlt 580. Only runs on 2 cylinders sometimes at cold. Change plugs and works sometimes.. Not always same cylinder.. Any way to check stator,coil?


Ask The SnowMan Your Sledding Questions Answered: Off ...

www.off-road.com/.../ask-the-snowman-your-sledding-questions-answer...
Mar 1, 2009 - Its a 96 polaris indy xlt 600 triple not the special edition though. ... THEM SITTING ON THE HEADS BUT ONLY 2 CYLINDERS ARE RUNNING WHEN ... Q: I have a arctic cat ext580 the compression in both cylinders is about 70psi .... i have a93 polaris 600 xlt and I just got home and the antifreeze is ...

93 XLT Carb settings? - Snowmobile Forum: Your #1 Snowmobile Forum

www.snowmobileforum.com/polaris.../41045-93-xlt-carb-settings.html
Nov 27, 2009 - I bought a new to me 95 polaris sport last year. it had not run in twoyears. ... It's all in the tuning, clutching, jetting and gears.. i have a 93 xlt 580 and i ... he is loading up with fuel and just cutting the spark out of a cylinder.. i had ... XLT w/ Triple Pipes Question?
May 8, 2013
93 XLT Ran Great, Shut Down, Now Backfires
Feb 13, 2012
Dead cylinder
Dec 11, 2011
1998 ski doo f3 700 wont run right
Feb 22, 2011
More results from www.snowmobileforum.com

Polaris Indy 600 XLT HELP! - Snowmobile Fanatics


Jan 04, 2016 | Cars & Trucks

2 Answers

Polaris troubleshooting


Sounds like a carb issue...make sure you have fresh ,clean gas.You havent got water in your carb/tank have you? I would start by taking the carb apart and give it a really good clean.Check all jets and orifices.Another words,take apart anything in the carb that you can,clean and replace.

Aug 08, 2014 | Polaris 2008 Sportsman 500 H.O

1 Answer

2010 Sportsman 500 HO


have seen this happen to my honda, water gets ingested in the carb when in deep water and settles in the bottom of the fuel bowl. you must remove the fuel bowl drain cap to drain out water

May 07, 2017 | Polaris ATV

1 Answer

Need a new carb or find a cheap rebuilt one at


check if ur gas line is workin rite take off tank, off n on 'switch if not that clean ur carb i had same problem clean off n on switch on gas tank if that aint problem ur carb is clogg some weres or just dirty

Apr 11, 2011 | Polaris ATV

2 Answers

Idling good start good but stalls if pressing throtle


there is a piece of debris floating around in the sediment bowl of your carburetor, its lodged in the high speed jet causing it to stumble and backfire......it will most likely need a carb rebuild average repair cost on this machine is around 150 dollars at a reputable polaris dealer

Nov 19, 2009 | Polaris ATV

1 Answer

93 polaris xlt tripple wont run to full potential


The issue I had with my 94 was due to an oil adjustment, wich you can find below the carbs. It ran great at full throttle but once it sat at idle, the plugs would get wet and the same type of bog would accure. Get new plungs and make sure all three are firing first, if they are then the oil adjustment is off. If not sorry to say but you may have a bad coil.

Feb 10, 2009 | APW Wyott Sport & Outdoor - Others

1 Answer

Wont start


you need to have your compression checked. this happened to me and one cylinder was toast. they should be around 120 psi and not more than 5% difference between the two. if not clean the carbs

Jan 31, 2009 | Polaris New Genuine Polaris Snowmobile...

4 Answers

Backfires and bogs


put it in a warm garage overnight the other possibility is the timing is out.

Robert

Jan 22, 2009 | Polaris New Genuine Polaris Snowmobile...

Not finding what you are looking for?
Winter Sports Logo

Related Topics:

443 people viewed this question

Ask a Question

Usually answered in minutes!

Top Winter Sports Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

yadayada
yadayada

Level 3 Expert

75197 Answers

Todd Arndt
Todd Arndt

Level 3 Expert

2044 Answers

Are you a Winter Sport Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...