Question about Hoover Vacuums

1 Answer

My Hoover Windtunnel Model U6618-900 doesn't have enough suction to pick up anything?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 575 Answers

Make sure you canister is empty. The interior air filter is clean. Check if the hose is free of any debris.

Posted on Dec 22, 2016

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Suction not working on vaccuum.


Check for a blockage in the hose, or a tear / hole in the hose between the "pleats"

Jun 13, 2010 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

Left side of Hoover Windtunnel won't pick up dirt and hair


Take it to your local vac shop for repair. They can help you. It needs to be serviced annually anyway to perform properly.

Aug 07, 2017 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

No suction


I have found more vacuums on the way to the dump because they were full. Check. Is it full?
If not the air way is clogged.

May 17, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Hoover Bagless WindTunnel vacuum cleaner.


very easy. you have clog. take the brush off look where the hole is thats where the clog is. it might be in there you might have to take the housing off of the motor

May 08, 2009 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

Hoover Windtunnel spits dirt back out the back


Your problem sounds to be an obstruction in the foot (lower body) of the windrummel. Most all windtunnel's have a second cavity for suction to go over the top of the roller. When you remove the bottom plate, next remobe the belt and roller, under the roller will be a removable cavity, take it out. remove the dirt and clean out any debris. also check the suction path connecting hose. if your belt has not been changed in the last 12 months, I would recommend changing that as well.

Jan 17, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Vac wont pull/**** anything while we try to vac floor,


Hello RonD30,
If you are getting suction thru the hose and not from the bottom section.. you have a clog somewhere inline with the base area... If you have access to a shop vac ... unplug the Hoover, open up the base and remove the beater bar /belt assembly.. then hold the shop vac nozzle on the point of entry to where the Hoover pulls the debris into the dirt compartment. I am fairly certain you have a clog somewhere in that ducting.. Stubborn ones may need a little motivation.. so you may be able to get an electricians snake or metal coat hanger bent to release the jam..
Hope that helps..
Regards,
Rick..
And you are right , regarding Lowes..but don't exclude Home Depot from the same rating..LOL Once the sale is done.. so are they...

Dec 13, 2008 | Hoover Vacuums

1 Answer

No suction


have u checked all of the filters. I know that when not all the filters r clean the machine will turn on but then it will sound louder and still have no suction. Most times there is a filter under dirt container thats sits above motor and if this filter is not clean the motor cannot breath. Thus no suction

Sep 29, 2008 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

Hoover self-propelled


No suction on Windtunnel 6630-900. All belts work, brush turns, it just won't pick up anything.

Sep 07, 2008 | Hoover Self-Propelled WindTunnel Bagless...

1 Answer

Getting no suction


Check the hose for a clog, when suction is low, you will usually find a clog in the hose or in the dirt inlet by the brush roll. If this is less then a year old, then it is still in warranty, if you can't figure it out, then take it and proof of purchase to a warranty repair shop.

Mar 21, 2008 | Hoover 5416-900 WindTunnel Bagged Upright...

2 Answers

Loss of suction in my Hoover Windtunnel bagless selfpropelled upright


Did you check the dirt inlet by the brush roll, filters ok, they should be replaced once a year. Belts can look fine, but if they are a few months old, I am sure they have stretched and the brush roll will not turn like it should under load. It is possible that the motor isn't running up to speed, thereby reducing suction.

Mar 11, 2008 | Hoover Self-Propelled WindTunnel Bagless...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

34 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18408 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1467 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...