Question about Kenwood Car Audio & Video

Open Question

Kenwood kac5206 car amplifier the redlight on top comes on nothing looks or smells internally is this simply the power light or whatis it goodor bad

Posted by on

Ad

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Technician can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Technician (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 5 Answers

SOURCE: Kenwood KAC-8103D Power Amplifier wont turn on

it sounds to me like its burnt.but with some amps the screws that hold it in place have to be screwed into the car chassisfor grounding. be careful not to srewe into hidden wires.

Posted on Apr 15, 2009

Ad
etirbynnor
  • 655 Answers

SOURCE: kenwood 7204 car amplifier flashes the blue light

Hello rogman9570,

I'd begin by checking all of the wiring. The most probable causes of this type of failure indication are:

• Speaker wire may be short-circuited.
• Speaker output contacts ground.
• Head unit (cassette receiver, CD receiver, etc.) or the amp ground fails.

If all of your wiring checks out OK, then the amp itself probably has an internal fault.

Hope this helps.

Posted on May 18, 2009

  • 155 Answers

SOURCE: looking for owners manuel for kenwood car amplifier ps 200

try retrevo.com seems to work for me..

Posted on May 11, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Kenwoood kac-7202 redlight/no output


you blew the output Ic's (amps one or more ) you can fix this by replacing the output IC's

Jan 29, 2014 | Kenwood KAC-7202 Car Audio Amplifier

1 Answer

No power to sub.. redlight flashing on top of amp


put a meter across the speaker without disconnected and measure the impedance, it should show you the stated rating say like 4 ohms or 30 ohms. if it shows nothing then you have blown it up. If it shows you a dead short then its still blown up and probably burnt out and is shorting. Try very gently pushing in and out the cone with both hands 1 on each side if it is stiff then you have knocked it of center or burnt it out. if you get a reading with the meter and the cone has not frozen then try another speaker on the amp. if this fails they the sub on another amp. if this fails look for a reset button on the amp. you could try giving the amp a new signal that you know works finally if this fails then it looks like you have taken both of them out

Apr 09, 2011 | Kenwood KAC-5204 350 Watt Max Power Stereo...

1 Answer

I have been using my Kenwood KRF-V7030D amplifier up until now without any problems... But now It simply wont turn on... There is power going to the unit as the red led lights up when the power cord is...


since the light is on there is the power going in but still you are not able to make it on so it have got the problem of internal mechanical problem, if atall it were the software problem then you could simply rebooted and could have got it in normal mode.
best thing to do is call some hardware expert and get it repaired and it will be cheap and relible too.
good luck
surya

Jan 21, 2011 | Kenwood Audio Players & Recorders

1 Answer

I have everything hooked up correctly and cleanly, but when i turn my truck on the blue light flashes on then off and my subs do nothing. I don't know if its shorting out or what is going on.


sounds like a loose ground, or a loose positive cable or possibly a blow inline fuse, and the only power your unit is getting is from the remote. triple check all your connections. use your senses, smell the amp, smell for a burned order, this usually identifies if it is something internal. but it sounds like in your case (from experience with) a bad ground. If your gound or positive is connected but not tight it may be enough to power the remote circut, but not good enough to handle the actual turn on (Click) of the circut. powering the led light usually takes about .5 amps, but powering the turn on switch usually takes anywhere from .5 to 20 amps, then the inital charging of the capacitors that are internal on every amplifier... that quick charge pulls a decent amount of curren fast (usually the first 2-3 seconds) to fully charge a small amplifer after it has clicked on. hopes this helps

Aug 08, 2010 | Sony XM-2002GTR Car Audio Amplifier

1 Answer

Amp lights up, but no power to outputs.


channels mey be burned....does the amp smell like burnt electronics

Nov 07, 2009 | Kenwood KAC-8104D Car Audio Amplifier

1 Answer

Kenwood KAC-8103D short?


probably popped a diode in the amplifier circuit. The thumping sound is most likely power feeding back through the circuit, so it will have to be replaced professionally unless you have acess to the proper soldering equipment for IC boards. Hope this helps, even though it is bad news

May 29, 2009 | Kenwood KAC-8103D Car Audio Amplifier

1 Answer

KENWOOD KAC-7201 Light flickers ..and fan turns on -nothing works


I had a kenwood amp that did almost the same thing. Try checking you zener diodes. I found 2 bad ones and replaced them and amp works fine ever since. If your not to good at diagnosing, I have my own business installing car audio/video products as well as amp repairs. I gaet amps from all ove the place. If interested send me a message, I'll be glad to help. One more thing, I'm the cheapest person in amp repair. Good luck

Apr 20, 2009 | Kenwood KAC-9152D Car Audio Amplifier

2 Answers

KAC-X520 kenwood 1000w amp


a red light indicates you got no power check your wiring you may not have a good ground, you need the green light to come on

Oct 09, 2008 | Kenwood KAC-X520 Car Audio Amplifier

1 Answer

It comes on but


I believe that the amplifier is in protection mode; more than likely you either have an internal short in the amp or a bad speaker running off of the amp.

Jun 06, 2008 | Kenwood eXcelon KAC-X812D Car Audio...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

48 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4889 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

77499 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...