Question about Pool & Spa

Open Question

I have a rite temp model RTN300TQ. Keeps shutting off

Posted by on

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My sta rite will not shut off, it runs all the time, the pool temp is up to 98, i have already replaced the Thermistor. The digital read out on the heater says its on 33 while its actually 98,


I would replace the user interface board. I am assuming you have a Maxithurm heater. The thermister is sending info to the temp comtrol on the user interface. A model would help me to be more accurate.

Apr 29, 2017 | Sta Rite Pool & Spa

1 Answer

Sta-rite heater keeps shutting off?


check gas pressure if ok check flame sensor

May 25, 2014 | Sta Rite Sta-Rite Max-E-Therm High...

1 Answer

I have a Sta Rite 400 btu heater. Replaced the manifold with tall the sensors. Replace the circuit board as well. Heater runs and keeps running just fine. After about an hour the temp in the hot tub...


This is a curious situation. Where is all that heat going if not into the water? If the heater is firing normally, the water temp should be rising much faster, unless the bypass is stuck open. However in that situation the high limits should sense that the water is too hot in the exchanger and shut the heater off. Verify that your gas supply is sufficient, because after running for an hour that heat should show up somewhere. It's possible there may be blockage in the gas supply resulting in a low flame.

Mar 07, 2014 | Sta Rite Pool & Spa

1 Answer

My sta rite pump just shut off on its own in the


need more info is motor hot when it turns off if so the temp over heat circuit is turning it off may need new motor

Sep 20, 2013 | Pool & Spa

1 Answer

My Sta-Rite poll heater doesn't work. The heater comes on when every time I restore power to the unit, the membrain buttons only work to change the temp. ont to shut off the unit, I use the service...


This issue sounds tricky. I recommend you callthe Sta Rite technical support at 888-782-7483 and they should be able to helpyou figure this issue out.

I hope this helps.

Sep 12, 2011 | Sta Rite STA-RITE CONTROL BOARD KIT -...

1 Answer

Ref: Sta-Rite Max-E 400. Pool temp is about 75


Your temp sensor has gone bad and will need to be replaced. It's a small tube that slides into the water manifold and you can follow the wires back to the board. Just unplug and set a new one in place.

May 12, 2010 | Sta Rite Sta-Rite Max-E-Therm High...

1 Answer

Sta rite 400na gives error code 05 after about 30 seconds


I am not sure if you have received an answer to the issue, or not, but just in case! An EO5 error code is an open stack flue sensor, or switch, There are two forms of the stack flue sensor, so you will need to know which one you have on the heater.

What this error code means is that the sensor "read" the flue temp to be over 500 degrees. Usually, it is just gone bad and reading the wrong temp.

Jun 14, 2009 | Sta Rite Sta-Rite Max-E-Therm High...

Not finding what you are looking for?
Pool & Spa Logo

Related Topics:

106 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pool & Spa Experts

Jay Finke
Jay Finke

Level 3 Expert

1343 Answers

Bill Jordan

Level 2 Expert

372 Answers

David Spradling
David Spradling

Level 3 Expert

5743 Answers

Are you a Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...