Question about Royal 29549X Dictionary

1 Answer

My royal r74 won't turn on.

I'm pretty sure that it's frozen. I tried to take out the batteries and put them back in. After I did that, three lights on the side of it turned on. What do I do?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 566 Answers

Have you tried to reset it?
There will be a little hole somewhere for that purpose. Just insert and push an unbent clip into that hole for a few seconds.

Posted on Jul 20, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2006 tribute that won't start, sometimes. The battery has been replaced and the alternator is not putting out quite the correct voltage but isn't really bad yet I don't think. It&


You need to replace the alternator, it may be charging the battery enough to start the vehicle for a few days, but once the battery runs low, it cant recharge the battery, would have the alternator tested, but i'm pretty sure that is your problem. Hope this helps...

Sep 08, 2012 | 2005 Mazda Tribute

1 Answer

1994 Toyota Tacoma PreRunner - won't start with new battery, lights won't come on


Check your battery connections on the battery and the other ends where they go the ground will go to the engine block and the positive to a solenoid make sure all of this is tight and has no corrosion. This is just a loose wiring problem

Aug 18, 2012 | 2000 Toyota Tacoma PreRunner

1 Answer

Acer Travelmate 3270 won't start?


Could be corrupt cmos, bad hard drive, bad memory, bad peripheral.
Remove hard drive and perform diagnostics on it to make sure it is good and not the source of issue.
Then check to see if machine is posting - if not, then you are in deep doo doo because without a posting procedure you cannot repair your OS, install a new one, nada.
A new mo bo will set you back 100 bucks on ebay: installation of mo bo on laptop is one Royal,, Royal PIA.

Sep 18, 2017 | Acer Computers & Internet

1 Answer

My camera is frozen and won't turn off. Can't video or anything.


Take the batteries out; this should shut it off. It should restart normally after the batteries are put back in.

Jun 08, 2012 | Kodak Playsport Zx5 Video Camera aqua

1 Answer

Camera completely frozen. Lens protector open. Won' start with battery or AC power. Performed hard reste, no change.


have you tried removing battery and putting it back in? also what does "frozen" mean specifically? is it frozen in the menu with buttons not working or not powering up at all?

Aug 03, 2010 | HP Photosmart R827 Digital Camera

1 Answer

My dreammaker spa has power and lights but the pump won,t turn on.it makes a sound for a few seconds like it is trying to turn over then it stops.it was recently running .


Sounds like the pump is jammed or the motor bearings are frozen. If you can take it apart, try the pump first. The bearings on modern motors are pretty reliable. Get everything cleaned and lubed and put it back together. Good luck...Lee

Jan 14, 2010 | Dream Maker Spas Dream Maker Ez Spa Hot...

3 Answers

1992 Oldsmobile 88 Royale.... won't start, but all lights come on


Try turning the key to the on postion-not crank, just to he postion right before cranking. leave it in that postion for 15 min, Do this three and after the third time go ahead an try to start it. Hopefully this will reset your security for you.

Aug 29, 2009 | 1992 Oldsmobile 88

Not finding what you are looking for?
Royal 29549X Dictionary Logo

Related Topics:

124 people viewed this question

Ask a Question

Usually answered in minutes!

Top Royal Office Equipment & Supplies Experts

James Cagle
James Cagle

Level 2 Expert

454 Answers

yadayada
yadayada

Level 3 Expert

76649 Answers

Michael Vincent Cruz

Level 3 Expert

868 Answers

Are you a Royal Office Equipment and Supply Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...