Question about Ryobi 30 Cubic Centimeter Gas Brush Cutter

1 Answer

The upper shaft on mine gets really hot also.

The upper shaft gets so hot you can't squeeze the trigger anymore. It's not even a year old.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Contributor
  • 22 Answers

You need to regrease the inside of the shaft, basicly it just has a square flex cable going from the motor to trimmer head and if it is not well lubricated inside the shaft the friction will create a lot of heat.

It'll be a tedeous process of getting grease into it, but that should take care of the problem.

Posted on Jul 19, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Auger clutch lever disengages even though drive clutch lever is squeezed


On mine (Honda HS55) it turned out to be gummy old grease on the shaft and the lever that are supposed to lock the auger lever down. The spring couldn't overpower the sticky old grease. If nudged or given enough time, it would slowly turn and lock, but not instantaneously, as it should.
10 mm wrench to remove the nut (bottom left) and bolt (under handle) holding on the metal cover.
Once cover was off I could see the locking lever, spring, and the shaft that had the gummy grease on it.
The third photo shows the locking lever as it should be engaged. I had to push it to engage it, due to the spring not being strong enough for the gummy grease on the shaft.
There are flat sides on the shaft, behind the threads for the nut that has already been removed. Use a wrench on those to turn the shaft out. Disassemble. Clean. Oil. Reassemble. Works great now.
Another possibility is that your locking lever or spring are broken.
1_zps7a4241d0.jpg

2_zps266fe5e3.jpg

5_zpsb996522b.jpg

6_zps6ca7f90a.jpg

Dec 17, 2013 | Honda Snowblower Cover Silver Hs928,...

1 Answer

Water sprays out from underneath. The water is spraying forward and to the right. Is this a common gasket failure issue? Or do I really need to take it all apart? (sigh) I have so much else I have to do...


i'm sorry to say but if you happen to have a vertical motor you'll be better off buying a new pump for 150.00 online.if you see the casing is made of pot metal which corrodes from the impurities of water mainly chlorine.stay away from pressure washers that have a shaft downward like a lawn mower they much like consumer use only for residential 1 to 3 times a year.find one with a horizontal shaft where you can have a much better chance of getting it fix or get replaceable parts for.feel free to question me i've been in this business for 30 years.
ps a replacement pump with a solid brass head would be better the main killer to these pumps is that they leave the unit running with trigger closed which causes pump tp rapidly heat up and cause failure you must squeeze trigger within 3 to 4 minutes tops so that the heated water in pump head has been released.

Aug 04, 2013 | Briggs & Stratton 2200 PSI Gas Pressure...

1 Answer

Clean water and solution will not dispense


This is an unusual problem. The most likely reason is that the supports inside the upper handle grip have broken, and when you squeeze the trigger, the rod that opens the reservoir assembly is not pushing open the valve. If you remove the upper tank, and look behind it, you should be able to see the end of the actuating rod sitting on top of a rubber valve assembly. Squeeze the trigger and watch the rod to see if it pushes down on the valve. If it doesn't, the upper handle grip will likely need replacement. If it does push down on the rubber seal, the reservoir assembly has probably failed and may need replacement.

Jun 07, 2011 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

Dear Experts, I need assistance from you ppl.I stay in India. I bought a medium quality glue gun and a glue stick. I plugged the gun to the power socket(220v)and waited for the glue to come out of the...


It takes a couple of minutes for the gun to heat up. When you first plug it in, touch the metal nozzle with your hand. It should become obviously hot within 15 seconds and too hot to touch within a minute . After it fully heats up (a couple of minutes), squeezing the trigger should advance the glue stick and push molten glue out of the nozzle. However, there is often an initial resistance to the trigger and you may have to squeeze a bit hard to get it started. If there is a problem with the trigger mechanism, you can also advance the glue by pushing directly on the back end of the glue stick with your thumb. Good luck.

Aug 04, 2010 | Garden

1 Answer

Heater blows cold air. After the truck gets warm if I turn the heat on and off and move the temp control lever from hot to cold and back up to hot it work. Today I noticed the temp gauge went to 215+...


I believe your thermostat is beginning to fail, although the truck really isn't all that old. Still, it is 5 years old, and has been through many heat cycles, so I would change the thermostat. Change--drain completely and replace--the anti-freeze at the same time, and use Dexcool anti-freeze. Check the heater hoses, and make sure neither of them has a collapsed area in it. Lastly, check the water pump--with radiator cap off on a cold engine--start it and warm to driving temperature (takes a long time with the cap off), and look at the coolant at the top off the radiator...is it swirling around the neck (if full), or gushing across the top of the core (if low on coolant)? If you squeeze the upper hose together with your hand while the thermostat is open, can you feel/hear the coolant rushing through it? These things mean the pump is pumping.

Feb 17, 2010 | 2006 Chevrolet Silverado

1 Answer

Cant change blade, holding stem is stuck


holding steem, guess you are talking about the shaft that holds blade.
move the shaft down by squeezing the trigger.if shaft doesnt move you have a trigger problem or motor problem.

Oct 03, 2009 | Bosch Saws

1 Answer

Machine will not brew at all, but is getting power


Are you sure that it isn't getting hot? I am having the same problem, but the plate is getting hot. I think there is a valve inside that prevents the machine from brewing once the plate reaches operating temp (so that the holding pot can't be overfilled). It's my assumption that it is stuck. Fill the reservoir with ice cold water and let it sit as long as possible. I let mine sit a day or two and the machine worked pretty well this whole week.

mine is not even a year old. I bought it 9 months ago.

Jun 04, 2009 | Cuisinart Coffee on Demand 12-Cup...

1 Answer

Squeeze throttle engine doesn't increase/tines don't turn


Most likely the throttle shaft on your carb is stuck from residual fuel. Follow your throttle cable down to your carburetor and see if the shaft is moving when you press the trigger on the handle. If not, try moving it by hand and see if it loosens up. If not you may have to take off the air filter cover and spray some carb cleaner in the throat of the carb while moving the shaft back and forth until it loosens up. That should work for you.

May 05, 2009 | Mantis 2-Cycle Tiller

1 Answer

Leaking Around Spigot, Coffee Urn


I have a Farberware L1360 with the same problem . If there is water in the pot , in about an hour a nice little puddle forms . It is leaking right where the spigot attaches to the body of the pot. I can see a rubber washer squeezing out around this spot. Maybe It melted?
I think it needs some heat resistant washer to replace it. Farberware co. doesnt really exist anymore. you can barely get parts. If the spigot itself works, mine does. I can't see buying a new one if it just needs a washer. Does anyone know what type of washer would be a good replacement?

Jan 09, 2008 | Pasquini Livia 90 Espresso Machine

Not finding what you are looking for?
Ryobi 30 Cubic Centimeter Gas Brush Cutter Logo

146 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ryobi Garden Experts

Nick Olsen

Level 2 Expert

183 Answers

Roland W VanLue
Roland W VanLue

Level 3 Expert

486 Answers

Doctor PC
Doctor PC

Level 3 Expert

7733 Answers

Are you a Ryobi Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...