Question about Peavey PV-3800 2-Channel Amplifier

2 Answers

Peavey 5150 II guitar amp! Power Tubes don't light up and only

Peavey 5150 II Power Tubes don't light up and only preamp tubes 1, 2, 3, and 5 light up. I had this problem before but it was fixed under warranty a few years ago. The preamp main board was burned at a few pins where the ribbon goes to power tube output board there are 7 pins

Posted by on

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

  • Expert
  • 75 Answers

The very same thing just happened to my 5150, it probably is a problem with the heaters, but haven't taken it apart to verify that.

Mudded - did you ever fix this problem? Could you post your solution?
It would save me probably hours of troubleshooting

Posted on May 25, 2010

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Peavey 5150 II has low humming sound but still plays and sounds pretty good...should i re-tube it?

Posted on Aug 19, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Peavey problems


cracked solder joints, how old is it, they have 5 year warranties..

Aug 02, 2014 | Peavey ValveKing 100w All Tube 212 Combo...

1 Answer

Having some negative issues while playing guitar through my amplifier.....


Have you checked all the other amp tubes? You may have a bad 12AX7 or 12AT7 tube.

Aug 02, 2014 | Peavey ValveKing 100w All Tube 212 Combo...

1 Answer

No sound. Screen face lights don't light up. All tubes glow when powered on. The speaker pops when coming out of standy-by into full on state. But absolutely no guitar sound, no auxiliary input sound, ...


If it is within warranty take it back to the shop. If not then its going to need an engineer to look at it. Its not worth fooling around inside a tube amp as the capacitors can retain lethal voltages even when unplugged.

Sep 16, 2011 | Peavey Vypyr Tube 60 Amp Combo

1 Answer

Preamp tubes for XXX amp. How do I choose, and can I replace myself?


Replace with like part numbers... 12AX7's and 12AT7's are common numbers. Unless the tubes have failed heaters, do NOT expect much if any improvement. If the tubes are microphonic and lightly tapping on them produces major noise that would be a reason to replace. Try to avoid getting skin oils on the glass of tubes when replacing.

May 15, 2011 | Peavey Butcher Guitar Amplifier Head (100...

1 Answer

My peavy vk 2x12 have a dirty distortioned sound in the clean chanel, i'd took a look at the back side and i saw the problem could be the 12ax7, one looks ok, one is dead, have no light while is turn on,...


* ALWAYS UNPLUG YOUR AMPLIFIER BEFORE REMOVING TUBES *

If you can see that a tube is definitely not lighting up then it may be blown. If this amp has seen regular use then it may be time for a new set of tubes. Try replacing the 12AX7s first before committing to a new set of 6L6s. Though, if you have the cash available, a new set of power tubes isn't a bad idea either. I would advise you to do the preamp tubes first and play through the amp for a few days first before changing the power tubes.

Keep in mind... if a tube (or tubes) has blown, there could be another issue in the circuit. Swapping in a new tubes is a quick way to determine that. Then it would be time to take it to your local repair shop.

Good luck and keep rockin'!

Feb 21, 2011 | Peavey ValveKing 100w All Tube 212 Combo...

1 Answer

I have a Peavey Valve King 112. When I plug in my guitar I get nothing.The power light is on and the preamp is on as well.There is just silince.No humming or crackling.


This could be anything. You could try swapping the preamp tubes. If it were a power amp tube problem, it is likely the mains fuse would have blown, Since the pilot lamp is still on, we will assume that the problem is at the preamp level. This absence of signal can be caused by a dead tube, or more complexly, by a faulty resistor or capacitor in the signal path. If you can't resolve the problem by swapping preamp tubes with a known good one, you should take the amp to a tech experienced in servicing tube guitar amps. Any good tech should be able to sort this out within an hour of labor time. I doubt it will require any expensive parts. It may even be as simple as a loose/bad connection, either from manufacturing, or from normal use. Pro tube amps are subjected to levels of heat, vibration and electrical stresses that consumer electronic gear never sees.

Oct 06, 2010 | Peavey Audio Players & Recorders

1 Answer

My peavey 5150 2 will power on but no sound....


It APPEARS that the preamp tube heaters are run from DC source while the latter ones and the power output tubes are run on AC.

Check the 6.3 volts AC going to the power amp tube.

That heater power is fed through fuse F2.

I suspect you will find that fuse has a bad fuseholder or is blown. A failure in the transformer is possible and I hope that is not the case.

A heater short in a tube is possible but doesn't happen often. Replace the fuse ONCE only and if it blows again investigate why. Could be bad wiring or a bad socket or an internal short within one of the unlit tubes. Thoose are rare but still possible.

May 08, 2010 | Peavey AMPLIFIER, 1000 WPC, DDT, 8/4/2...

1 Answer

No volume.


Are the tubes bad? Do they light up? Check the tubes and install replacements if necessary. If it's a preamp tube that went bad, just replace that one tube. If a power tube went bad then replace the set of power tubes. Be sure to get a matched set when replacing power tubes, and to bias them.

Aug 08, 2009 | Fender Hot Rod Deluxe Guitar Combo...

1 Answer

Hi, Peavey Classic Guitar amp , Has NO SOUND


Hi Mike,

If you switch on the amplifier, do you hear nothing at all?
Or do you hear low level noise or hum out of the speaker?
Don't know if you're technician.
If the tubes are glowing, you can measure the high voltage.
Check also fuse 3 and 4, thats the neg. voltage -27V and -14V.


regards,
Gerard

Jul 06, 2009 | Peavey Audio Players & Recorders

Not finding what you are looking for?
Peavey PV-3800 2-Channel Amplifier Logo

1,265 people viewed this question

Ask a Question

Usually answered in minutes!

Top Peavey Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5056 Answers

Vito Vacirca Jr.

Level 2 Expert

140 Answers

Steve

Level 3 Expert

3287 Answers

Are you a Peavey Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...