Question about Hoover SteamVac F5914-900 SpinScrub Upright Vacuum

1 Answer

We have a Hover F7411-900 which runs great but for some reason the wash does not dispense the cleaning solution. It works fine on rinse but not on wash. We tried cleaning the round piece at the base of the cleaning solution but that did not fix the problem. How can you repair so that the wash will work.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 97 Answers

That would be the wash silonod, the thing that makes the soap and water mix together in order to make the soap come out at the bottom were the brushes are.

Posted on Jul 20, 2009

  • 1 more comment 
  • pickupguy Feb 05, 2014

    how do I replace it

  • pickupguy Feb 05, 2014

    what is the part number?

  • pickupguy Feb 05, 2014

    what is the part number?

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

It cleans as a carpet cleaner but when pulling the handle down to wash no water


Mine had a clogged heater owing to corrosion in the metal inlet/outlet area. I pulled the handle apart and pulled the hoses off the heater and scraped out the crud, and it's worked fine ever since.
If it's not that, then it could be the pump.
If it is the first problem, ALWAYS run clear water water through the unit for a bit before you put it away after using it. I believe that it is the soap that accelerates the corrosion.
Good luck!

Mar 26, 2015 | Bissell 1699 ProHeat Clear View Upright...

1 Answer

"Power Brush" attachment doesn't work


When my hover suffered a similar issue i found the problem to be a little stone caught in the part you described as a water wheel, however later i found that one of the connecting hoses from the front of the hover had a little blockage , later, i actually washed the filters and left them to dry over night wrapped in a towel on a warm heater, it was back to normal , the last hover gave in as the motor started to slowly give in , it could be this

Mar 15, 2014 | Vacuums

1 Answer

My bissell pro heat 2X has stopped dispensing water from the tank, the suction is working and it seems to be dispensing the detergent, so it is not rinsing or washing with water. I have cheaked to see if...


I have a Proheat 2X and had the same problem. I tried the Water Rinse setting and found water came out and was suctioned properly, but on the Light Clean, Normal Clean, and Heavy Traffic settings, the unit failed to do anything. Problem may be with leaving the soap dispenser in-place, which might scum up the tubing.

SO, an alternative to throwing out my unit and buying something else was to put one capful of the Bissell soap in the water resevoir and keep the unit on Water Rinse. IT WORKS BEAUTIFULLY NOW. Don't know if this will help, but at least I didn't have to buy a new unit. Rinse everything after using and there's been no problem.

Apr 19, 2010 | Vacuums

1 Answer

When I am cleaning carpet, the water spray works


I have a Proheat 2X and had the same problem. I don't know if this will work with your unit... but I tried the Water Rinse setting and found water came out and was suctioned properly, but on the Light Clean, Normal Clean, and Heavy Traffic settings, the unit failed to do anything. Problem may be with leaving the soap dispenser in-place, which might scum up the tubing.

SO, an alternative to throwing out my unit and buying something else was to put one capful of the Bissell soap in the water resevoir and keep the unit on Water Rinse. IT WORKS BEAUTIFULLY NOW. Don't know if this will help, but at least I didn't have to buy a new unit. Rinse everything after using and there's been no problem.

Apr 19, 2010 | Bissell 25A3 Upright Vacuum

1 Answer

When in the wash mode it does nothing, but the rinse works just fine. what do I need to do. I have cleaned this also. Hoover F7220-900 steam vac v2


There are two possible causes:

(1) defective switch in handle (not likely), or

(2) defective electric solution valve in the base of the unit that switches the solution dispense ON and OFF. This requires a major teardown to access, the removal of hood, drive transmission, and the motor cover.

Oct 27, 2009 | Hoover F7425-900 SteamVac V2 Widepath...

1 Answer

No water/cleaning solution comes out on wash cycle


With this model, the soap dispensed is controlled by electric solenoids. these can be tricky to troubleshoot. I would take it to your nearest dealer. these solenoids fail, and cause a variety of symptoms.

Oct 08, 2009 | Hoover F7220900 SteamVac V2 Upright Vacuum

2 Answers

Hoover steam vac..F7452-900. not working in wash-auto rinse mode


This problem sound like you hav a problem with the pump. I would take it to a shop for service

Sep 26, 2009 | Hoover F7452-900 SteamVac Upright Vacuum

1 Answer

Water does not dispense on wash cycle


this would be the soap/ water valve. it is stuck closed or isn't opened.( no cure for an non-opened valve, just replace.)

Jul 16, 2009 | Hoover F7220900 SteamVac V2 Upright Vacuum

3 Answers

Not dispensing water and no suction


I'm assuming the belts are OK.... Your heater is clogged. Unplug the machine and let it sit for 30 minutes. Take the handle apart, there will be a 4 inch by 8 inch metal box inside. This is the heater. Remember I said to let the machine sit for 30 minutes? If you didn't, the heater may be EXTREMELY hot!! Disconnect the two hoses going into it, and clean the metal pieces out (that the hoses connected to) with a needle or very small drill bit. You may want to remove the 6 or 8 screws holeding the heater together and remove the cover to clean it out. Reassemble and fill both tanks with VERY hot water ONLY and run the machine to rinse the entire system.

To prevent future reoccurences... use only Bissell extraction shampoos. Never put anything in the detergent tank except shampoo. (And only water in the water tank) Mixing chemicals with anything else turns the water/detergent mix to sludge. Also, when finished shampooing, put ONLY water in both tanks, and run the machine until one of the tanks run out of solution. Doing this rinses the hose lines out and prevents hardening of the solution in the heater ports.

I've fixed these machine for years. No dispensing is almost always the heater clogged.

Sep 29, 2007 | Bissell 7901-1 ProHeat Scotchgard Upright...

4 Answers

Bissell pro heat cleaner


This could be due to dried out soap in the works below the dispenser. Try cleaning the hole, putting plain water in the soap dispenser to clean it out further. You could just put some soap in with the water. Be sure to run lots of rinse water through afterward to clean out the heating unit.

Aug 18, 2007 | Bissell 7901-1 ProHeat Scotchgard Upright...

Not finding what you are looking for?
Hoover SteamVac F5914-900 SpinScrub Upright Vacuum Logo

Related Topics:

149 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18391 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1460 Answers

Brad Brown

Level 3 Expert

15557 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...