Question about Vacuums

3 Answers

Windsor Sensor Vacuum

The bag full light comes on and after a minute or so, the power shuts off. The bag is new.

Posted by on

3 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Re: Windsor Sensor Vacuum

Mine did this and i took it apart and in the base are two connectors that were rusted...i sanded them and it worked fine after that

Posted on Aug 10, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Re: Windsor Sensor Vacuum

Pull out the wand (while the unit is running). If this turns off the light, then the clog is in the base-- try turning it so you can see the bottom, and there's a door (I've seen some orange and some white)-- check for a clog in there.

If pulling out the wand doesn't help, unclip and pull out the hose at the end opposite the wand. If this fixed the problem, the problem is in the hose.

If neither of the above worked, it's a bag problem or filter problem, or it could be in the motor.

Posted on May 13, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.


    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers
Re: Windsor Sensor Vacuum

Sounds like you have a clog, either in the hose, or the inlet down at the bottom. When there is a clog, the red light will come on and may also shut down to protect the motor.

Posted on Feb 05, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Where is vacuum chamber on a Windsor sensor xp12

it comes up from the back,it is probably plugged or the sensor is dirty

Apr 21, 2015 | Windsor Vacuums

1 Answer

How to fix sensor s12. red light for bag stays on even when vacuum bag is not full and the vacuum is clear

You most likely will need to change the Yoke assembly. There is a sensor built in that gets clogged with fine debris over time. This will take care of the problem.

Feb 09, 2015 | Windsor SR12 Sensor Bagged Upright Vacuum

2 Answers

I have windsor s12 red light for bag is full is on and it's not clogged. what next

Check the line going from the bottom of the vacuum to the bag, it may be clogged. A coat hanger can help you clear any jams, but be careful not to puncture the duct.

Jan 27, 2015 | Windsor SR12 Sensor Bagged Upright Vacuum

1 Answer

Windsor sensor vacuum lights flashing then motor shuts off

I've worked on these a lot. What I think you're explaining is the bypass flow switch which is a common failure. It's located in the base inside the auction side of motor housing...

May 01, 2014 | Windsor SR12 Sensor Bagged Upright Vacuum

4 Answers

I have a Windsor Sensor s12 and power shuts off after 5 min. of vacuuming. I'm wondering if it's overheating of if there is some other sensor that causes it to shut off.

Your Sensor most likely has an internal heat sensor that is shutting off the motor. Some vacuums install an external heat sensor with a reset button that you must push to re-start the vacuum. If your model does not have an external reset button it is most likely a sensor inside the motor. If it is defective the motor must be replaced to solve the problem. But first make sure the overheating is not being caused by a blockage somewhere or the bag is too full. Air must pass completely through a vacuum starting at the floor where it picks up the dirt through all the canisters, filters, bags, etc. and then is exhausted from the vacuum. Any restrictions or blockage can cause the motor to over heat.
That Vac Guy

Jan 04, 2013 | Windsor SR12 Sensor Bagged Upright Vacuum

1 Answer

Vacuum shuts off and on while trying to vacuum

check power cable for brakes and cracks, replace if need be..

Nov 18, 2012 | Windsor SR12 Sensor Bagged Upright Vacuum

1 Answer

My windsor vacuum brush light keeps coming on

You may try a new brush. With these models the light will continuously run to signal it needs the brush replaced.

Jan 29, 2011 | Windsor SR12 Sensor Bagged Upright Vacuum

1 Answer

'Bag Full' light indicates at 1/3 bag

The sensor is a small hole into the vacuum chamber. It moves the alert system as vacuum inside the unit builds up.

The filtration, built into the bag, is getting filled up and creating a higher vacuum inside the unit, giving a false reading. The only ways to eliminate this are to give the bag a shake to clear some of the dirt out of the filter, try to pick up coarser dirt first or buy generic bags-without the filtration.

Jul 21, 2009 | Windsor SR12 Sensor Bagged Upright Vacuum

4 Answers

Windsor sensor says bag is full when its not

Are you vacuuming up fine particals like pet dander or just large amounts of regular dust? Also when was the last time you replaced your filters?

Just some sugestions.

Mar 17, 2009 | Windsor SR12 Sensor Bagged Upright Vacuum

1 Answer

Vaccum doesn't have power.

I had one of these come in for service, a new mainboard was the solution. They're getting power if the lights come on. The board just isn't letting it go.

Best of Luck!

Oct 29, 2008 | Windsor SR12 Sensor Bagged Upright Vacuum

Not finding what you are looking for?
Vacuums Logo

Related Topics:

210 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts


Level 3 Expert

2572 Answers


Level 3 Expert

18257 Answers

Roger Potts

Level 3 Expert

694 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides