Question about MTX 6001 Car Audio Amplifier

1 Answer

I was driving along, enjoying my MTX TC6001 when it started producing very loud constant bass... so I brought the amp back to future shop and had it replaced. The replacement unit was an open box, but I was told that it was inspected and in perfect condition. Once I plugged this into my car system, no bass but my subs started to smoke. Anyone can help with this???

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Its because you romote is crossed over along the car electricals o rewire every hing

Posted on Jul 19, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Mtx mxa 6001 amp cant get it to produce good bass using mtx 5500 subs running a 2ohm load


You seem to have everything in spec. check your crossover points and your speaker wiring. subs may be playing out of phase.
A huge factor is subwoofer enclosure ...if the enclosure is not in spec with sub requirements the subs will not peform great.

Sep 23, 2013 | Car Audio & Video

1 Answer

I have a system installed and i have mtx speakers plus mtx subwoofers i want to know how could i take the bass of the speakers because it sounds horrible when loud


if you turn the bass setting in your radio down it will take the bass out, but may take some of the bass out of the subs as well, if this occurs and you still are not satified, you either have to get a car receiver with a non fading subwoofer preout, or you could get bass blockers for all the speakers you dont want the bass in

Apr 05, 2012 | MTX Car Audio & Video

1 Answer

Im having the problem with my mtx tc6001 amp smoking my speakers I hook up everything and when I turn on radilo speakers jump pop and smoke.


MAKE SURE THE SPEAKERS ARE CONNECTED TO THE AUDIO OUTPUT OF THE AMP AND NOT TO SOME WIRES SENDING DC POWER ........ IF THE AMPLIFIER HAS AN INTERNAL PROBLEM AND IS SENDING DC CURRENT TO THE SPEAKERS THIS WILL MAKE THEM SMOKE ALSO ...... HAVE THE AMP TESTED ON A BENCH IN A SHOP ...
MY GUESS IS IF THE SPEAKERS SMOKED THEY ARE DESTROYED AND CANNOT BE FIXED....... COIL ON THE BACK OF SPEAKERS NOW OPEN ---- SORRY TO TELL YOU THIS...

Jun 29, 2011 | Car Audio & Video

1 Answer

Car stereo


check your amp to see if its on high or low setting in order for it to bump it needs to be on low thats all the bass settings and you shouldnt hear the words come out of your subs

Nov 01, 2009 | Car Audio & Video

1 Answer

Constant sound from subs


I Had the Same Problem I just unplugged my amplifier changed the fuse, also i had a fuse in the battery cable and changed that, unconnected the RCA wires and plugged them back in and then put new fuses in and plugged everything back into the amplifier and it worked again. If that doesnt work get back to me i will try to help you.

Jan 09, 2009 | MTX RT2200 Car Audio Amplifier

3 Answers

Mtx TC-6001 Amps Problem


I had same problem with a TC6001 and get solution from MTX, not send to MTX instead MTX kindly sent a quotation for parts to be replaced, I can tell you what parts need to be replaced if you still need a solution.

Jul 12, 2008 | MTX 6001 Car Audio Amplifier

1 Answer

Mtx


Well it could be that your ears just got used to the bass. It happend to me after about a week of haveing my subs. And make sure that your power wire hasnt got melted somewhere. also that you have good ground.

Apr 13, 2008 | MTX 3002 Car Audio Amplifier

1 Answer

Subs will go off the wall with bass, but not in tune with music.


hi, first disconnect the rca input, then switch on headunit and if the amp produces a constant bass thump it then means it has an internal fault. if the amp idles quietly then replace the rca cable, or try connecting the headunit lineout feed directly to the bass amp, in this way you cud find out if your fault is coming from the headunit or the equaliser. cheers

Nov 23, 2006 | MTX Thunder 8302 Car Audio Amplifier

Not finding what you are looking for?
MTX 6001 Car Audio Amplifier Logo

Related Topics:

178 people viewed this question

Ask a Question

Usually answered in minutes!

Top MTX Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

yadayada
yadayada

Level 3 Expert

76846 Answers

Are you a MTX Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...