Question about Hayward EC50C Perflex Filter w/ 1 HP Pump and Cord

1 Answer

WE have a EC50 system w/1HP matrix. Pump runs

WE have a EC50 system w/1HP matrix. Pump runs fine once it is on. Once turned off at night, it won't turn on in the morning. Can get it on in late morning early afternoon. It's tripping gfci circuit.

Posted by on

Ad

1 Answer

Hayward Matrixs' have a one year warranty.

If it is tripping the circuit that is usually an electrical problem, and has nothing to do with the motor. Open up that back with the motor off and try to turn that shaft with a flat head, if it turns than it is an electrical problem; if it doesn't then contact Hayward directly for warranty information. Hayward is a pain to get ahold of but they are great about honoring their warranties.

The Matrixs' are fairly new and I have yet to see a shaft freeze up.

Posted on Sep 04, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1 hp power flo matrix. When I run the pump without water on a bench it runs fine. I put the hoses back on and run it, it starts slow never kicks into full power and trips the braker. Any thoughts?


It sounds like something is causing the motor to not only have limited torque but also draw more than normal current. It sounds like a problem in the motor but exploratory surgery would indicate the cause for sure.

If you are not wanting to turn wrenches yourself then my best suggestion is to bring it to Leslies Pool Supplies and they often can put it right for the price of the parts while you watch.

I hope this helps.

Sep 18, 2011 | Hayward 1hp Power Flo Matrix Above Ground...

1 Answer

I have hayward 1 h.p. pump cant get it to prime it will pump at a trickle it has to pull 3-4' rise to the pump is this to much height? or is my intake line clogged? or?


The rise is more than ok. You could have a plugged line or a plugged impeller or an air leak. I would look to the suction pipe coming into the pump and the lid and "O" ring on it.

Sep 29, 2010 | Hayward EC50 SYSTEM W/ 1 HP MATRIX PUMP...

1 Answer

Powerflo matrix pump is humming not pumping


I think you have a start/run capacitor issue or your impeller has spun its center out. Check the impeller first. If the impeller is intact, take your motor to your full service pool professional for repair.

Aug 01, 2010 | Hayward 1hp Power Flo Matrix Above Ground...

1 Answer

High psi, low intake and output. That possible?


Thank you for posting your question here on Fixya.com.

High pressure at the filter means the water is held up and not able to freely flow thru, hence the rise in pressure. If repeated bumps and refills are not working your filter fabric is clogged. You can try to wash them (again I assume) and if necessary even try acid washing as well. If none of these works you'll need to replace the fabric or the entire assemblies which is usually near the price of just replacing the filter.

If this answer does not fix your problem, please comment with additional details prior to rating the answer. Positive feedback is appreciated once your problem is solved!

John

Jul 13, 2010 | Hayward EC50 SYSTEM W/ 1 HP MATRIX PUMP...

1 Answer

My new ec50 is clogging frequently. Is at 18 psi


lower the better (psi) this means the water is flowing fast through the filter, high pressures means it's time to clean filter again. keep cleaning until the pool is squeaky clean, then you can go back to cleaning once a week
Jay the pool pump motor repair guy Longwood Florida

Jun 15, 2017 | Hayward EC50 SYSTEM W/ 1 HP MATRIX PUMP...

1 Answer

No water in pump after running for short time


suction side leak... your grabbing air somewhere in the suction line.... take a hose at low pressure and with the pump running put it over various parts of the suction line... including your pump lid... if the problem goes away and you have no more air in the pump then you know what your problem is

May 22, 2010 | Hayward 1hp Power Flo Matrix Above Ground...

Not finding what you are looking for?
Hayward EC50C Perflex Filter w/ 1 HP Pump and Cord Logo

Related Topics:

128 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hayward Pool & Spa Experts

Jay Finke
Jay Finke

Level 3 Expert

1358 Answers

Bill Jordan

Level 2 Expert

372 Answers

john h

Level 3 Expert

12650 Answers

Are you a Hayward Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...