Question about AudioBahn A2300HCT Car Audio Amplifier

1 Answer

I'm working on an audiobahn A2300HCT and it seems to have a dead short in the front end of the power supply (The fets,caps and rectifiers will all have to be pulled, one at a time.Any suggestions?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 655 Answers

Hello rick27,

I'm assuming that you have already pulled the board out and cannot visually locate any out of place looking component and that you've inspected the board for solder bridges, broken pieces of wire, and other signs of FOD.

If this is the board you are looking to troubleshoot, I'd start nearest the fuses and work systematically from there. You can test many components if you just remove one lead from the circuit. Both diodes and capacitors can be field-checked quickly with one lead disconnected.

I'm working on an audiobahn A2300HCT and it seems - 942a8f0.jpg

Posted on Jul 17, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Heeey. I have the Audiobahn A2300HCT and it has a very strange problem. When i start the amp its in the normal blue mode but i have no sound. The one power output (LEFT) indicator shows +3DB (full) the...


My brother just bought an A2300HCX and almost the same thing happen. 1 of the gauges (left side) was no movement. We tryed hooking the amp to the right side, and it works. The Left side turns out was shot, had to get it fixed. So sorry to tell you but sounds like one of the channels has internal damage. I know this isn't the good new you were wanting to hear, but hope it was helpful

Apr 08, 2010 | AudioBahn A2300HCT Car Audio Amplifier

1 Answer

No power ,all fuses are fine


More than likely the power supply has gone bad. I do not know if Denon uses a switch mode power supply or a linear supply. One way to tell is the weight of the amp. Heavy = linear supply and light = switch mode. Common problems with switch mode supplies are the FETs used for switch or the PWM generator (pulse width modulation generator) Linear supplies more than likely would have a bad bridge rectifier or shorted bypass cap on the DC rail.

Feb 06, 2010 | Denon AVR-2500 Receiver

1 Answer

Reversed 12 volt and ground wire when i installed it...now the red light is on AudioBahn A2300HCT


check for a short or burnt trace by the negative (ground traces) on the power side of the board

Jul 04, 2009 | AudioBahn A2300HCT Car Audio Amplifier

1 Answer

HEY I HAVE 4 GAUGE GROUND & POWER THAS WHAT THE AMP ALLOWS. I TRY 0 GAUGE BUT IT IS TO BIG FOR THE AMP. A2300HCT.


Hello again VICENTEMULGA,

Audiobahn's website has apparently been shut down and it's my understanding that they are no longer manufacturing any new products. And not supporting the old ones, online anyway.

But I did find this site that sold the A2300HCT and still have the specifications listed. The 3rd from the bottom in the description shows "1/0- or 2-gauge power and ground leads recommended".

At the very least, you should consider running 1/0 or 2-gauge from the battery to a distribution block and then run a very short jumper from the distribution block to the amp.

May 05, 2009 | AudioBahn A2300HCT Car Audio Amplifier

1 Answer

AudioBahn A2300HCT no sound


Generally, if the amplifier smokes, the power supply FETs have failed.

Many times, the output transistors fail and that causes the power supply FETs to fail.

Audiobahn won't release schematics. The amplifiers are relatively simple and a schematic isn't generally required.

If you know how to check the transistors, check them to determine the severity of the damage. If you don't know how to check them, read through the following page following all links provided.

Basic Amplifier Repair

Let me know if you have any other questions.

Sep 04, 2008 | AudioBahn A2300HCT Car Audio Amplifier

1 Answer

Audiobahn powered subwoofer


yep, they dont make audiobahn any more i think they still make other subs to one of them is DUB subs, ebay is the best place for me to find audiobahn, and for parts...

Jul 24, 2008 | AudioBahn A2300HCT Car Audio Amplifier

1 Answer

Wierd stopped working audiobahn a2300hct


Disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If it powers up normally, the wiring and speakers need to be checked. If it still shuts down, the amp likely has blown output transistors.

Apr 05, 2008 | AudioBahn A2300HCT Car Audio Amplifier

1 Answer

Audiobahn A2300HCt wont work


you might not have enough power pushing the amp.... I have two batteries and two caps running

Apr 02, 2007 | AudioBahn A2300HCT Car Audio Amplifier

Not finding what you are looking for?
AudioBahn A2300HCT Car Audio Amplifier Logo

Related Topics:

193 people viewed this question

Ask a Question

Usually answered in minutes!

Top AudioBahn Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

xxxxxx xxx

Level 3 Expert

4869 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8531 Answers

Are you an AudioBahn Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...