Question about Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

1 Answer

Motor on our kenmore progressive agitator is not

Motor on our kenmore progressive direct drive agitator is not working.I took it to a repair shop and they wanted to replace the agitator motor for 125$. I know it has a thermal protector and a overload protector. couldn't this be the problem? or are they wanting to rip me off? how do i know for sure that it really is the motor and not some 10-12$ item?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 4,088 Answers

Look for a reset button on the motor and press it in. If it clicks, then it was tripped. An excessive load on the motor can make the reset trip. Try turning the motor shaft to make sure that it is not bound up. Run the machine empty for a short time to see if it works. Good luck!

Posted on Jul 16, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No suction motor comes on at all


It should be under warranty. Take it to a warranty repair center

Jan 17, 2014 | Kenmore 31913 Progressive Direct Drive...

2 Answers

Agitator doesnt turn


There is actually a reset button on the agitator, I would try pushing this switch first to see if this fixes it. The button is located on one of the sides of the agitator housing, I'm not sure if it's the left or the right side, or on the top of it.

Look on the sides of the part of the vacuum that is on the floor and see if you can see a small red pole on either side. If you can't find it here, look on the top of the part of the vacuum that touches the floor for a brush overload reset switch.

Try pushing that poll whenever you find it. This switch is a protection mechanism that will shut the brushes down to protect them if something gets vacuum up inside of the brush, it will automatically shut itself off to prevent any damage.

Simply push this overload switch down, and this should hopefully fix your problem.

If this didn't, please let me know and I can walk you through some more advanced troubleshooting.

If this was helpful, please be so kind and rate my repair, or leave feedback.

Thank you!

Chris Jones
GoVacuum.com

May 18, 2010 | Kenmore 31913 Progressive Direct Drive...

1 Answer

My vaccuum has no more suction


There is no drive belt on a progressive drive vacuum. It is direct drive meaning it is attached via the motor. No vacuum means no air flow somewhere in the unit. Torn bag,Wrong bag, pluged filter under bag.Make sure the opening in the bag is the correct size,too big and it will not seal. Make sure when you close the housing it seals also. No housing seal no vacuum. Kenmore vacuums tend to be plastic housings. Cracks are comon in the wheel housing area. Check there first. Plastic expoxy will work with this fix if so needed.

Feb 22, 2010 | Kenmore 31913 Progressive Direct Drive...

1 Answer

Sweeping part of the vacuum stopped spinning.


Is the belt stretched or broken? There needs to be a (not-stretched and not broken) belt connecting the rotating brush (agitator) to the motor pulley on the vacuum.

May 05, 2009 | Kenmore 31913 Progressive Direct Drive...

1 Answer

I have a kenmore progressive direct drive handi mate jr. upright vacuum. My daughter used it last night to vacuum up some cat litter that had spilled on the floor. I went to use it today and it turned on...


its probably clogged up with cat litter.might have gotten into the motor.your motor has a motor guard inside if it. when it overheats it will shut down till it cools off.you need to clean all th cat liter out of it.and clean the filters.with a direct drive you might want to take it in to a repairman to sevice. its not a shop vac i advise you not to pick up things like cat liter

Apr 28, 2009 | Kenmore Vacuums

2 Answers

Kenmore progressive/direct drive-- roller stopped turning


We have the same vacuum & had the same problem. As the vacuum ages & the hose is periodically removed from the nozzle to use with the attachments, the white switch, adjacent to the nozzle connection, wears. If the hose is not fully reinserted or if the attachment notches are inadvertently aligned with the white stitch, the agitator may not work reliably. Assuring the hose is fully inserted, with the locking notches away from the switch has eliminated this problem with our vacuum cleaner.

Jan 24, 2009 | Kenmore 31913 Progressive Direct Drive...

1 Answer

Agitator wont turn


Some of these have a resetable circuit breaker, if it has one, push it. There is a motor on the brush roll which could be bad. There also is an on/off switch, it may have a problem.Also may have a switch where the hose goes into, some models have a actuator for the switch, when the hose is pushed in, it actuates the switch so the brush roll motor turns on and stops when you pull the hose out.

Sep 03, 2008 | Kenmore 31913 Progressive Direct Drive...

1 Answer

Bad Motor


That dust is from the carbon brushes on the motor. You may need to check them, and also clean out the motor compartment. A slight noise could be a motor bearing starting to go. Does the smell like rubber or electrical. If rubber, then the belt has stretched and needs to replaced. If electrical, then something is causing the motor to run hot, like a clogged filter, or it could be a motor going bad.

Dec 19, 2007 | Vacuums

Not finding what you are looking for?
Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum Logo

700 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18390 Answers

kakima

Level 3 Expert

102366 Answers

yadayada
yadayada

Level 3 Expert

75744 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...