Question about Televison & Video

1 Answer

Mitsubishi vs60719 dead pictuer tube leaked looks like it is green tube wet singal broad & power broad no blow fuses reraly dont trick

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 668 Answers

The Cooling fluid is a glycol based and is very conductive and corrosive. If it leaked on the Signal board the board will need to be replaced as well as the Green CRT. I would look very close to the other two CRTs for any signs of leaking. The cost will probably be too much to invest into this set especially when there is no guarantee that the other two CRT,s will not leak in the near future. There is also a good chance that Mitsubishi no longer has the Signal board available. You can check at
1800-553-7278.
I hope this helps,
Skyassoc

Posted on Jul 16, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Amp keeps blowing fuses


Blowing fuses, was caused by many thing.
Short of rectifier,resistor,elco,tube heater,tube pin, and also trafo itself (primary or secondary winding). It must check step by step.
CAUTION :
THIS IS HIGH VOLTAGE AREA.
RISK OF ELECTRIC SHOCK THAT CAN KILL.
DON'T DO THIS IF YOU ARE NOT TECHNICIAN OR NOT FAMILIAR WITH VACUM TUBE CIRCUIT. THE CIRCUIT MAY STILL CONTAINS ELECTRIC SHOCK EVEN IF IF THE AMP IS NOT POWER PLUGGED.


The simple steps (see picture) are:
  1. Disconnect all connection from secondary of power trafo (PLV,PDCH,PACH and PHV).
    Power ON the amp. If fuse is not blowing,trafo is good.
  2. Power OFF the amp. Unplug the cord.
    Connect PLV1-PLV2-PLV3 (this are Bias voltage,+/-15VDC and Backlight PCB voltage) to power trafo.Power ON the amp. If fuse is not blowing,PLV circuit is good.If fuse blowing,there are parts is damage (dioda,elco,7815/7915,resistor) in this PLV circuit.
  3. If step 2 is good,go to next step.
    Power OFF the amp. Unplug the cord.
    With PLV circuit stay connected,connect PDCH 1-2 and PACH 1-2 to power trafo. Power ON the amp.
    If fuse is not blowing,PDCH and PACH circuit is good and all tubes heater/filaments are lights after a few seconds.
    If fuse blowing,there are parts is damage (dioda,elco,tube heater pins) in this PDCH/PACH circuit.
  4. If step 3 is good,go to next step.
    Power OFF the amp. Unplug the cord.
    With PLV,PDCH,PACH circuit stay connected,connect PHV 1-2 to power trafo.
    Power ON the amp. CAUTION: HIGH VOLTAGE AREA is ON.
    If fuse is not blowing,PHV circuit is good.
    If fuse blowing,there are parts is damage (dioda,elco,tube pins) in this PHV circuit.
.amp-keeps-blowing-fuses-01sk4vtrndbaaguwe2brflsj-5-0.jpg
Notes:
  • Steps had to be done sequentially from 1 to 4, not upside down.
  • If tube/heater pin is short,it can't be repair. The tube must be replacing.
  • PDCH circuit is voltage for V1-2-3-4 heater/filaments.
  • PACH circuit is voltage for V5-6-7 heater/filaments.
  • Always replace fuse with same type.

amp-keeps-blowing-fuses-01sk4vtrndbaaguwe2brflsj-5-1.jpg

Oct 02, 2015 | Peavey 6505 Plus 120W Guitar Amp Head

1 Answer

Mitsubishi WD62725 TV doesn't come on


Check and recheck that all connections are secure. Look on the circuit boards to see if anything looks wet. That would be fluid leaking from one of the tubes. One of the parts you put in may have issues. Check your voltages.

Jan 28, 2015 | Mitsubishi WD-62725 62" Rear Projection...

1 Answer

Turn signal & flashers stopped working on '95 geo tracker 2wd, 5 speed.


old post 95 tracker.
ALL four corners dead and dash (warn lamp dead) in cluster
do you hear i flash, click click????
first is fuses, but there are 2 .
http://www.fixkick.com/power-elect/95%20electrics/all-lamps95b.pdf


page 2 see that.
are the 2 blink/has fuses good. test good not just LOOK good
after all if a feed is shorted you will blow both. (tested)

the blinker module ,usually dont fail
its electronic and robust.
fuses good, then
the black wire ground cut or rusty a body
G200 it uses, and if bad usually kills the engine.
yellow-white must be 12vdc blinks on. key on
switch is bad. i bet this is ok
the relay green is OUTPUT
if the blinker has power it clicks
if it green wire flashes with test lamp the blinker module is good
if the output of the blinker switch is dead L and right
the switch is bad.
assumes both left and right sides not shorted. to ground.

Feb 16, 2014 | 1995 Geo Tracker

1 Answer

I recently purchased an Orange AD5 amp. It came to me dead so the store I bought it from told me to try to change the fuses for this amp is becoming rare and hard to get. I replaced both fuses with the...


Check for burned components, broken wires or cracked insulation on wires. Inspect the tube sockets and circuit boards for carbon tracks. Next, check the power supply rectifiers for shorts.

If you don't find anything, pull out all of the tubes (be sure to document where each tube goes!) and see if the fuses still blow. If they don't, one of the tubes has an internal short. (If the fuses blew only after warm-up, it would be an overload on a tube rather than a short through the tube.)

If this was a solid-state amplifier, I'd suggest checking the audio output driver transistors - this is the most common fuse-blowing failure in those.

Feb 13, 2011 | Orange Amps Orange Amplifiers AD Series...

1 Answer

I need to know what fuse is for the power locks on my 1997 golf


Take the lid off the fuse box (Which is on the side of the dashboard)

There is a cardboard panel showing the fuses and their application , you need to look for the one with a key symbol

The fuses are colour coded thus

Light Brown 5 amps
Red 10 amps
Blue 15 amps
Yellow 20 amps
Green 30 amps

If you look at the top of the fuse it will have open circuited and there will be a visible gap

If the fuse blows as soon as you put the power back on you have a dead short

Do not exceed the rating , otherwise you may cause a loom fire

Jun 03, 2009 | Volkswagen Golf Cars & Trucks

1 Answer

I had a power outage and now the tv will not power on. This is for a 55" Mitsubishi WS-55511. no green blinking lights.


Hi,

You may have a blown fuse. Unplug the TV and remove the back. Look for a small fuse near where the power cord goes in.
If it is blown that may be the problem.
Use a magnifying glass to read the AMP rating.
replace the fuse and plug it in. If the fuse blows again you need expert repair services.

If the fuse doesn't blow then try to turn it on.
If it turns on then check the operation of the TV.

If the fuse blows again or the TV won't work correctly then you need expert repair service to fix your TV.

You may be able to have your household insurance pay if it is damaged by lightening or a power surge.

Lee

May 02, 2009 | Mitsubishi WS-55511 55" Rear Projection...

1 Answer

Can't get tv to turn on


have you checked the timer for your tubes some models have a fuse that blows when the tubes blow / time out dont take my word for it though as i only know enough about electronics to get me by

Jan 20, 2008 | Mitsubishi WS-48513 48" Rear Projection...

2 Answers

Beer Spilled on my Power Acoustik PS2-820 Amp


Hi , now that you have the amp apart , just check the underside of the printed circuit board and check for any corrosion ,rub it with a soft brush . then try connecting without speakers . see if it still blows fuse, if it does then there is a likelihood that your mosfets / outputs may have shorted the first time you reconnected it . Good luck

Mar 21, 2007 | Power Acoustik PS2-820 Car Audio Amplifier

Not finding what you are looking for?
Televison & Video Logo

Related Topics:

169 people viewed this question

Ask a Question

Usually answered in minutes!

Top Televison & Video Experts

The Knight
The Knight

Level 3 Expert

74118 Answers

Cindy Wells

Level 3 Expert

5101 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

6694 Answers

Are you a Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...