Question about Amplifiers & Preamps

2 Answers

Problems with the Operation circuit on Technics SU-A900 MKII aplifier.

Does anyone know what the problem is with my amp? When I turn it on, the operation light no longer comes on and thus the amp doesnt come on.
I've had the same problem before on an earlier Technics amp.
Was wondering if this was a common fault?

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Re: Problems with the Operation circuit on Technics...

Did your amp make a bang and then the problem started ?

Posted on Dec 15, 2007

Re: Problems with the Operation circuit on Technics...

Hi There Cushy,

The Amp needs Power.....and if the power switch is turned on and the light doesnt come on then there is no power....

Have a good look around the back of the amp and see if you can find a fuse please...

Its a small circular plastic item labelled "FUSE" with a screwdriver slot in it..

Turn the power off at the wall socket then unscrew this fuse holder, the glass / ceramic fuse will come out,,, replace it with one of the same physical size and of the same rating probably 1.5Amp.

Turn the amp back on and it should go if not then there is a major failure inside the case.....Needs a serice call Im afraid....

Cheers From YUBEUT

Posted on Nov 18, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Su-2760 will not work. gets a flash of power, turn off

Sounds like the safety circuit is tripping cutting off the power. Most probable cause a short circuit on the main power amp board, causing an overload.

Apr 01, 2014 | Technics Amplifiers & Preamps

1 Answer

Technics Amplifier SU-V4

The clicking sound will be a relay for the protection circuit. That could be faulty, but first check out the main devices on the main amp section. Those attached to the big heat sink. If you see a single IC amp that could well be faulty.

Oct 04, 2013 | Amplifiers & Preamps

2 Answers

I need an Operator Manual for a Technics Amplifier SU-600

I have the User manual of Technics SU-600 in pdf format. If you can sent your email address the i will sent you the manual.Its not possible to sent the manual through this site as it is a pdf file.

Oct 26, 2011 | Technics SUV500 2-Channel Amplifier

1 Answer

Technics amp SU-X999. I need an output I.C type SVI-4004

NAother option is to fix a universal amplifier kit into the set which powers from the same voltage preferrably a MOSFET drive which are very much available in the market and can be suited into the set. They will alos be very effficient but take care tto do the fixing mechanically , connecct the right power and groung with good shielding. Disconnect the old amp totally and use the power lines that come to the IC. I hope this works for you. Good day

Jul 30, 2010 | Technics Amplifiers & Preamps

2 Answers

Su-v55a technics amp cuts off when volume up to 2

usually meens it is protecting itself from destruction
check your wires and speakers for problems

Feb 09, 2010 | Technics SUV500 2-Channel Amplifier

1 Answer

Technics amplifier su-v98, cuts off at 22-24 desibls

The most common cause of this is defective coupling caps inside. These allow some DC voltage to pass through to the final amp stage. This DDC voltage is detected by the protection circuit and the unit shuts down. This unit will require service. Please note that this should be a simple and inexpensive repair. The cost should be less than $10 for parts.


Jul 04, 2009 | Technics SUV500 2-Channel Amplifier

Not finding what you are looking for?
Amplifiers & Preamps Logo

Related Topics:

332 people viewed this question

Ask a Question

Usually answered in minutes!

Top Amplifiers & Preamps Experts


Level 3 Expert

4518 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

The Knight
The Knight

Level 3 Expert

66552 Answers

Are you an Amplifier and Preamp Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides