Question about Kenwood Excelon KAC-X621 Car Audio Amplifier

1 Answer

Kac - x621 is reading 99.9a current - Kenwood Excelon KAC-X621 Car Audio Amplifier

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 578 Answers

WHAT HAPPEN AT 99.9

Posted on Aug 07, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Technician can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Technician (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Where is the ground connection on a kenwwod kac 728s


if u lay it down where u can read it right to left it would be on the left hand side. the ground would be in the middle of the three connection points

Jan 04, 2012 | Kenwood KAC-728S Car Audio Amplifier

1 Answer

Amp is flashing a e-02 error


This means the unit has failed and direct current is being generated to the speaker output. Try turning the power off and releasing the protection. If that doesn't work, you will probably need to take it in to an audio specialist because there is an internal problem with the amp.

Feb 24, 2011 | Kenwood Excelon KAC-X621 Car Audio...

1 Answer

X621 excelon amp has red light on, stoped workin all of the sudden now a minimum sound exports with a bit of static. do i reset it? what do i do and how?


If disconnecting all power wires, and replacing all fuses (including inline ones) doesnt reset it. then its toast. Hate to break it to you :( Contact the manufacturer if you feel it is under warranty.

Apr 14, 2010 | Kenwood Excelon KAC-X521 Car Audio...

2 Answers

My subs/amp are not working


when you car is running, it charges the battery somewhat. So the voltage problem is not a problem. The red light means the amp is going into ''Protect Mode". This usually happens when something is wrong with the amp. Usually the amp is getting hot. Check all of you connectiong and check the final impedance of the subs. Make sure the amp can handle the impedance of the subs. If you need anymore help, message me.

Feb 12, 2010 | Kenwood Excelon KAC-X621 Car Audio...

1 Answer

No sound and current read 0 amps reads 0 it is installed correctly it was workin before then quit the volt indicater started blinkin now the light is constant but no sound the volts reads 12.1


Check the fuse on the unit first, if fuse is good and you have power to the am you may have fried it. This is common when the speaker load is not adhered to prperly. Make sure your speakers are connected properly (2/4/6/8 ohms) and not exceeding the limits of the amp, this fries them 99% of this time.

Sep 04, 2009 | Kenwood KAC-X541 Car Audio Amplifier

1 Answer

No sound from my woofer


Check your speaker connections... try using a multimeter set to "OHMS" and see if the speaker is reading around 4-8 ohms... if it shows no reading there is no continuity in the coil of the speaker

Mar 24, 2009 | Kenwood KAC-929 Car Audio Amplifier

1 Answer

No sound flashing e-02 in window


Turn power off this will release the protection turn power back on if code is still flashing contact kenwood dealer

Jan 04, 2009 | Kenwood Excelon KAC-X621 Car Audio...

1 Answer

No power turn on??


Does the voltage at the battery drop when you connect 12v to the remote terminal?

If not, there is too much resistance in the power/ground wiring.

If the voltage drops at the battery, either the battery is weak or the amp is drawing excessive current.

Dec 03, 2007 | Kenwood KAC-728S Car Audio Amplifier

1 Answer

Kenwood kac x621 kenwood kac6402


May i suggest removing the equilizer unless you can adjust the settings for each amp seperatly. The amps themselves will allow you to add bass boost and treble boost. I think the problem your having is trying to run to much bass through your system causing it to distort badly.

Feb 25, 2007 | Kenwood Excelon KAC-X621 Car Audio...

Not finding what you are looking for?
Kenwood Excelon KAC-X621 Car Audio Amplifier Logo

Related Topics:

48 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4886 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

77202 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...