Question about MTX Thunder TA7801 Car Audio Amplifier

3 Answers

The red light on my amp keeps coming on and it wont work

All my wires are hooked up correctly but when i turn my car on the red light comes on instead of the green and the amp wont work what should i do about this other then gettin a new amp...

Posted by on


3 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.


    An expert who has achieved Level 3.

  • Master
  • 505 Answers

Sounds like you blown it mate

Posted on Jul 18, 2008

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that got 5 achievements.


    An expert whose answer got voted for 20 times.


    An expert who has answered 20 questions.

  • Expert
  • 109 Answers

Red light represents protection mode which is usually related to either bad woofers or too low of an impedance. It also can mean that you have blown the amp due to either of the above.

Posted on Jul 17, 2008

  • Level 1:

    An expert who has achieved level 1.


    An expert who has answered 20 questions.


    An expert that has over 10 points.


    An expert whose answer got voted for 2 times.

  • Contributor
  • 33 Answers

You need to check your woofers. Most likely one or both may be a) blown or at a dead short or b) the ohm rating on them may be too low. What model woofers and amp do you have??

Posted on Nov 17, 2007

1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

Cant get the power to work on a xd1222

If the radio is correctly installed and, there is no power on the vehicle's accessory wire when the key is turned on, check the vehicle's radio fuse. If you connect the red to constant 12 volt along with the yellow radio memory wire the stereo WILL NOT TURN OFF. There is nothing strange about that.

Oct 14, 2012 | Dual Electronics XD1222 Car USB Player

1 Answer

The Ground wire is hooked up right but the red light wont go off and stay green so the amp will work. It is very frusterating all the cables are the right size its is a 1000 watt amp. I have two 500 watt...

Sounds to me like the amp is going into protection mode. Try placing one sub on the amp with very little gain. One of the biggest reason why this happens is because the subwoofers are wired wrong. What is the brand and model number for your amp?

Apr 14, 2011 | Car Audio & Video

1 Answer

Sony xplod amp won't work it stopped for no reason

try hooking the amp up with 3 wires, the red power wire, the black ground wire, and the remote wire, do not hook up the speakers at this time

Apr 25, 2010 | Car Audio & Video

3 Answers

The saftey red light keeps coming on

It means that the subwoofer is blown. The red light is called the Protect light. Disconnect the speaker wire from the amp and then turn the amp on and see if the red light goes away. But if as soon as you hook the speaker wires back to the amp and the red light turns on that DEFINATELY means the sub is blown.

Apr 04, 2010 | Cadence TXA 1000D High Power Mono...

1 Answer

Amp will not come on ,no light

Yes!!!!!!!!!! Your remote wire is what tells your amplifier to turn on and off it won't work without it. Assuming your stereo headunit is an after market unit it has the correct wire for this. what you have to do is pull out you headunit, and in the back of the headunit where all the wires plug into your unit there is blue wire with a white stripe. this is the remote turn on wire. connect a wire to that blue n white wire and run it back to your amp, insert it into to the spot marked remote. turn your head unit on and your amp will power up... if you have all the rca cables hooked up your amp should be ready to go.... btw good choice on the amp, kenwood is the way to go!

Aug 31, 2009 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

Amp won't turn on

disconnect audio inputs and outputs and see if one of those are causing it , if it still does it with all audio inputs and outputs disconnected then there is a problem with the power amp

Oct 08, 2008 | Lightning Audio B2.300.2 Car Audio...

2 Answers

Sony xplode 1000 watt amp

Make sure you don't have a short circuit somewhere. Make sure the wiring is all intact.

Also look at this link:


Nov 07, 2007 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Concept CC-2502 Car Audio Amplifier

The amps are probably going into protection mode. The wires are most likely not hooked up correctly. Make sure you have a good ground, good power source, and the remote wire is run correctly. Also make sure the speaker output wires aren't touching each other, and you have the correct ohm load for the amp. What kind of speakers/subs are hooked up and how are they wired?

Sep 20, 2007 | Concept CC-2502 Car Audio Amplifier

Not finding what you are looking for?
MTX Thunder TA7801 Car Audio Amplifier Logo

Related Topics:

376 people viewed this question

Ask a Question

Usually answered in minutes!

Top MTX Car Audio & Video Experts


Level 2 Expert

150 Answers


Level 3 Expert

77932 Answers

Mark Skinner

Level 2 Expert

77 Answers

Are you a MTX Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides