Question about Audio Players & Recorders

1 Answer

Amp's lights come on, but no sound from speakers

I got this amp froma friend who didn't want to work on it due to no time. So I first changed the two fuses up top as soon as the cover is off as these were blown...now I get lights, but no power to the speakers. I noticed the 4 fuses on the panel in the middle of the receiver were blown also. I changed these and it seems to still have the same issue. For one, I am not 100% sure I am wiring this correctly. Can I use the ''preouts'' of a tape deck? This is being hooked up to a old Sony Rec.

Posted by on

  • 2 more comments 
  • espositos Jul 15, 2009

    Dan, thanks for the response. It is a Yamaha M85. Do you think replacing the fuses will fix it?

  • espositos Jul 15, 2009

    Dan, thank you.
    It is a Yamaha M85. Do you think the fuses will fix the problem?

  • espositos Jul 16, 2009

    Thanks Dan. Where are the outputs? Also, are they hard to replace? Would this be worth to get fixed?

  • espositos Jul 16, 2009

    Dan, Thanks. What do the Output things look like? Also, are they are hard to replace? Is this something I can do or should a pro do this change?

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 4,234 Answers

It sounds like the output transistors are faulty and that they took out the fuses when they failed. At this point the protection circuits are kicking in and preventing the output section from turning on. Can you please reply to this and post the make and model? That will help me to give you some information about what is needed for the repair.

Thanks,
Dan

Posted on Jul 14, 2009

  • ABRsvcs Jul 15, 2009

    Replacing the fuses is not likely to fix it. If you can replace them, go ahead. I have not seen one of these repaired that way, but anything is possible. In all likelyhood, the outputs will require replacement. I will try to locate the service manual for your model and post additional details.



    Dan

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Legacy 1000w 2 channel amp worked awesmoe then just stopped working after a few songs. Didn't turn up too loud. Didn't have the settings too high. still getting power (amp light on, led lights...


Open your speaker box up most likely the jumper from the inside of the box to the subwoofer itsself is broken free, Usally when they have lights around the sub woofers there seperate leads, bet 10-1 you have loose wires inside the speaker box

Mar 25, 2013 | Legacy Audio ICON LA2770BK 1000W 2-Channel...

1 Answer

MTX 8302 sound just quit on front speakers


hi Dan....Have you had any other service or installs shortly prior to the onset of clipping? In any case, the 8302 has Onboard Thermal Protection which is kicking in due to excessive heat. If you've had this running fine for a period of time, by that I mean at least a month, then we need to focus on why you're suddenly overheating......please update your post with any further information and progress.....good luck my friend

Aug 04, 2007 | MTX Thunder 8302 Car Audio Amplifier

1 Answer

Brand new pioneer 820 watt amp worked for about ten minutes, now the speaker output light flashes on and off


You didn,t have the sub wire up properly, End fried the output transisters in the amp. Or it was not set (Properly)

Nov 05, 2012 | Pioneer Car Audio & Video

1 Answer

I have a HD 203 .. the right side speaker is not giving any output , the left is still working though...so do i have to change the speaker or the wire's or it useless and i have 2 through them awa


have a friend come over with their phones and plug in. if the same problem persists its the amp and it blew that channel. no problems then get new phones save old ones for parts.

Sep 16, 2012 | Sennheiser HD203 Headphones

1 Answer

I have a Legacy Predator 2000 watt amp with 2 12'' Kicker speakers. It has been in my car for about a year now, and it recently just stopped working. I have the green light to the amp, im not sure about...


If you have checked your ground, live, remote and RCA's, The problem may lie with your kicker speakers.
There may be a loose wire connection on the speaker terminals (hense no sound).
Check the terminals at the speaker (+) and (-) then check the speaker wires to your amp inputs.
Usually if there is a fault with any wires linked to your amp, the amp goes into protect mode.
If your amp is not going into protect mode, try linking a different speaker to each terminal on your amp (left) then (right). If you get sound through a different speaker, more than likey your speaker wire to your kickers has came loose (due to vibrations) or there is a break in your speaker wire.

Hope this helps. If any more info is needed I'd be happy to help more. Please rate if helpful

Mar 18, 2011 | Car Audio & Video

1 Answer

Red protection light stays on all time....


try disconnecting one at a time each speaker till the red turns to green. One of your speakers may be bad. Amp is just telling you that its clipping and overheating due to the change in ohms of a shorted or bad speaker. Its also possible the amp is on its last leg due to heat. Heat breaks down electronics part and eventually get worse.

Apr 05, 2010 | Car Audio & Video

1 Answer

Line 6 spider 210 volume problem


The bypass switch in the headphone jack is likely broken. NEVER unplug the headphones while the amp is on.

There are certain small amps that have a possibilty of popping the power amp due to a feedback arrangement. Likewise, never use the headphone jack for ANYTHING other than headphones.

Dec 20, 2009 | Music

1 Answer

Only a steady pulse comes out of my bull power


hello, it seems that you may have a bad ground on your amp? turn everything off(pull amp fuse at battery) and go to the amp ground and clean paint away to bare metal! secure ground tight and make sure the car battery is not low voltage! this may stop the pulse! the sound problem of no sound in speakers, if still there! make sure the speakers are not shorts or pinched to ground! this could damage the amp! hope this helps, good luck!

Jun 12, 2017 | Magnat Bull Power Reflex 300 Car Subwoofer

1 Answer

Car audio


hi, your amp seems to be getting power but the cables might be wrong so it's not getting enough power. the light on the amp should be green if everything is going well. are you sure the cables are suitable for your amp?

Sep 11, 2007 | MTX RT202 Car Audio Amplifier

1 Answer

No sound


as u have speakers with u u connect another speaker in to the sub connection and reduce the volume to min and check if sound is coming use another wire to connect the speaker to the amp and if it is working u check the cable then the sub it would have burned off due to some internal problems and it has to be checked by a technician this problem may be due to wire broken or something like that

Jul 03, 2007 | Jl Audio 500/1 Car Audio Amplifier

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

187 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

5190 Answers

The Knight
The Knight

Level 3 Expert

74459 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...