Question about Vacuums

2 Answers

Poor suction on carpet

Suction through the hose it fantastic but when I try and vacume the carpet the suction is poor and the motor gets quite warm

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Re: Poor suction on carpet

I just pick this one up from a garage sale and it had the exact same problem. No the belt is fine. There didn't seem to be anything stuck in suction tube path. I did find that the carpet height selector was on its highest setting. When I adjusted it down to a lower level the suction and cleaning ability greatly improved. I am going to try this for a while. It would be nice if this is the solution to the whole problem.

Posted on Mar 20, 2008

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that gotĀ 5 achievements.


    An expert that hasĀ over 500 points.


    An expert who has answered 200 questions.

  • Expert
  • 298 Answers
Re: Poor suction on carpet

Did you check to see if brush is spinning ,
is belt broken? It could be something stuck
in the mechanism in the impeller, shute,etc

Posted on Nov 16, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Chess piece lost in shark navigator rotator

You must extract the chess piece or else it could move within the unit and cause further damage. If you cannot open the shark and get to the intake section, then have a service do it for you.

Feb 26, 2014 | Shark Helmet NV22L Shark Navigator Upright...

1 Answer

Eureka pet expert vacuum lost suction

I had the same problem with exact same vacuum, was working great and the one day just lost almost all suction in the hose and in very very poor suction on base when vacuuming carpet, also when vacuuming the carpet everything I vacuum shoots out the bottom and hits my feet, never happened b4, checked all hoses and tor apart every thing to see if their war dust in motor, clogging anywere but nothing everthing looked great, NEED HELP CANT AFFORD TO BUY ANOTHER VACUUM OR TO TAKE TO REPAIR MAN TO B CHRGED AN ARM AND LEG, SOMEONE PLEASE HELPPPP!!!!!!!!!!

Jun 05, 2012 | Eureka 3276AZ Pet Lover Bagless Upright...

1 Answer

Dyson hose does not produce alot of suction when extended.

Hi its Darran at Dyson.

It sounds as though the wand/hose is blocked. with the machine locked in the upright positino, remove the hose from the machine, switch on and test the suction. If the suction is poor, remove the wand from the hose and test the suction from the top of the hose. If the suction is strong, you will need to check the wand for a blockage. If the suction is still poor, check the hose for a blockage.

You may find it useful to wash the filter as this can sometimes cause a drop in performance if its dirty and it wuold be more noticable from the hose.

I hope that this information is useful to you.

Kind regards
Dyson Customer Service

Feb 19, 2010 | Dyson DC14 Animal Bagless Upright Cyclonic...

1 Answer

No suction.

Poor suction can be caused by obstructions, poor air flow or a compomise in the air flow (hole in the hose). Since you have started with that I would next look at all filters and clean them. First check for suction at the motor, then at accessory hose and then the base. this will lead you to a suction issue. If your baelt has not been replaced in the last 6-12 mo I would change that too. check to make sure your carpet setting is coorect for the carpet being cleaned.

Oct 15, 2009 | Vacuums

1 Answer

Suction/Brush not working

Hi there SmartAlec from here.
There are a couple of common reasons that your electrolux vacuum cleaner would appear to have lost it's suction. The first and most common is that it has actually broken a belt. If the belt is broken the brushes won't spin and it will not pick up dirt. It is easy to test simply turn the vacuum on, release the handle (as if you were about to vacuum carpet) and lift up the head and see if the brushes are spinning. If not i can supply you with a new belt.
If the brushes are spinning then your next most likely cause is that there is a blockage in the vacuum somewhere. Test this by turning machine on and checking the suction at the hose (as if your were going to vacuum the couch) if it is poor then remove hose and fish out blockage. If it is ok you may have a blockage between hose and the brush of the vacuum.
If it is neither of these problems i can trouble shoot over the phone if you live in Australia 0269215200 or by email
Happy Vacuuming.. :)

Aug 25, 2009 | Electrolux EL5010A Bagged Upright Vacuum

1 Answer

Hoover Tempo Widepath 12 AMP, poor pick-up and suction. Fantastic suction at the attachment hose though.

Could be blockage in hose,, try straightening out the hose,,and shove a broom handle down there,,,,if there is no bend!! and clear the blockage out.

Jan 16, 2009 | Vacuums

1 Answer

Bad suction on bissell powerforce bagless vacuum

I took the bottom apart and it needed a new belt and that was the problem so it's fixed.

Jan 16, 2009 | Bissell 6594 PowerForce Bagless Upright...

1 Answer

Losing suction filter clean,hoses clear,output blower good,but very poor suction

if the blower is much stronger than the suction, you may have an air leakwhere the cover fits on tank or possibly a warped tank or cover. feel all around the unit for air being drawn in somewhere besides the hose. try it without the hose on and block the inlet for a couple seconds to see if the unit leaks air in. also replace the filter , dont try to clean it, the pores clog and reduce suction and damage motor.

Jun 11, 2008 | Craftsman 17765 Canister Wet/Dry Vacuum

1 Answer

Hoover agility--poor suction, still!

When you remove the dirty water tank, on the machine, there is a screen that gets clogged and will prevent good suction, is this one clean? If it is, do you feel suction at that screen, if so then there is a problem with the tank. If no suction there, then you will have to check it over for a air leak or a bad seal.


Apr 29, 2008 | Hoover F6212-900 / F6215-900 SteamVac...

1 Answer

Poor suction

i had the same problem and moter cutout for over heating.i removed everything removable to see blockages i found a ball point pen and wood shavings.i cleaned every part possible including the rubber gaskets.also cleaned the bubber gasket in the waste bin.[mine is a 07] still poor suction. i removed side filter washed it in "warm water" and washing up liquid[dyson say to use cold water] the rinsed out in cold water,left the filter over night on a news paper nr the radiator. problem solved..fantastic suction and no over heating.hope this will help

Apr 02, 2008 | Vacuums

Not finding what you are looking for?
Vacuums Logo

Related Topics:

719 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts


Level 3 Expert

2572 Answers


Level 3 Expert

18258 Answers

Roger Potts

Level 3 Expert

694 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides