Question about Technics SA-AX530 Receiver

Open Question

I have a Technics Amp SU V26 - the volume gets loud and then cuts out, and the volume switch creates alot of static at low volume adjustemens.

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 1 Answer

SOURCE: Technics SH-AC300 Connection to Power Amp & Pre-Amp

Hi!
The problem is, that your SH-AC300 needs an amp with 5.1 input (but no decoder). For this purpose technics delivered SA-AX710.
So if you'd like to use your current equipment it would be impossible.
The only option is for you to buy 2 more Power Amps (SE-A900S), so that each of 3 amps would take care for one part of music. (one for FL, FR; one for RL, RR; and one for sub and center).
Another option is for you to buy SA-AX710. Then all the problems would be solved with it.

Posted on Feb 24, 2008

Ad
  • 1 Answer

SOURCE: Erratic volume on Technics SU-X911 amplifier (Class A)

I have a technics su x911 linked to ars x911 and a sl pj26a and a st x 933l tuner and turntable, they are all linked to each other as is typical however, I can turn the amp on,the red light shows on and everything else will work but not the amp.there is no led display and no vulume control.

the set has not been used for many years but has been kept clean and dry.
do they have to be connected in a certain order, the remote control doesnt seem to make any difference.

Posted on Aug 19, 2009

  • 1 Answer

SOURCE: I am trying to restore my volume to a Technics (SA-GX670) receiver.

i can,t find my speakers, at the bottom of my computer

Posted on Feb 13, 2011

caroldon
  • 17129 Answers

SOURCE: I need a volume control

You can easily salvage one from a scrapped or damaged set and this will not be hard.
So please visit the nearest audio/video service centers and you will be able to get one easily from a set that would suit the technics amplifier.

Posted on Sep 03, 2011

  • 2 Answers

SOURCE: Technics su z2 amp shuts off sound

hello. we cant help if we dont know what music source you are using.

Posted on Sep 01, 2012

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

4 Answers

Technics stereo Integrated Amplifier SU-G75 powers up few seconds then overload light appears and a clickng noise coming out of metal boxq with tag FP-3 M V RTP1P5C015 on it iis it supposed nto make c


If the receiver works at low volume, but goes into OVERLOAD and shuts down at higher volume, it means you are player the unit too long and too loud. Try yo keep the volume down to a reasonable volume.

Nov 15, 2014 | Audio Players & Recorders

2 Answers

Technics su-g75 amp goes to loud static after a few minutes


Hi Aawpharmd,

system control error.
please go for repair shop.
regards,
nuwan

Jan 13, 2014 | Technics SU-G75 Amplifier

1 Answer

I have a technics hifi su-ch900 everytime I play a cd or cassette or have the tuner the sound cuts out when its slightly loud, on low volume its fine. I have checked the cables and they are correctly...


I found a link to a CH900 that switched off completely.
If you are not a technician, please don't open the amplifier.
But I think it will be a simple repair. It is not the same problem, but it looks a little simelar.

http://www.electronicspoint.com/technics-su-ch900-switching-off-t53309.html

Also found a service manual, but not complete. Still here is the link

http://elektrotanya.com/technics_su-ch900.pdf/download.html

Oct 30, 2013 | Audio Players & Recorders

1 Answer

Technics su a900


I have the same TECHNICS SU A900 MKII as you are talking about and it always runs warm I think using 4R speakers instead of 8R speakers should solve the problem and actually I am thinking of switching to 4R as well.

Oct 13, 2013 | Audio Players & Recorders

1 Answer

Hello I have a Technics SU-V45A amp, it's about 18


See there is a problem with the volume conroller as it is 18 years old the controller has worn out replace the volume controller with a new one and you will be able to enjoy great sound again

Dec 05, 2010 | Technics SUV500 2-Channel Amplifier

1 Answer

Su-v55a technics amp cuts off when volume up to 2. 1


poor solder connections to the volume pot It needs to be resoldered

Aug 19, 2010 | Technics SUV500 2-Channel Amplifier

2 Answers

Su-v55a technics amp cuts off when volume up to 2


usually meens it is protecting itself from destruction
check your wires and speakers for problems

Feb 09, 2010 | Technics SUV500 2-Channel Amplifier

1 Answer

Technics su z2 amp shuts off sound


hello. we cant help if we dont know what music source you are using.

Apr 13, 2009 | Technics SA-AX530 Receiver

Not finding what you are looking for?
Technics SA-AX530 Receiver Logo

Related Topics:

156 people viewed this question

Ask a Question

Usually answered in minutes!

Top Technics Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5113 Answers

T-Comtech Repairs
T-Comtech Repairs

Level 2 Expert

417 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

6694 Answers

Are you a Technics Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...