Question about Boating

1 Answer

I have a 2000 5.7 efi with bravo3. It seems to have a dead miss maybe one cinlinder. Changed plugs and tested for fire on each.(good)Checked injectors and they are working fine except one side seems to dump a little more fuel than the other, and some times when I shut the engine off the TBI fuse blows. Any ideas?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 5,537 Answers

This sounds like you should ask several boat repair shops if they have a tester for the TBI module. By the flow you suspect the TBI is not regulating correctly and with a fuse blowing intermittingly it indicates grounding somewhere. You might do a close inspection of the injector wires and unwrap their wiring loom to see if there is evidence of shorting.

If there is slack in the TBI loom try a wiggle test with the engine running to see if miss changes.

Posted on Jul 28, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Miss fire after up to temp and runfor short amount of time. I get a miss fire coming to a stop..drops to cylinders or 1. will not accelerate at all boggs with miss fire.


Check your tank vent. Ride the bike until it stalls, pull over and pop open the gas tank lid. If you hear a "ffffwwwwwah" of air being sucked in when you open the tank, your air vent is blocked. The bike runs great when you start out, but as fuel is taken out of the tank no air can get in to replace it and the tank develops a vacuum.

Jan 14, 2015 | 2000 Yamaha V-Max

1 Answer

Miss fire after up to temp and runfor short amount of time. I get a miss fire coming to a stop..drops to cylinders or 1. will not accelerate at all boggs with miss fire.


Joe, i'm afraid we'll need some more info; year, make and model. Have you changed anything to after market like air cleaners or exhaust? How many miles are on it?

Jan 14, 2015 | Motorcycles

1 Answer

1994 Geo Metro will not start


all spark plugs dead. and at the main coil?
in this case after fuse (test them , ones that look good can be bad)
these steps work or all EFI cars made.
first is the rotor spinning cranking, if not the cam belt snapped!
a 1 second check, do you try to run 60k mile belts 200k ?


  1. CEL lamp on? key on? no crank? y/n,, if no the ECU is dead. or lamp burned out, we fix this FIRST. for next tests.
  2. I insert the diagnostic jumper clip (paper clip)
  3. the CEL now flashes codes, write them all down.
  4. I then crank for 5 seconds. and release the key.
  5. The ECU then reports live codes. beyond above stored codes.
  6. The ECU is very good at finding bad crank or cam sensors dead or even missing pulses, 1 in 10 lost. trust it, on all cars ......
  7. if no sensor code errors or spark bad errors then do the next things.
  8. The ecu also reads back the Tacho signal and will report dead tacho, sig, the ECU creates this and is the COIL drive signal to the ignition coil via the IGNITOR device.
  9. If the ignitor dies, or the coil primary opens, (dead Ign.coil) then the ECU see this and gives you Spark fail codes, cranking only!
  10. if you get far with a dead ignition coil, the ignitor is bad or the coil assuming coil even has power 12vcd key on.
this is all in the FSM, if you read it.
as is the Ignitior tests, and the coil tests.
The FSM is an amazing thing if your read it.
buy one.

ECU = engine brain, or EFI brain
EFI = eletronic fuel injection
CEL is the check engine light also called SES or MIL.
your ECU is OBD1 and no scan tool works .
only the winky blinky light.

Mar 04, 2014 | 1994 Geo Metro

1 Answer

Cerokee 3,1td startoff solenoid


which engine, no engine stated means answers will be wrong.
so??????????????????
that above is a statement so will run with that.
so what makes you think there is no fuel pressure??
1: the pressure gage is way low? how low , that you connected.
2: the pump seems silent. (near useless test)
3: pump never gets 12vdc cranking, you must crank.
4: the dribble test fails. (wasted time) (rail drips)
5: the injectors seem all dry, (spark plug tips are all dry)

now EFI 101 (crash course)
THE EFI system will be dead if fuse are blown.
and the ECU never injects with spark errors.
or CKP errors
or CMP errors
or IMMO is active. immobilizer is unhappy see lamp, look at it.

if all that works good, the ASD closes
the injectors fire
and the car starts if the ECU/PCM sees any errors stated above
it drops out in 2seconds <KILLING all injections,.
this is the PCM logic hard coded for fire prevention. all cars have it
with EFI.
does that help.

key factorys, ASD closes, for 2 seconds.
crank with no errors (scan tool shows errors after 5 seconds cranking)
if that works the engine does start.

ask for more tests, i have 3 more that find any bad start.

Feb 16, 2014 | Jeep Grand Cherokee Cars & Trucks

1 Answer

Number 2 cylinder misfire at idle. Runs smooth at 1000 rpms


Could be a loose connection at the plug or at the coils. Look at in the dark and see if you see any spark off.

Aug 27, 2017 | 2000 Chevrolet Blazer

1 Answer

2008 96ci EFI a year ago at 25,000 miles changed to a 103 stage 2 with stock head and SE 255 cam which harley installed Now at 53,000 miles changed to 103 SE 11:1:1 piston SE 110 heads SE263 cam.This is my...


The Night rider site is not set up so that one can ask a question. It's more a site that offers information about "how to" stuff so that you can read and learn how to do a job or verify that you have done the job correctly.

According to your response, I'm assuming you have good compression and you're confident in your work as the cams are concerned. Now, the problem seems to be more electrical rather than mechanical. Have you checked for spark at the plugs? The Twin Cam engines have a compression sensor. If this sensor does not sense compression, the plugs won't fire. This could be your problem since you installed the compression releases. Have you somehow over ridden these sensors?

Good Luck
Steve

P.S. I have no formal training with the Twin Cam enignes nor do I work on them. I've got all I want to do with the older models. Especially the Shovelheads. It's gotten very difficult to find a Shovelhead mechanic these days. The last year for the Shovel was 1984 for most models.

Nov 08, 2010 | Harley Davidson FXD Dyna Super Glide...

2 Answers

I have a 2000 neon with a 2 liter, it has a skip in the motor.it is a pretty bad miss i can barely take off. i hold the pedal then after a few seconds(5-10) it finally takes off but with no power a bad...


on the plugs that you changed did you notice a black carbon trace on the ceramic part of either one of the plugs,if there is this means the wire is firing to the ceramic part of the plug, you will need plug wires, if any mark on plugs you just installed replace them also

Aug 18, 2009 | 2000 Dodge Neon

1 Answer

Lack of power, hesitation, #1 miss firing


you may need to perform a leak down test to the cyliner and maybe you may have carbon on that valve. make sure the new spark plug wire has the correct continiuty

Jul 27, 2009 | Mitsubishi Mirage Cars & Trucks

3 Answers

2000 bonneville will not crank-battery good-starter good


Hey Cameron check your battery cables!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Nov 12, 2008 | 2000 Pontiac Bonneville

Not finding what you are looking for?
Boating Logo

Related Topics:

67 people viewed this question

Ask a Question

Usually answered in minutes!

Top Boating Experts

Steve
Steve

Level 3 Expert

693 Answers

ray gallant

Level 3 Expert

45441 Answers

Fabrice Wolters

Level 2 Expert

320 Answers

Are you a Boating Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...