Question about Sharp Twin Energy EC-T5980 Bagged Upright Vacuum

Open Question

Sharp 8.5 amp, 900 w upright vacuum, new bag, cleared out clog from all intakes, no suction at all...heeeelp

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
AceKiller
  • 7 Answers

SOURCE: No suction in upright position

Check the adapters at the bottom. They're supposed to move cleanly when you lower the handle. It's pretty obvious if there's an air gap when you lower the handle, and you should hear the suction in the air gap.

And...call Dyson...their support is great!

Posted on Nov 07, 2007

Ad
  • 45 Answers

SOURCE: How to for Belt replacement and solution to suction loss

You say it lost its suction, then you also say this is plenty of suction power, seems you cant figure out the prob. Try cleaning the fan on the suction blower. The blades can get chocked with dust which will give you a reduced suction.

Posted on Jan 06, 2008

reddevil6
  • 1673 Answers

SOURCE: my Miele vacuum full bag indicator

Check the suction at the vac, without the hose, if it is strong, then you hose is clogged. If it is weak, filters could be the problem, one is the back where the bag sits, the other is on the top, you can see it when you raise the lid.

Posted on Jan 29, 2008

reddevil6
  • 1673 Answers

SOURCE: sharp upright vacuum EC-12SXT5

The inlet by the brush roll may be clogged. Alot of times the hose may be clear, but the inlet catches debris and clogs it. Did you drop something down the hose and did it dome out the other side? But if you unhook the hose and there is suction at the hose end, then it should be clogged in the inlet.

Posted on Feb 14, 2008

SOURCE: Brush will not turn and lights will not light

If its not the belt or agitator it could be that the motor burnt out (this is what might be wrong with mine because everything else seams to be fine when checked with a multimeter). The upper switch assy. is part #48663238 $27.49 @ searspartsdirect.com the lower switch in the foot assy. area (by belt) is part #91001026 $6.49. Sears also gives parts list with schematics.

Posted on Apr 01, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why doesn't suction work on eureka


The hoses may be clear but debris could be clogging the point where it is discharged into the bag or container. There also could be a debris clog at the intake.

Sep 03, 2014 | Eureka Vacuums

1 Answer

Hoover upright bagless vacum.motor runs, brush turns, no suction through hole behind brush roller. however there is suction going out of dust cannister filter flap to motor. what could possible problems...


Sorry to read about your problem, I hope this helps you out.

you have a clog between the brush and bag

I tried to help you. Please help me and Rate/Vote on my response, thanks and good luck

Dec 23, 2010 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Brush spin,good suction at hose, no suction at


Air passage from back of brush head, through the joint, and up to bag, may be blocked.

Jul 11, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Hoover windtinnel suction problem


the intake hos at the bottom might be clogged.first take all the filters out and disconnect the hos completely from the vacuum,then check and see if you have suction.the intake hose is the clear looking one at the bottom that wrapps itself up from the base to the backside of the upright.you can use a coat hanger to push out the clog if there is one just bend the tip till its rounded.work it down into the intake hose from the back.after removing the hose and the filters you should have suction.just make sure all the filters get cleaned .you can blow out the hose with a garden hose

Apr 02, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

No sunction from my Hooveer windtunnel vacuum


disconnect the hose from the intake hose on the back its the clear looking hose at the bottom on the back.yes you should feel suction where the bag gets connected the clog is at the bottom.but clean the filters first.your long hose i would take it outside and blow it out with a garden hose.on the bottom where the intake hose is ,take a coat hanger and bend the tip till its rounded so you don't puncture a hole in the hose.just work it down into the tube and se if you can push the clog out the bottom ,you can put your hand over the intake hose where it connects to the long hoseand see if you have suction there,if not then the clog is in your intake hose.if you do then the clog is either in the long hose or the filters

Mar 17, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

No suction or very little


Make sure you have a good bag installed in the vacuum and the door is properly in place. Remove the attachment hose from the bag chamber and turn the machine on. You should have good suction coming from the hose inlet. If you don't you have a problem in the bag chamber. Bad bag, door is not on correct, door is defective, dirty secondary filter.

Connect the hose back to the machine and pull the other end out from the bottom, and turn the machine on. You should have good suction there. If you don't you have a clog or hole in the attachment hose and it needs to be unclogged or relplaced.

Reconnect the to the bottom. Flip the mahine upside down. Take the screws out of the bottom plate and remove. Remove the brushroller and belt. Turn the machine on and you should have suction at the inlet coming off the brushhousing. It you don't, then you have a clog in the nozzle hose and it needs to be removed. It will probably be more accessable from the bottom side since that is the way that it entered.

Sometimes a suction problem can be confused with an brush problem. The belts on that machine should be replaced every 6 to 8 months because they will strentch and wear. This is an inexpensive maitainance that will dramatically improve its function. Part Numbers are 38528-035 and 38528-034

Nov 21, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Suction hose


i would first double check the hose, remove it and drop a marble through it to be sure. make sure the bag is new and also check the filter underneath the bag if it is clogged it could cut the suction.

Sep 16, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

2 Answers

No suction


check the belt or the inside tube between the bag and the brush

Aug 11, 2008 | Dirt Devil M086700 Vision Bagless Upright...

1 Answer

Sharp upright vacuum EC-12SXT5


The inlet by the brush roll may be clogged. Alot of times the hose may be clear, but the inlet catches debris and clogs it. Did you drop something down the hose and did it dome out the other side? But if you unhook the hose and there is suction at the hose end, then it should be clogged in the inlet.

Feb 13, 2008 | Sharp Twin Energy EC-12SXT5 Bagged Upright...

1 Answer

NO SUCTION ON FLOOR


Dear Thyagie,since you said the cleaning tool attachment is working,I guess that means the cleaning tool attachment still has suction" so theirs a good chance that there is a clog that needs to be cleared and you wont need a new vacuum at this time.

But you will need to try and trace the clog and clear it. I would start with the tube by the roller brush and work my way up from there !
Also check the roller brush and the belt and make sure it's working properly.If your vacuum has a filter make sure it is clean,and of course make sure the vacuum bag is not full.

I hope this helps,EarlsOK

Dec 09, 2007 | Hoover U5262-900 / U5260-900 / U5266-900 /...

Not finding what you are looking for?
Sharp Twin Energy EC-T5980 Bagged Upright Vacuum Logo

Related Topics:

80 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sharp Vacuums Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

jasbo
jasbo

Level 3 Expert

2237 Answers

Mike

Level 3 Expert

4340 Answers

Are you a Sharp Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...