Question about SPL Audio Car Audio & Video

1 Answer

The fuse blew on my spl 1920watt amp and now the protect light wont go off and it wont do anything

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 108 Answers

Did you put a new fuse in it? If you didn't then put a new fuse that is rated at what the amp calls for. If you have and the light stays on, then odds are there is a broken wire inside and the amp needs repairing or replacing.

Posted on Jul 12, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My rockford fosgate T1 amp blew a fuse and now protection is on


Chances are that more than a fuse went. I would follow (internally) the path of the wires from the speaker you mentioned - inside the amp. This should bring you out to the main amp. I think you will find that whatever powers that channel is faulty.

Apr 10, 2013 | Rockford Fosgate FAP T1 Amplifier

1 Answer

I Have an spl audio amp 520 watt and when it turns on it automatically goes to red which is protect. what could be causing this problem


It could be 3 things. There could be a short somewhere, your ground isn't strong enough, or you accidently switched up the ground line and the power line on the amp. Since the fuses aren't blown I would say that your ground isn't strong enough.

May 01, 2011 | SPL Car Audio & Video

1 Answer

Amp goes straight to protecting


bad power supply or out put i hat to say it but spl is note a good company i would replace the amp

Jul 07, 2010 | SPL Dynamics CRM1200-2 Car Audio Amplifier

1 Answer

Dash & rear lights wont come on..fuse blew? HELP!


It is loctated in the underhood fuse box and it is call the park fuse it is a 10 amp fuse

Sep 05, 2009 | 1997 Saturn SL

2 Answers

My amplifier turned off while playing and wont turn on at all now


Hello, it sounds like you shorted the outputs of your amp or the power supply mosfets shorted. Very common when people have the music at a loud volume. Does the protect light come on? If not then the power supply is probably shorted not letting the protect circuit get any voltage. Some amps do this and other amps if the power supply shorts have the protect cicuit built in such a way that if the power supply shorts out the protect circuit still works. Cause you checked all wiring and redid it and no fuses blew then this is your problem. I repair amps everyday for a living. ?Most of my out of state customers are from fixya.com. I'm the cheapest amp repair business you'll find. If interested send me a private message letting me know what kind of amp it is, name and model number, and i'll get you back up and running with warranty.

Btw, I’m available to help over the phone in case u need at https://www.6ya.com/expert/mark_b53a7494531bf96d

Aug 23, 2009 | Car Audio & Video

1 Answer

2000 watt american legacy amp protection ligh wont go off


Same thing happened to me so I returned it for repair turns out it was an internal 25amp fuse on the output. Got it back an it sounded very weak now it does not play at all. Nothing wrong with my setup as I have now got an 800watt amp that is running great.

Jul 01, 2009 | Lanzar MXA422 Car Audio Amplifier

2 Answers

Hi. I have a Kicker amp KX1200.1 that doesn't seem to be working. I think it blew a fuse. Do you know how I can get that fixed?


You should have an inline fuse (external) at the amp and one at the battery. There are not fuses on the amp.

Jun 25, 2009 | Kicker KX1200.1 Car Audio Amplifier

1 Answer

The amp wont come on


sorry to have to tell u this but you blew your amp or just the channels this happens when you dont have the ohm rite for amp and speakers

Dec 20, 2008 | Nitro BMW-482 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

76 people viewed this question

Ask a Question

Usually answered in minutes!

Top SPL Audio Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4979 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Marvin
Marvin

Level 3 Expert

81342 Answers

Are you a SPL Audio Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...