Question about Porter Cable Electrical Supplies

1 Answer

I have a Porter Cable T550 that fluctuates on rpm, also it makes a loud pop from the exhaust after about 2 minutes of run time and continues throughout running.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 286 Answers

Sounds like it is running lean, needs to be cleaned and adjusted.

Posted on Apr 28, 2015

Testimonial: "I have given it a cleaning but the air fuel screw wont stay at any position other than all in and tight. Any ideas?"

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Repairman can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Repairman (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Porter cable cffn25 won't run. Trips breaker


The little compressors were not built for continuous duty. The pump probably seized, or the motor burned up, or both.

Nov 25, 2013 | Porter Cable Air Tools & Compressors

1 Answer

Porter cable air nailer leaking air from exhaust port continually


It certainly sounds like you may need to replace the seals on the tool.

The two main culprits are loose screws or bad seals.

Try tightening all the screws on the unit.

If that doesnt fix then you will need to purchase an overhaul kit for your model or take to a repair shop.

Since you did not give me your model #, Here is link to locate necessary parts:

http://servicenet.deltaportercable.com/

Thanks

Apr 20, 2011 | Porter Cable Air Tools & Compressors

1 Answer

Is this tool known to get hot?


We have two of these at my work. It becomes very hot to hold after only about 4-5 minutes of running. And I do mean "hot"--hot enough to make the body distinctly uncomfortable to hold, and hot enough for me to worry about soldered connections inside melting. Connecting a dust hose to my 2 1/2" shop vacuum helps cool it a bit, but merely enough to double the run time to about 8-10 minutes. Then I set this sander aside and let it cool down for about 15 minutes before using it again. Yes it is known to get hot

Feb 23, 2011 | Porter Cable 371K Factory Reconditioned...

1 Answer

Car suddenly started running poorly, Difficult to start, and bogs badly when gas pedal is pushed. Gradual acceleration up to 2500 to 3000 rpm allows it to go but it does not get better when warmed up. Some...


popping out of the tail pipe is usually a tell tail sign of a timing issue. Pull the timing cover and hand crank the engine. If the marks on the crank and cam line up check vacuum. If needle fluctuates roughly 2in/hg take note(possible burned valves) Inspect the plugs for signs of carbon fouling(fuel injector issue). if the plugs show good burning with a yellowish white check compression. If compression is good check cylinder leak down. if cylinder leak down is less than 30%. check exhaust back pressure.

Dec 16, 2010 | 1995 Mazda 626

1 Answer

Bought new porter cable oiless boss compressor and want to know what i need to do before operatining it for intial use


The first thing is to make sure the compressor pump has oil!

Run the unit with the tank drain open for 10 minutes to break the compressor and rings in. Let the motor cool for 30 minutes and then use the compressor as normal.
Make sure to change the oil every 50 hours of use

Sep 26, 2010 | Porter Cable 4 5 Gallons 150PSI Job Boss...

1 Answer

Ignition timing specs for a 1988 volvo 760 turbo wagon ?


It is most likely going to be between 5 and 15 degrees BTDC. I would put it at 5 degrees BTDC. At idle, if the motor is extremely quiet, but the exhaust loud, move it to 10. As you advance the timing, the motor should become louder and the exhaust quieter (at idle). As you increase RPMs, the motor should get quieter and the exhaust louder. This is only true with an injector pump that has static timing (does not automatically increase with increased RPM).
If your engine has dynamic timing (automatically advances with increased RPM), then I would set the timing at 5 degrees, test run. Maybe change to 7 degrees, test run...etc. Basically, don't make dramatic changes with the injector pump timing if it is dynamic. I hope this helps.

Apr 30, 2010 | 1988 Volvo 760

1 Answer

Maytag LDG9334AAE Gas dryer making popping noise from vent


clean clean clean everything, dont let it go to much longer or you will have a fire, and dont ignore this or you regret it... then tell me if it makes the noise

May 07, 2009 | Maytag Dryers

1 Answer

Rpm fluctuations


either you need a new tranny or your ecu is reading a code. Same thing happened to mine, i had my transmission replaced.

Apr 24, 2009 | 2003 Hyundai Accent

1 Answer

Won't start -Porter Cable Cable 135 PSI, 60 Gal compressor


ARE THE POINTS BURNT IN THE PRESSURE SWITCH? DO YOU HAVE A LEVER ON THE SWITCH SET TO ON OR AUTO? IF YOU THINK ITS THE SWITCH JUST BYPASS IT AND TIE THE WIRES TOGETHER TO SEE IF IT RUNS. BEWARE YOU HAVE NO PRESSURE PROTECTION EXCEPT POP-OFF VALVE. MOST P.O.S. COMPRESSORS LIKE PORTER CABLE HAVE 3500 RPM MOTORS AND HAVE A THERMAL RELEIF BUTTON ON THEM. JUST PUSH TO RESET. MAKE SURE YOUR WIRNG OR DROPCORD IS LARGE ENOUGH GAUGE. SMALL GAUGE DROPCORDS KILL COMPRESSORS.

Jan 17, 2009 | Porter Cable Cable 135 PSI, 60 Gal. Oil -...

2 Answers

Porter-Cable generator won't power anything; engine runs, low rpm


You have a simple problem and it has nothing to do with the octane, honda's love better gas, thats all I use in all my equipment and even my 4000 psi pressure washer runs better and cooler with higher more efficient octane, Your problem is in the carb, clean and service it, make sure the air breather is clean (soap and water only if it is a foam unit and do not spray it with any oil) then check for water in the gas by draining the tank into a large clear glass container 1/2 gal at a time. and after all this is done and needs to be done anyway, change the spark plug run the unit and make sure the throttle up solenoid is adjusted properly or even working if this unit is equipped with one. good luck

Dec 22, 2008 | Porter Cable 10,000 Watt 20 Hp Portable...

Not finding what you are looking for?
Electrical Supplies Logo

Related Topics:

65 people viewed this question

Ask a Question

Usually answered in minutes!

Top Porter Cable Electrical Supplies Experts

John Trevino

Level 3 Expert

1388 Answers

yadayada
yadayada

Level 3 Expert

77202 Answers

Spud Howell

Level 2 Expert

57 Answers

Are you a Porter Cable Electrical Supply Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...