Question about Sony Car Audio & Video

1 Answer

I have a sony cdx gt520 in a 2000 Jeep Cherokee.When in tutun on my vehicle the screen is blue.When I hit source to turn on the radio or CD player, it turns off and on and won't play.Any suggestions?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Sony Master
  • 10,875 Answers

Bad switch

Posted on Apr 26, 2015

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

SOURCE: Cannot play my portable audio device with Sony cdx c500x

The multichanger has to be connected,with a cd in, but then the head unit will play whatever is fed to the bus in sockets. This effectively means the multichanger is playing to itself. If you want both to work, use a pair of piggy back rca leads into the head unit, one to the cd, one to the mp3. Then break into the cd leads and feed one of the pairs, one +ve, one -ve to a double pole switch so that you cut the sound from the cd allowing the mp3 in. To play cd's, flick the switch.

Posted on Jul 27, 2008

  • 1 Answer

SOURCE: CDX-S2000 Volume, Source, and Mode buttons not working????

Hey jshaff, try taking off the detachable front, and you will see a reset button, press and hold in for 10 secs, this should solve your problem. if it doesn't work first time keep trying. you must have power to the head unit for this to work. you will hear the cd make a noise and that should be that, try and let me know.

Posted on Oct 04, 2008

  • 1 Answer

SOURCE: no sound from cd but stereo works no problem

there are 2 blue wires........dont hook the blue to blue!!!!!!!!!!!!!!!!!!!!!! hook blue to the blue/white wire!!!!!!!!!!! problem solved. so e-z huh? lol i did the same thing.

Posted on Feb 28, 2009

SOURCE: CD RESET

to fix this problem you have to take the face plate off. There should be a small button on the middle-left side that sais "reset" on it. Get a ballpoint pen and press this button. Pop the face plate back on and play your CD and it should work no problem.

Posted on Jul 11, 2009

  • 2 Answers

SOURCE: Sony CDX-S2210 buttons are jammed

Hi Sameersach,
Have you found a solution for your problem? I have the same player and I got the same problem...please, let me know if you found a solution. Thanks!

Posted on May 10, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I recently installed my sony xplod to my jeep and the radio, volume works fine. when i insert a cd, i hear nothing, counter and track displays but no sound...please help


are you using an amplifier? if so, it sounds like you are using the blue wire (antenna remote turn on) instead of the blue/white wire (amplifier remote turn on) to turn the amplifier on.

Feb 17, 2011 | Sony XPlod CD Player w/MP3 Playback...

1 Answer

I've had my Sony Xplod CDX S2010 Radio/CD player in my Jeep for years and it has all of a sudden locked up on me. The CD player will play and eject CDs, however it doesn't allow me to adjust volume or skip...


i'm not sure if there is a flexible cable that goes from the face to the motherboard. if there is, that could be the problem. it could also be a bad switch.

Aug 25, 2010 | Sony CDX-S2010 CD Player

1 Answer

CDX-RA700 CD Player: My wires on my sony CDX-RA700 do not match my 2005...


The following should help you. Good luck. Please rate. Radio 12v orange + radio harness Radio Ground black/orange - radio harness Radio Ignition yellow + radio harness Radio Illumination brown/white + radio harness Factory Amp Turn-on lt. green + radio harness Power Antenna gray + radio harness LF Speaker +/- tan - black +,- radio harness Notes: If equipped, the amplifier is in the passenger side of the trunk. RF Speaker +/- blue - red +,- radio harness LR Speaker +/- white - brown +,- radio harness RR Speaker +/- orange - green +,- radio harness
For the stereo the following will work.

167f25e.jpg

May 07, 2010 | Sony CDX-RA700 CD Player

1 Answer

When I turn off my truck and the blue lights on, it turns off but when the radios on and I turn the truck off the radio does turn off unless I hit the off button! Help sony xplod cdx-gt640


do you mean the blue light on the power button? it sounds like your radio's switched power input (usually red) is hooked up to a 12 volt constant source.

Feb 22, 2010 | Sony XPlod CD Player w/MP3 Playback...

1 Answer

Cd player works but not radio


No, it uses the same source.
Have you checked which band you are selecting? It has 3 FM bands, LW and MW, right?
It may not be a relay, but an untuned station.

Aug 19, 2009 | Sony CDX-GT210 CD Player

1 Answer

No sound from cd but stereo works no problem


there are 2 blue wires........dont hook the blue to blue!!!!!!!!!!!!!!!!!!!!!! hook blue to the blue/white wire!!!!!!!!!!! problem solved. so e-z huh? lol i did the same thing.

Feb 16, 2009 | Sony CDX-CA700X CD Player

1 Answer

Radio audio working but no audio from CD. Shows cd playing but no


:) swap your blue with your blue/wht or vice versa.. (behind the radio) this WILL fix your problem..

Jan 27, 2009 | Sony CDX-CA850X CD Player

1 Answer

Sony cdx gt200


I HAVE A SIMILAR MODEL AND I HAVE TO HIT THE SOURCE BUTTON TILL AUX APPEARS MAY BE A RADIO MALFUNCTIO

Nov 13, 2008 | Sony XPLOD CDX-GT200 CD Player

1 Answer

Sony cdx -m8800


Remove the radio, disconnect the blue wire, and connect the blue/white wire in its place. This should fix your problem.

Sep 08, 2007 | Sony CDX-M8800 CD Player

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

86 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4836 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

287 Answers

Philip Rowney
Philip Rowney

Level 2 Expert

94 Answers

Are you a Sony Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...