Question about Durabrand HT-3917 Home theater System

1 Answer

The sub-woofer seems to have stopped working.

It will turn on into stand-by mode (orange light), but then seems to go low power and won't let me turn it on the rest of the way.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Durabrand Master
  • 10,875 Answers

Yup it stopped working,guess its time to get a new one

Posted on Apr 22, 2015

  • Sam Lubahn
    Sam Lubahn Apr 22, 2015

    any places you would recommend to get a new subwoofer and not have to buy the whole set again?

  •  johnny rebel
    johnny rebel Apr 22, 2015

    radio shack

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Sub woofer is not working. it has orange flashing light at the back


Look at the connection of the sub woofer. The orange light indicates either there is some problem with the wire or the connector at the end of the wire.

Also make sure the pin or hole where you insert the sub woofer is working perfectly. You can simply check it by placing another sub woofer at that vary spot and see if it is working fine. If the hole is fine then the problem is either with your cord or your wire pin.

Oct 24, 2012 | Audio Players & Recorders

1 Answer

Subwoofer is not playing


It is hard to say. The sub-woofer has its own amplifier, although it is supplied the sound data from the main amplifier. It could have a problem with the battery power circuit (Sub-Woofer Amplifier Connector Pin 6, LIGHT GREEN/VIOLET) or it could have a problem with the GROUND circuit (Pin 2, BLACK/LIGHT GREEN) Or it could possibly not be receiving the signal from the main amplifier (Pin 7, BROWN/ORANGE "+"), (Pin 8, RED/BLACK "-"). Or it could be that either the sub-woofer speaker is blown, or the sub-woofer amplifier is defective.
There is also a "High Audio Mute" circuit that connects between the main amplifier and the sub-woofer amplifier.

Mar 06, 2012 | 2000 Lincoln Navigator

1 Answer

Hello, my Harman Kardon HKTS 15 sub woofer don'st work, the light that suppouse to turn from orange to withe when i turn on my receiver stay orange.could be the cable from my receiver to the sub...


It could be because of your subwoofer AMP is gone.

Temp fix: Disconnect the subwoofer wire from receiver for 20-30mins and plug-it back. It did work for couple of months.

Aug 22, 2011 | Harman Kardon Audio Players & Recorders

1 Answer

My subwoofer doesn't receive power, all amp fuses are fine, amp powers on, remote wire and rca wires are connected and intact. Before it stopped working all together the woofer would cut out and after...


If you are getting power to the amp, try this....Find a small speaker, unhook your sub and wire speaker to amp. Turn on your system at a low volume....If the other speaker is playing through amp, then your sub is shot.....If the small speaker doesnt work, then its either your channel is gone on the amp or the rcas have quit off off your head unit.

Oct 07, 2010 | Kenwood eXcelon X1200M Car Amp

1 Answer

My sub woofer will stop working if i put the bass up to loud, ill have to turn my car off and on to get it to work again. What could be the problem?


Seems like your power amp for the sub woofer may be going into protect mode/thermal overload when you push the volume too much. Therefore it shuts down. I am surprised the speaker hasn't blown yet.

As far as turning car off/on to get it to work, it's as if your car is the power switch.

Amp and speakers may not be wired correctly, as you want to make sure your amp/speaker ohm measurements are within a specific range for the amp and speakers work together properly. You may have it wired for a 2 ohm load, and maybe your amp can't do 2 ohms all day long.

Apr 09, 2010 | Kicker Comp DC12 2-ohm Enclosed Subwoofer...

1 Answer

No Sound


This might very well be a fuse - check by setting the sub woofer to "On" to see if it powers up. If it does, there may be a problem with the sub woofer audio cable(s) or connection(s).

Don't forget to check for a tripped circuit breaker or blown fuse on the stereo's speaker output. If your sub is connected to a low level output - this shouldn't be a possible cause - as circuit breakers & fuses are usually on amplified (high level) or speaker outputs.

Another possibility is that the settings of the stereo has been changed from a *.1 system to plain stereo 2.0 or some other setting that disables the LFE (low frequency effects) or sub woofer audio output.

Sep 18, 2009 | JBL Venue SUB10 Subwoofer

1 Answer

No signal from sub connected to NAD T760 in test mode.


Try using front pre out to the sub from the receiver. the crossover is in the sub anyway. If this works change your settings on the receiver and test again. If sub is still inop, could be an internal issue with the sub amp. Does your sub amp have an on/auto/off switch or light? check that as well. Hope this helps, if you need further assistance, send a reply and I'll help some more

May 24, 2009 | NAD T760

1 Answer

Sr7200 LFE (sub woofer) output stopped working


Chances are if The Receiver only has sound in Stereo Direct Mode and all surround modes and Sub out are Inop the DSP (Digital Signal Processing) Card is most likey defective. These boards are not available from marantz (D&M Holdings) and must be Component level repaired which usually is not cheap. If Only the Sub out is not working check setup to be sure sub woofer is set for on. Also If On Screen setup menu does not appear on video monitor Unit may need to be Reset manually which entails discharging a Capaitor on main P.C.B Contact kstahl65@att.net for details

Dec 16, 2007 | Marantz SR-7200 Receiver

1 Answer

The AVR-3300 power-off to stand-by mode


You have a blown amp or a leaky cap and the unit is going in to save mode to avoid destrying the unit.

Take it in for a repair. I don't think it should run more than $50-$75 for a fix depending on what component is bad.

Nov 19, 2007 | Denon AVR-3300 Receiver

Not finding what you are looking for?
Durabrand HT-3917 Home theater System Logo

84 people viewed this question

Ask a Question

Usually answered in minutes!

Top Durabrand Audio Players & Recorders Experts

Rod
Rod

Level 2 Expert

224 Answers

yadayada
yadayada

Level 3 Expert

74896 Answers

Jonathon summesfield

Level 2 Expert

285 Answers

Are you a Durabrand Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...