Question about Windsor Vacuums

1 Answer

Where is vacuum chamber on a Windsor sensor xp12

Having issues with bag full light staying on when bag is not full even does it with new bag installed

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Windsor Master
  • 10,875 Answers

It comes up from the back,it is probably plugged or the sensor is dirty

Posted on Apr 21, 2015

  •  johnny rebel
    johnny rebel Apr 21, 2015

    or need to change all filters,if they are clogged they will do that

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How to fix sensor s12. red light for bag stays on even when vacuum bag is not full and the vacuum is clear


You most likely will need to change the Yoke assembly. There is a sensor built in that gets clogged with fine debris over time. This will take care of the problem.

Feb 09, 2015 | Windsor SR12 Sensor Bagged Upright Vacuum

2 Answers

I have windsor s12 red light for bag is full is on and it's not clogged. what next


Check the line going from the bottom of the vacuum to the bag, it may be clogged. A coat hanger can help you clear any jams, but be careful not to puncture the duct.

Jan 27, 2015 | Windsor SR12 Sensor Bagged Upright Vacuum

4 Answers

I have a Windsor Sensor s12 and power shuts off after 5 min. of vacuuming. I'm wondering if it's overheating of if there is some other sensor that causes it to shut off.


Your Sensor most likely has an internal heat sensor that is shutting off the motor. Some vacuums install an external heat sensor with a reset button that you must push to re-start the vacuum. If your model does not have an external reset button it is most likely a sensor inside the motor. If it is defective the motor must be replaced to solve the problem. But first make sure the overheating is not being caused by a blockage somewhere or the bag is too full. Air must pass completely through a vacuum starting at the floor where it picks up the dirt through all the canisters, filters, bags, etc. and then is exhausted from the vacuum. Any restrictions or blockage can cause the motor to over heat.
That Vac Guy

Jan 04, 2013 | Windsor SR12 Sensor Bagged Upright Vacuum

1 Answer

My windsor vacuum brush light keeps coming on


You may try a new brush. With these models the light will continuously run to signal it needs the brush replaced.

Jan 29, 2011 | Windsor SR12 Sensor Bagged Upright Vacuum

1 Answer

Our Winsdor Sensor XP12 does not show any power or lights, I did check the handle connection, it was fine. The power cord has been repaired with duct tape 3-4 x where someone has sucked up the cord, this...


Any time the cord has been damaged badly enough to require taping, the possibility or intermittent "opens" exist. This means the wires are in contact much of the time, but will losed contact periodically. Even if it worked fine seconds ago, jiggling just right may cause this. This also presents a shock hazard.
I strongly recommend replacing the cord as soon as possible. If you are unable to do this, then please take it to a shop to be done.

Aug 31, 2010 | Windsor SR12 Sensor Bagged Upright Vacuum

3 Answers

No Power to Windsor Sensor XP12


The Windsor Sensor vacs all have a removable handle.

The handle is inserted into a "socket" which has contacts to complete the electrical circuit.

The handle is held in place by a gray plastic lever.

If the lever is not pressed down completely, the handle is able to slide within the socket during regular use.

If the handle slides out far enough, the electrical connection within will be disconnected and the vac will have no power.

Simply lift the lever, pull up to remove the handle, and re-insert the handle fully, then press down firmly on the lever to lock the handle securely in place.

This is the first step to solve your problem and hopefully this is all that need to be done.

If this does not work, please repost here and I will help you all I can.

Note: I am a big fan of the Windsor Sensor vacs and find them to be easy to work on and a great vac all around!

Aug 12, 2009 | Windsor SR12 Sensor Bagged Upright Vacuum

1 Answer

'Bag Full' light indicates at 1/3 bag


The sensor is a small hole into the vacuum chamber. It moves the alert system as vacuum inside the unit builds up.

The filtration, built into the bag, is getting filled up and creating a higher vacuum inside the unit, giving a false reading. The only ways to eliminate this are to give the bag a shake to clear some of the dirt out of the filter, try to pick up coarser dirt first or buy generic bags-without the filtration.

Jul 21, 2009 | Windsor SR12 Sensor Bagged Upright Vacuum

4 Answers

Windsor sensor says bag is full when its not


Are you vacuuming up fine particals like pet dander or just large amounts of regular dust? Also when was the last time you replaced your filters?

Just some sugestions.

Mar 17, 2009 | Windsor SR12 Sensor Bagged Upright Vacuum

2 Answers

My windsor s12 vacuum light says the bag is full but it is new?


It sounds like a blockage in the hose or in the yolk.I believe you can remove the hose from the machine to inspect and clear it.Also check the trapdoor on the bottom of the powerhead to be sure it is clear.While you are going through the machine check under the upright filter next to the bag to see if it is clear.Good Luck-Scott

Oct 10, 2008 | Vacuums

1 Answer

Electrolux Epic 6500SR Full Bag sensor working, Does not Reset properly


The problem was a sticking switch that was not being reset. The vacuum on/off switch mechanism is comprised of two switches. One is the main switch that turns the vacuum on and off. The second is a shut off switch that gets tripped when the full bag sensor is engaged. This second switch is supposed to get reset when you push the on/off switch on the outside of the machine. The full bag shutoff switch was stiff and it, therefore, was taking a couple of presses of the on/off switch to move the shutoff switch back into the running position.

Jun 19, 2008 | Electrolux Epic 6500 Vacuum

Not finding what you are looking for?
Vacuums Logo

Related Topics:

169 people viewed this question

Ask a Question

Usually answered in minutes!

Top Windsor Vacuums Experts

Mike

Level 3 Expert

4340 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18394 Answers

Thatvacguy.com

Level 3 Expert

1250 Answers

Are you a Windsor Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...