Question about Greenworks 1700 PSI 1.4 GPM Electric Pressure Washer 51012

2 Answers

Pressure wand is leaking at the out let end, and pump has a small surge when setting at a idle

I removed filter and cleaned it still same problem. Tried another hose but same problem. The unit works great, just has a leak at the end of the nozzle. cleaned spray nozzles, took hose off of wand and made sure no blockage there.

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 28 Answers

Sounds like water is leaking past the shutoff valve on the wand. Check your owners manual parts diagram to see if there is a washer or o-ring to replace.

Posted on Apr 16, 2015

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Greenworks Master
  • 10,875 Answers

You are missing the orings that belong in there,they blow out if you dont know what you are doing

Posted on Apr 16, 2015

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Changed fuel pump and inline filter,starts like its flooded and will run at high rpm,but surges at low rpm then dies like its flooding out,dont know what to do,could it be fouled plugs?


Any applicable trouble codes? Clean the throttle body and idle air system. Check for vacuum leaks.
I don't know year--make--model?
If a fuel problem, use a fuel pressure gage, check for correct pressure, then with key off, see if the pressure holds for a bit. If pressure drops like a rock then check for fuel pressure leak.

Oct 30, 2016 | Cars & Trucks

2 Answers

Sudden power surge -happens in stop and start traffic. Foot on brake when power surge happens-I had to slam on brakes to prevent read end collosion. Three events in last two weeks.


Just my opinion, I wouldn't drive till you get it looked at, that sounds dangerous.
How long since a tune-up?
Any applicable trouble codes?
Sounds like something is telling the computer to up the idle, at the moment, I don't know why? Are you running the ac when this happens?
Check and clean throttle-body and anything that has to do with idle air system. Also, check the maf sensor, where applicable.

May 01, 2016 | 2004 Mercury Mountaineer

2 Answers

I have a Mazda Tribute '02 and randomly when i drive it it starts jolting like it is struggling to go when i accelerate. Its usually when i go over 60kph but sometimes i can drive it a short distance...


FUEL PUMP GETTING WEAK.CHECK FUEL PRESSURE.AFTER YOU DO AFTER YOU REPLACE FUEL FILTER AND AIR FILTER. THEN CLEAN FUEL INJECTORS BY POURING A CAN OF SEAFOAM TO 3/4 TO FULL TANK OF GAS.CHECK FUEL PRESSURE SHOULD BE 65 PSI. IF FUEL SYSTEM OKAY.YOU HAVE INTAKE LEAK CHECK ALL VACUUM HOSES AND PCV VALVE FOR VACUUM LEAKS,HAVE VECHICLE CODE SCAN VECHICLE LOOK FOR TRANSMISSION FAULT CODE.FAULTY TORQUE CONVERTER CAUSE ENGINE TO SURGE.LOOK FOR TPS FAULT CODE.AND IDLE AIR CONTROL FAULT.THEY BOTH CAN CAUSE SURGE PROBLEMS.

Mar 10, 2011 | 2001 Mazda Tribute

1 Answer

Have 1995 olds cutlas with v6 3100 engine. engine runs great at idle and lots of power when cold. after driving for 150 miles car starts cutting out and loosing power under load. still idling great at that...


could be a fault with the fuel pump. it may be wearing out. check the fuel pressure at delivery. a blocked filter can also do this as its being surged for more fuel not the normal filter this one is on the pump it has larger holes and if you have sludge in the tank this can stop the fuel delivery. . for vacuum leaks spray some carb cleaner around the air lines any change in the engine usually indicates an air leak. also the fuel pressure valve these can all lower or stop fuel pressure.

Jun 29, 2017 | Oldsmobile Cutlass Ciera Cars & Trucks

1 Answer

Water surging back to pool when shut off


sounds like you have air built up inside the filter when the pump shuts off. the most likely cause is a suction side air leak, bad lid o-ring or union o-ring or maybe even the threaded fitting going into the pump. When you turn the pump off, you may be able to see water squirting out wherever the leak is. Once you find/fix the suction side leak the filter should stay filled with water and not surge backwards when the pump turns off. Make sure you keep the filter clean as well.

Apr 22, 2010 | Hayward SAND FILTER, PRO SERIES

2 Answers

Gas tank troubleshooting


A mechanical pump pulls fuel from the tank and pressurizes it on the carb side. This makes any small rust holes in the fuel line nearly impossible to find (with injection the line from the tank is pressurized and any hole no matter how small will spray....a mechanical pump will draw air into the hole instead. You can check it for leaks by removing the end at the tank and blocking it off, then disconnecting it from the pump and attaching a flowing siphon hose to it. any leaks will then drip.
The fuel pickup in the tank has a fine mesh screen on it. You can either blow it off the end of the pickup tube by applying high pressure air to the line while it's disconnected from the pump, or by dropping the tank and cleaning it. As long as you are using a good filter on the line it won't hurt anything but if it does work you can consider removing the tank and cleaning it.
Your fuel pressure should be between 5 and 7psi. Good idea to run some of your fuel into a clear glass jar and check it for water.
Have you checked the intake gasket for leaks? While running, spray carb cleaner where the manifold and head join. If the idle changes substantially, you have a leak. I'd also check actual engine vacuum...you should have about 19 inches of vacuum at idle.
Last, your timing chain may also be worn. At times the chain will ride up on the cam gear and alter the cam timing. I would definitely keep that for last but keep it in mind anyway.
If combustion is good in all cylinders your plugs should be coffee coloured on the electrode porcelan. Black, or oil fouled is not good.
White is questionable but as long as they aren't blistered they should be ok like that. Last thought is that rebuilt carbs are not always done up right...building is becoming a lost art. Though yours is simple it still needs to be set up correctly or it may not work.

Apr 05, 2010 | 1988 Jeep Wrangler

1 Answer

Karcher G 3000 BH Engine Pumping Problem


This may not be a motor problem. It sounds like your pump is not working properly and the motor is just following the pump. First thing to do is check for leaks in the pump, wand hose, gun etc. It may also be a blown water seal inside the pump.

Aug 17, 2009 | Karcher 2500 PSI Pressure Washer

1 Answer

Olds alero 2.4 idle fuel pressure


most likely idle air control sensor or low engine coolant I know sounds funny but IAC uses coolant to regulate idle. Idle air control valve or throttle body positioning sensor.

Dec 10, 2008 | 1999 Oldsmobile Alero

1 Answer

When motor is at idle speed it surges


Try a simple test. It is ok to run the pump without water for a short time. Check idle speed without water in system to see if enginet surges. If it does not surge, then most likely the unloader/ pressure valve is causing the engine to surge when in the unloaded state. Life of unloader /pressure valve is shortened by letting system bypass for long periods of time. Enjoy

Nov 22, 2008 | Garden

Not finding what you are looking for?
Greenworks 1700 PSI 1.4 GPM Electric Pressure Washer 51012 Logo

397 people viewed this question

Ask a Question

Usually answered in minutes!

Top Greenworks Garden Experts

Ed60062

Level 1 Expert

28 Answers

Marc Taylor

Level 2 Expert

128 Answers

richie46

Level 3 Expert

12962 Answers

Are you a Greenworks Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...