Question about Pool & Spa

1 Answer

My Apollo Spa shuts off and on when high speed is pushed. I replaced pump and it is the same. Any help is appreciated.

I filled it after being drained for the winter. It imediately tripped the 50 amp ciecuit breaker. This was a short in the heater. I replaced the heater and it turned on fine. now it circulates fine on slow speed but acts like there is an internal circuit breaker tripping whenever the high jet speed button is pushed. My local Apollo Spa shop said the motor was bad on the main pump. I replaced it ($600) ane it does exactly the same thing.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 1,631 Answers

Check your voltage to that pump. If the pump is set to accept high-voltage of 240 V, and you are only providing low-voltage of the 110-120 V then you will be getting that symptom.

Posted on Apr 13, 2015

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

PartsCenter
  • 125 Answers

SOURCE: Heater not coming on.

sounds like the heater element is out. if you turn the breaker on and once the tub cycles on it trips the breaker again. it is definitely the heater element.

Posted on Feb 26, 2009

  • 2 Answers

SOURCE: High speed spa pump shuts off

The motor may have a thermal cutoff if the motor draws too much current. Do you have a sufficient large gauge circuit supplying the motore? If not the actual voltage at the motor may drop, causing it to draw more current to make up for the loss of voltage, thereby tripping the motor's protective breaker. I assume the motor will start again after serveral minutes of cooling down.

Curtis

Posted on Apr 19, 2009

  • 37 Answers

SOURCE: When Aroma Therapy button is pressed imediately

Bad Blower motor

Posted on Oct 11, 2009

  • 990 Answers

SOURCE: I have an mid 90's Apollo Spa with a mechanical

The motor that drives the clock has a cog that drives the mech. This has probally worn and you will need a new gut for your clock. If this is a yellow dial it is probally a Intermatic timer.If you get the model number off the clock Home Depo can probally fix you up. The wires may not go to the same place's so be sure to wire to new specs. Two wires in are from the breaker and will be the line wires and the two that go to the motor are the load wires. Good luck.

Posted on Feb 25, 2010

  • 8 Answers

SOURCE: Coleman 500 series SPA 50A circuit breaker trips

bad connection follow wires from breaker to to moter theres abreak causing arc find it

Posted on May 09, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Pump does not shut off and timer does not stop after the 20 minutes.


What is on?
If equipped with a Small (Laing or Grundfos branded) circulation pump, these are normally Constant Duty pumps running 24-7
If not and it is your Low Speed running, then your switching mechanism has failed. This is normally the symptom of a spa that has a Mechanical Timer. Does your spa have one? If so, it may have failed, replacement should take care of it.
If electronic, then a relay has fused together on the PCB, and the only proper repair is replacement of that Board.
Now... If you are referring to HIGH Speed (you were not very specific) then this is a problem! A serious problem that needs correction ASAP!
Why?
Because a pump that runs constantly on high speed will STILL HEAT the water long after the heater turned off! Until it boils!
That is if the high limits have failed as well, don't think it doesn't happen, it does!
A very potentially Dangerous situation.
Kinetic energy or friction of water moving through the plumbing occurs! There is a restriction of the path/flow of water through the spas complete plumbing system, but the pump pushes it still no matter what, over and over. This is energy transferred to the water.
Good Luck.

Jun 07, 2015 | Pool & Spa

1 Answer

2 Speed Flo-Master stuck in high speed after turning on and off the electric


Is your switch an "air switch" ... could be you have a leak in the hose that connects from the push button to the actuator that actually does the switching. Check it out.

Dec 12, 2012 | Pool & Spa

1 Answer

Pump starts switching between high and low by itself for 45 seconds, then shuts off.


Thank you for posting your question here on Fixya.com.


Is this a two speed pool pump with a toggle switch as part of the motor or a spa pump plugged into a control that uses relays to switch from high to low?

If it is a pool pump you will need a new toggle switch.

If it is a spa unit, replace the relay.


If this answer does not fix your problem, please comment with additional details prior to rating the answer. Positive feedback is appreciated once your problem is solved!


John

Dec 03, 2010 | Pool & Spa

1 Answer

I have an appolo spa explorer model...bought it


you must have a small pump call laing if you do, air picket inside the plumbing try to turn both pump on high and wait few minutes if doesn fix try to loose the nut just a little bit with the breakers off and let the air go out. try one more time. if doesn work turn on high both pump and touch if they are working then a impeller may be broken inside one of them try to turn each one separate to find wich one as t he broken impeller.

Oct 29, 2009 | Aqua Flo Aquaflo Flo Master Xp2 Spa Pump...

1 Answer

Pump shuts itself off


Fill the tub with water, disconnect the supply pipe to the pump and ithe head of water should push out any air

Make sure you can get the hose back on easily before you fill the tub other wise you are going to get wet

Oct 09, 2009 | Aqua Flo Aquaflo Flo Master Xp2 Spa Pump...

1 Answer

High speed spa pump shuts off


Pump speed Selector Switch Contact Probably Missing, Checkout

Feb 01, 2009 | AO Smith 2 Hp Spl 3450rpm M56 Frame...

Not finding what you are looking for?
Pool & Spa Logo

Related Topics:

72 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pool & Spa Experts

Jay Finke
Jay Finke

Level 3 Expert

1338 Answers

Bill Jordan

Level 2 Expert

372 Answers

David Spradling
David Spradling

Level 3 Expert

3543 Answers

Are you a Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...