Question about Panasonic Kenmore Canister Vacuum Hose 116 Whispertone Powermate Progressive

1 Answer

I have a kenmore that has no light or power head working. When I opened it I saw a rock inside, I removed that the suction is fine but still no light or rotating The reset button is not helping.

Posted by on

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Panasonic Master
  • 1,069 Answers

Make sure there is proper power voltage coming from the contacts at the end of the hose.

Posted on Apr 07, 2015

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a kenmore model 116.25512506. The roller is spinning but no suction from the head. The attachments have suction but not the head. How do I remove bottom cover to check for blockage?


Is the suction control plastic ring shut?. If it's wide open you get almost no suction. See picture.
25823072-bhx41vpbxgcw2fhkwng0wody-1-0.jpg If that is closed check the long metal wand. Disconnect from the beater bar head and check the whole length of the wand and look into the beater bar head opening for something plugging it.

Aug 15, 2015 | Kenmore Vacuums

1 Answer

Have suction but belt not moving


Are you referring to the drive belt on the power head? Remove the power head and try vacuum without it, if it picks up fine, the problem in in the power head/hose assembly, could have a blockage inside the head of the hoses attached to the head. If those are all OK, look for an air leak in the system. at/around the bag, canister, loose clamps, etc.

Feb 21, 2015 | Rainbow Vacuums

1 Answer

Kenmore InteliClean 116.35923502 Two, I believe unrelated, problems. 1) The InteliClean sensor lights stay amber and red even when the machine is in the upright position and the suction line is...


I had the same problem with the amber inteliclean light continually on. I found the problem to be in the plastic housing that connects the suction hose to the back of the upright section. You have to remove three screws and gently pull the hose housing off the vacuum. Inside I found a hairy clump that was caught on the inside of the hose. The optical "dirt sensor" is just inside the fitting on the upright section. When dirt or other stuff blocks the optical path of the sensors, the amber light will illuminate. My vacuum had an uneven cut on the hose which caused a snag point for hair, dirt and debris. Once this was removed, the vacuum worked like new.

Regarding the roller, this unit has an integrated motor in the roller. I would guess that you will need to take it apart, and hopefully only clean it up. If you need bearings, that will likely be expensive.

Dec 24, 2010 | Kenmore Progressive Bagless Upright with...

2 Answers

Kenmore progressive 360 vacuum cleaner has low suction


Check the tube that leads down to the brush head for clogging as well as any motor or HEPA filters. If that still shows nothing, take the cover off the brush head (like you're changing the belt) and look for obstructions in there. Usually, if you have low suction on the accessory hose, the problem is with a motor filter, HEPA filter, or a clog where the hose goes into the unit. If you have good suction on the accessory hose but none on the floor, it's usually in the brush head (clog or broken belt) Good luck

Feb 28, 2010 | Kenmore 35912 / 35913 Progressive Upright...

1 Answer

The vacuum works on carpet mode but not floor and only when the wand is attached to the floor brush otherwise it does not work at all


Please define "works" on carpet mode" do you mean when you say it does not work at all, that it does not run, or does not have suction.
This sounds like the symptom of a clogged hose with blockage like this another vac needs to be used to draw things back out of the hose the way they went in.. Remove the hose and try dropping a penny through it . If there is an obstruction the penny will stop at that point and rattle inside the hose.

With a blockage at the hose, your power head will still lift lint and light soft dust, it will appear to have suction because the brush will sweep but the dirt will not go all the way through the hose.
Please post back to clarify if this is a vac that does not run or simpley has no suction

Nov 04, 2009 | Kenmore 25614 / 25615 Progressive Bagged...

3 Answers

The brushes will not turn when on and cannot move them even manually


Drive belt has most likely broke and jammed inside the power head. Remove the bottom plate on the power head and replace the drive belt.

Oct 07, 2009 | Kenmore 25512/ 25513 Progressive Canister...

1 Answer

Vacuum not picking up dirt


The neck in your power head is likely clogged. Disconnect from the wand and look inside. Also check the wand.Since you have suction on the bare floor the hose is likely not blocked.

Sep 11, 2009 | Kenmore 22512 Bagged Canister Vacuum

1 Answer

Wiring schmatic for kenmore canistar vacuum


Generally, there are two wires inside the unit which connect to the wiring going down the suction hose.  Since the unit is a/c...it doesn't matter which of them goes to which terminal.  The wires are switched in some cases.  Look for the open terminal.

Dec 19, 2008 | Kenmore 23612 Progressive PowerMate Bagged...

1 Answer

Kenmore whispertone model 11620412003


I am getting suction to the power mate, but the mate doesn't
work. The belt seem fine, but the light and beater doesen.t
go on. Tried the reset - no result. Thanks

Dec 29, 2007 | Vacuums

2 Answers

Lack of Suction


There are actually several possibilities.

Check to make sure that the brushroll is spinning. The brushroll is responsible for virtually all of your pickup on carpet, and is the culprit for most complaints of "lack of suction."

If the brushroll is not spinning, listen at the head to see if the motor inside the power head is active. If you can hear it running but the brushroll is not turning, you have a broken belt. If the motor in the power head is not turning at all you may have an electrical short in the hose, the wands, or the main power outlet from the body of the canister; but before you get too involved check the power head for a thermal reset button. Some of the Electrolux powerheads are equipped with these, and some are not, so check your user's manual. If there isn't one, or if it isn't tripped, you'll need to look for electrical issues.

In this particular model it is fairly common for the electrical contacts on the wands to short out, so inspect the metal contacts to look for scorching, or melting of the plastic around them. If you have access to a VOM, check for voltage at the contacts on the end of the wand, and if it is not present, check all of the contacts sequentially back to the canister body to determine which part is not passing voltage. If you have voltage all the way through the wand, you either have a loose connection inside the power head, or the power head motor has burned out. If you have power from the canister body, but not through the end of the hose, either your hose has a short in it, or the circuit board in the handle assembly that controls the power head power has shorted out.

If your brushroll is turning, then you do, in fact, have a clog somewhere inside the power head, which a visual inspection behind the brushroll and into the elbow will confirm.

Best of luck,

-R

Apr 01, 2007 | Electrolux EL7020A Oxygen 3 Ultra Canister...

Not finding what you are looking for?
Panasonic Kenmore Canister Vacuum Hose 116 Whispertone Powermate Progressive Logo

118 people viewed this question

Ask a Question

Usually answered in minutes!

Top Panasonic Vacuums Experts

Joseph Hoffmann

Level 3 Expert

1702 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18389 Answers

Kevin Getz
Kevin Getz

Level 3 Expert

1031 Answers

Are you a Panasonic Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...