Question about Audio Players & Recorders

1 Answer

I have a prosound 1600 amp and the temperature light is on permanently from power up and under no load. Any idea how to fix?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Audio Player... Master
  • 5,151 Answers

If something is getting hot you should be able to "feel" the cause of that. I would say leave it on for 10 minutes. Switch it off and look for something that is very hot to touch! Be careful don't burn your fingers! If you find something, but are not certain it's the cause. Then get a can of Servisol Freezer spray and squirt the spray on the part, while the amp is switched on. If the light goes off you might have found the part.
Electronic parts shop sell the spray, Maplin in the UK and Radio Shack in the USA and it can be found on the net too.

Posted on May 04, 2015

Ad

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
gregs_rockin
  • 274 Answers

SOURCE: ProSound 1600 Professional Power Amplifire, No Manuals, No Service, No Manufakturwebsite? Who can help???

Try on google, To do a search.There are sites where you can download manauls for no charge, I found the owners manaul for my adcom Power Amp that way. End it is over 15 years old.

Posted on Oct 22, 2012

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Prosound 1600


How can it trip if you cannot reset it?

Jun 19, 2014 | Audio Players & Recorders

1 Answer

Prosound disco lights broken


more likly lazor. and personally i would leave it be. check for proper battety supplie amps and otherwise consult the designer and request proper instructions for bulb replacements, sometimes its an art. and sometimes its a recall. i personally would do without the lazar.

Jan 04, 2014 | Cars & Trucks

1 Answer

No Sound Output from Prosound 200 amplifier


check the remote wire its that its blue and runs from the amp to your head unit

Mar 06, 2013 | Car Audio & Video

1 Answer

ProSound 1600 Professional Power Amplifire, No Manuals, No Service, No Manufakturwebsite? Who can help???


Try on google, To do a search.There are sites where you can download manauls for no charge, I found the owners manaul for my adcom Power Amp that way. End it is over 15 years old.

Oct 21, 2012 | Audio Players & Recorders

2 Answers

Prosound 1000 amp protect light


If the amp has an overload protection to it, which is sounds like it does, there should be a reset for the amp or a method of resetting the amp to working condition. Go to the manufacturers website and look for that or send them an email. They will be able to direct you.

Sep 28, 2012 | Technical Pro Integrated Amplifier 1000...

1 Answer

99 Firebird turn signal/parking light short.


So, you say that a 1600 Watt amp doesn't make your ammeter move, that is 120Amps, but your indicator lamp does ... something not right here.

Jun 04, 2017 | 1999 Pontiac Firebird

1 Answer

Lavalogic 1620 fails to come on - there is power to the machine - any idea what next to check kind regards


I also have problems with AEG Lavalogic 1600. It is caused by the control knob and the poor contacts. One service repair person fixed it and lasted 1 month. Then the problem reappeared. Now, I turn on the knob and the machine does not turn on, but I push lightly the button, not to a full path, just to cause a contact and it starts.

1051b74a-c8e6-4d65-ba66-2b299264dd2f.jpg

May 31, 2010 | AEG Lavamat Lavalogic 1600 Front Load...

1 Answer

Prosound amp is running fine but the protect light is still on


Hello martinpresto,

The most likely causes are overheating and operating the amp into too low of an impedance. Or the amp itself could be failing. If the protect comes on immediately after the amp has cooled overnight, it's probably not overheating. Too low of an impedance can be caused by a shorted voice coil.

You can check the load with a multimeter. Disconnect the speaker wires and measure their resistance with a multimeter. Since the published impedance is nominal and varies with frequency, you'll be reading the DC resistance. Some manufacturers include the figure in their "R subscript e" specification. Usually, it's a little lower than the impedance. So a 4 ohm load may read 3.2 ohms. If the DC resistance checks OK, it's probably the amp itself.

Hope this helps.

Sep 19, 2009 | Lanzar Vibe 218 Car Audio Amplifier

1 Answer

Finding the best amplifier


Hello sharky75,

That 1600 watt peak power figure for your subwoofer can't tell you what amp you need. You need to know the maximum RMS power the sub can handle. And you need to know the impedance (ohms) of the voice coil(s). JBL GT5 series subs have an RMS rating of 275 watts. The GTO series handles 300 watts. The Power series handles 400 watts. The GTi series handles 700 watts. Some are single voice coil, so the impedance is fixed. Others are dual voice coil allowing you to wire them for different impedance loads.

For maximum performance your amp should be able to provide at or near the same number of watts RMS into the lowest impedance at which the sub can be configured. For example, if your sub is the Power Series Model number P1224, it has dual 4ohm voice coils and can be wired to present either a 2ohm load (parallel) or an 8ohm load (series). You want to wire the voice coils in parallel for the 2ohm load and select an amp that outputs up to 400 watts RMS into 2ohms. The Orion Cobalt CO8001 is just such an amp. If you have one of the GTi Series subs, a better amp would be the JVC Arsenal KS-AR75 which outputs 700 watts into 2ohms.

Hope this helps.

Jul 31, 2009 | JBL Power P1022 Subwoofer - 10" Dual 2...

2 Answers

Prosound Power AMP, no sound available


hi jacko, i had the same problem with my prosound 1000.
changed all the fuses etc with no luck.
then as a last resort, i tried wiggling and lightly tapping the internal wires on the main board then all of a sudden there was sound!
i know next to nothing about electronics but i am thinking that i may have reset some kind of power protection cut off that may have been sticking, but what do i know?.
Please, like everything else electrical, if you do try this, make sure power is off first.

hope this helps, its worth a try.

paul

Jan 22, 2008 | Audio Players & Recorders

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

303 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

5151 Answers

The Knight
The Knight

Level 3 Expert

74377 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...