Question about ARC Car Audio & Video

Open Question

I have two 15 inches 2ohms Arc Audio subs hook up to aAudiofonics Adf-2847 3000watt amp but my amp started going into protection mode... What would cause this

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
The Marv
  • 72 Answers

SOURCE: Amp goes into protect mode.

I would definately suspect wiring. If you can use a volt meter. Put it on the b+ to ground and see what the reading is should be 12+ then try the ground to remote wire should be 12+. If it drops below 12 volts when car starts. Recheck wires for loose connection. Also double check the wire you have the remote wire connected to. You might even want to disconnect from the amplifier and use a jumper wire from the positive terminal on the amp to remote on the amplifier and see if it stays on then. If it stays on you will have to find the loose connection or find a different wire to get remote power.

Posted on Feb 05, 2007

Ad
osborne382
  • 306 Answers

SOURCE: Amp stuck in protection mode.

check to make sure your ground wire is attached to a clean metal surface no more then 18" away from amp. check all wires to ensure none are touching other terminal. all else fails remove one sub and see how it play, if its works great switch subs. could be a defective amp. if it is the amp and you payed for it with a credit card or bank card you can do a charge back from the bank to get your money back if the store wont replace it. thell the bank "you want to do a charge back cause it wasnt as discribed).

Posted on Nov 12, 2007

  • 63 Answers

SOURCE: LIghtning Audio B300.4 Protect Light

protect mode should be reset if the negative of your amp is disconnected then reconnectewd. if it doesnt help, move your ground to a different location. if THIS doesnt help, consider a repair or a new amplifier.

Posted on Jul 13, 2008

  • 631 Answers

SOURCE: mmat amp 1200 watt

If the amp is in protect mode, it probably has shorted output transistors.

What model amp is it?

Posted on Aug 20, 2008

  • 631 Answers

SOURCE: car audio amp in protection mode

If you power up the amp with the RCAs plugged in, does it go into protection mode.

If you power up the amp with the RCAs plugged in, does the woofer pop?

Posted on Oct 26, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

On a lanzar 535n 5 channel 3200 watt amp what is the best way to hook up 2 lanzar max 12 inch duel voice coil subwoofers


If your amp allows it hook the the sub's to the first two channels but bridge it and only run it on 2ohms so you don't blow your sub's

May 29, 2015 | Lanzar Car Audio & Video

1 Answer

I have 2 12 inch kicker rt dual 2 ohm subs. On a kicker cx1200.1 i want to kno how to hook it up to 2ohm to the amp. And if i can add another 10 inch kicker rt 2ohm sub in the future.


Do to the impedance Of your sub u can't run it @2ohms its going to either be @1ohm or 4ohms and your amp isn't 1ohm stable and u will risk damaging your amp. So your only option is to run it @4ohms and on a good note your sub is 100-600 watts RMS and your amp will push 400-500 watts RMS @4ohms. Now if you want to run 2 sub's in the future That amp will work perfect because it pushes 1,200watts RMS @2ohms and to wire your 2 sub's @1ohm just follow the steps in the image below. Hope this helped.25345194-v0hbouy2nvquqteoroa5j5rq-3-0.png

Dec 30, 2014 | Car Audio & Video

2 Answers

XA10002 dual channell amp pushing a single 12 inch JL Audio sub and continues to go into protection mode. All setting are turned to the lowest possible and remote wire, power wire, and ground wire are all...


Make sure you are wiring the sub to the correct ohm's. Some amps have a protective feature that will send them into protect mode if they do not since the right ohm load. If the sub is wired correctly double check your ground wire on the amplifier, and if that if also fine then your amp will need serviced.

May 31, 2011 | xXx XA10002 Car Amp

1 Answer

I hooked up my two 10 inch JL Audio W3v2 2 ohms to a mono JL Audio 500.1 amp and the subs will not work. I have the subs wired in a series. I then hooked them up to my friends amp and the subs worked. Any...


try one at a time. if they work then try hooking them up differently. if none work, then check to see that your amp is not in protect mode. if amp is ok, then check to make sure you have your rcas connected to your amp. in other words, re-check all your wiring. if still nothing, try your amp on your friends car and vise versa.

Apr 01, 2010 | Jl Audio 10W3v2 Car Subwoofer

2 Answers

Legacy audio LA590 car audio amp protecet mode


Is that on all the time or are you saying the light is on? If that light is always on that just means it's protecting your amp. If it's off and not playing bass then your in trouble

Mar 01, 2010 | Legacy Audio American Legacy II LA590 Car...

2 Answers

Protection light comes on


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. Dou .A thumbs up would be greatly appreciated if this answer is helpful to you. protection-light-comes-lv2kkrmxrai4iihdvw4m3np2-2-0.jpg http://www.nitrobmw.com/

Jun 14, 2009 | Nitro BMW-482 Car Audio Amplifier

2 Answers

I need to know how to bridge a a 4 ohm 15 inch sub down to1or2ohm


Hello solo7908,

With a single 4ohm DVC sub there are only two possible wiring solutions, parallel the voice coils for a final 2ohm load or series the voice coils for an 8ohm load. In your case, you want to wire them in parallel, both positives and both negatives connected to the amp terminals.

Here are the diagrams: (-) to (-) and then to the amp - (+) to (+) and then to the amp. Impedance = 2ohms.

Hope this helps.

Jun 06, 2009 | Kicker CompVR 12" Subwoofers/Enclosure...

1 Answer

Kole amp in protect mode?


Are you setting the bridge switch for both left and right or are you trying to run both subs off of one set of terminals? If you running the subs off one set of terminals you are effectively running the amp below 2ohms and thus the amp is not 2ohm stable and you will destroy it.

Some amps actually all ready run a bridged output for left/right operation, this could also be the reason why the protection circuit is kicking on.

Either way it's a component mismatch and you either need a stronger amp or different subwoofer setup.

Mar 09, 2009 | Kole audio Nitric XP2-2000 Car Amp

1 Answer

Car audio amp in protection mode


If you power up the amp with the RCAs plugged in, does it go into protection mode.

If you power up the amp with the RCAs plugged in, does the woofer pop?

Oct 26, 2008 | Pyle PLAD413 Car Audio Amplifier

1 Answer

My Amp


sounds like the sub that throws it into protect mode is cross wired pull sub out and make sure they are wired right make sure ground from sub goes to ground on box and do same for power wire

Jun 11, 2008 | Sony Xplod Car Audio Amplifier XM-DS1300P5...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

40 people viewed this question

Ask a Question

Usually answered in minutes!

Top ARC Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4875 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

76848 Answers

Are you an ARC Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...